aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiles Alan <m@milesalan.com>2020-05-30 10:22:38 -0500
committerKevin Daudt <kdaudt@alpinelinux.org>2020-05-30 17:25:59 +0000
commit06e66cc2c46c855e9dce100b76dcbb495f9eccf9 (patch)
treed91df1757a0edc9cde0105290b1131e3bcd0cfa1
parent78b618a93b6c6364b2b6ea4d1e85addcea4d9bc9 (diff)
downloadalpine_aports-06e66cc2c46c855e9dce100b76dcbb495f9eccf9.tar.bz2
alpine_aports-06e66cc2c46c855e9dce100b76dcbb495f9eccf9.tar.xz
alpine_aports-06e66cc2c46c855e9dce100b76dcbb495f9eccf9.zip
testing/lf: new aport
https://github.com/gokcehan/lf Terminal filemanager written in Go with vim-style keybindings
-rw-r--r--testing/lf/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/lf/APKBUILD b/testing/lf/APKBUILD
new file mode 100644
index 0000000000..7508b54059
--- /dev/null
+++ b/testing/lf/APKBUILD
@@ -0,0 +1,37 @@
1# Maintainer: Miles Alan <m@milesalan.com>
2pkgname=lf
3pkgver=14
4pkgrel=0
5pkgdesc="Terminal filemanager written in Go with vim-style keybindings"
6url="https://github.com/gokcehan/lf"
7arch="all"
8license="MIT"
9makedepends="go"
10subpackages="$pkgname-doc"
11source="$pkgname-$pkgver.tar.gz::https://github.com/gokcehan/lf/archive/r$pkgver.tar.gz"
12options="chmod-clean net"
13
14export GOPATH="$srcdir"
15export GOCACHE="$srcdir"
16export GOTMPDIR="$srcdir"
17
18prepare() {
19 mkdir -p ${builddir%/*}
20 mv $srcdir/$pkgname-r$pkgver "$builddir"/
21 default_prepare
22}
23
24build() {
25 go build -v -o bin/$pkgname
26}
27
28check() {
29 go test ./...
30}
31
32package() {
33 install -Dm755 "$builddir"/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
34 install -Dm644 lf.1 "$pkgdir"/usr/share/man/man1/lf.1
35}
36
37sha512sums="cd2e268d551a0a83a32563424675455288e09b28d60940143eff4d24cf5b98ad0d7bd9ab100ea5a456e37460c318001ad5b444d252a986e9ddcfff274adf7720 lf-14.tar.gz"