aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-06-05 14:28:29 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-06-05 14:29:49 +0000
commit3d1b019a6adaf25f92a2477d3fb412855f692e64 (patch)
tree2a6a16f5557dc03e505821ff4d50636685bff28c
parentb3e558c7d2c1ea31358f41069e89944bd6ec68fb (diff)
downloadalpine_aports-3d1b019a6adaf25f92a2477d3fb412855f692e64.tar.bz2
alpine_aports-3d1b019a6adaf25f92a2477d3fb412855f692e64.tar.xz
alpine_aports-3d1b019a6adaf25f92a2477d3fb412855f692e64.zip
community/py3-sentry-sdk: new aport. New dep of gns3-server
-rw-r--r--community/py3-sentry-sdk/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-sentry-sdk/APKBUILD b/community/py3-sentry-sdk/APKBUILD
new file mode 100644
index 0000000000..92e4a36f39
--- /dev/null
+++ b/community/py3-sentry-sdk/APKBUILD
@@ -0,0 +1,28 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname=py3-sentry-sdk
4pkgver=0.14.4
5pkgrel=0
6pkgdesc="The new Python SDK for Sentry.io"
7url="https://sentry.io/for/python/"
8arch="noarch"
9license="BSD-2-Clause"
10options="!check" # test depends on sanic that is not avail atm
11depends="python3 py3-certifi py3-urllib3"
12makedepends="py3-setuptools"
13source="$pkgname-$pkgver.tar.gz::https://github.com/getsentry/sentry-python/archive/$pkgver.tar.gz"
14builddir="$srcdir"/sentry-python-$pkgver
15
16build() {
17 python3 setup.py build
18}
19
20check() {
21 python3 setup.py test
22}
23
24package() {
25 python3 setup.py install --prefix=/usr --root="$pkgdir"
26}
27
28sha512sums="539f337d7933f9c859fc9314edf2be5643f0acd6823fcff64aad5c00cd8c55743d2f6438a1b3352f179b0d84351d435c2db27516618a3046bc400e7dbeeecff0 py3-sentry-sdk-0.14.4.tar.gz"