aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2020-05-15 15:45:20 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-06-05 14:21:28 +0000
commit556709557784dff0bdb1f89dfeb4614d7c5c07b4 (patch)
tree8e08bbc6ee23a3d83e649efed83ff7a4f25f6229
parent12cbb6719eb6dca26caf25f41e68885230a1d203 (diff)
downloadalpine_aports-556709557784dff0bdb1f89dfeb4614d7c5c07b4.tar.bz2
alpine_aports-556709557784dff0bdb1f89dfeb4614d7c5c07b4.tar.xz
alpine_aports-556709557784dff0bdb1f89dfeb4614d7c5c07b4.zip
testing/libfyaml: new aport
https://github.com/pantoniou/libfyaml Fully feature complete YAML parser and emitter.
-rw-r--r--testing/libfyaml/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/libfyaml/APKBUILD b/testing/libfyaml/APKBUILD
new file mode 100644
index 0000000000..462449e1c2
--- /dev/null
+++ b/testing/libfyaml/APKBUILD
@@ -0,0 +1,43 @@
1# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
2# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
3pkgname=libfyaml
4pkgver=0.5.7
5pkgrel=0
6pkgdesc="Fully feature complete YAML parser and emitter"
7url="https://github.com/pantoniou/libfyaml"
8arch="all"
9license="MIT"
10depends="libltdl"
11checkdepends="check git"
12makedepends="autoconf automake bash libtool"
13subpackages="$pkgname-dev"
14source="https://github.com/pantoniou/libfyaml/releases/download/v$pkgver/libfyaml-$pkgver.tar.gz"
15options="!check" # tests failing, (See: https://github.com/pantoniou/libfyaml/issues/20)
16
17prepare() {
18 default_prepare
19 ./bootstrap.sh
20}
21
22build() {
23 ./configure \
24 --build=$CBUILD \
25 --host=$CHOST \
26 --prefix=/usr \
27 --libdir=/usr/lib \
28 --sysconfdir=/etc \
29 --mandir=/usr/share/man \
30 --infodir=/usr/share/info \
31 --disable-static
32 make
33}
34
35package() {
36 make DESTDIR="$pkgdir" install
37}
38
39check() {
40 make check
41}
42
43sha512sums="ccdd47cdc1703d18a3aee362b3acbc6a3f98fbb65032544231a05eb944a8d9a6e160b6411a2db0f50e4f70f44e4aa368f1df15a7980ce5480be59dd99e9c58b8 libfyaml-0.5.7.tar.gz"