aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2020-06-04 18:15:05 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-06-04 20:14:26 +0200
commit5b17b206ddffa8e619b03dc101bbf2be47292082 (patch)
treedf5c2504afd4b3b6cadc7502d70c11a5c2c20fa5
parent032072893c88e7ae2c9182cebb3796856d5a39fa (diff)
downloadalpine_aports-5b17b206ddffa8e619b03dc101bbf2be47292082.tar.bz2
alpine_aports-5b17b206ddffa8e619b03dc101bbf2be47292082.tar.xz
alpine_aports-5b17b206ddffa8e619b03dc101bbf2be47292082.zip
community/py3-dotenv: new aport
-rw-r--r--community/py3-dotenv/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-dotenv/APKBUILD b/community/py3-dotenv/APKBUILD
new file mode 100644
index 0000000000..a8a5b63275
--- /dev/null
+++ b/community/py3-dotenv/APKBUILD
@@ -0,0 +1,28 @@
1# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
2# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
3pkgname=py3-dotenv
4_pkgname=python-dotenv
5pkgver=0.13.0
6pkgrel=0
7pkgdesc="Reads the key-value pair from .env file and adds them to environment variable."
8url="https://github.com/theskumar/python-dotenv"
9arch="noarch"
10license="BSD"
11depends="python3"
12makedepends="py3-setuptools"
13source="$pkgname-$pkgver.tar.gz::https://github.com/theskumar/$_pkgname/archive/v$pkgver.tar.gz"
14builddir="$srcdir/$_pkgname-$pkgver"
15
16build() {
17 python3 setup.py build
18}
19
20check() {
21 python3 setup.py check
22}
23
24package() {
25 python3 setup.py install --prefix=/usr --root="$pkgdir"
26}
27
28sha512sums="da1fc6f513ab7492a73bf6c4548ccc2d804c82e08d44e719d37cd4fc24078f7864f17ca5413156369a804deaaf76be0b579c31a4827db4756279b5b0627cea9d py3-dotenv-0.13.0.tar.gz"