aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-06-04 12:08:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-06-05 00:38:46 +0000
commit6d263bc5d55f5a4e25318c7b58aa55b652f24d16 (patch)
treedb6c2e69700092d3b429b3f006547b40d7a8bde5
parent38aee84eebed24d11119de050dc8c386ef9556f1 (diff)
downloadalpine_aports-6d263bc5d55f5a4e25318c7b58aa55b652f24d16.tar.bz2
alpine_aports-6d263bc5d55f5a4e25318c7b58aa55b652f24d16.tar.xz
alpine_aports-6d263bc5d55f5a4e25318c7b58aa55b652f24d16.zip
community/tpm2-tss: move solinks required at run-time back
See !8841
-rw-r--r--community/tpm2-tss/APKBUILD17
1 files changed, 16 insertions, 1 deletions
diff --git a/community/tpm2-tss/APKBUILD b/community/tpm2-tss/APKBUILD
index f11fee4fa8..b32ff279a4 100644
--- a/community/tpm2-tss/APKBUILD
+++ b/community/tpm2-tss/APKBUILD
@@ -3,7 +3,7 @@
3# Maintainer: Alexander Sack <asac@pantacor.com> 3# Maintainer: Alexander Sack <asac@pantacor.com>
4pkgname=tpm2-tss 4pkgname=tpm2-tss
5pkgver=2.4.1 5pkgver=2.4.1
6pkgrel=0 6pkgrel=1
7pkgdesc="TPM 2.0 TSS" 7pkgdesc="TPM 2.0 TSS"
8url="https://github.com/tpm2-software/tpm2-tss/" 8url="https://github.com/tpm2-software/tpm2-tss/"
9arch="all" 9arch="all"
@@ -55,6 +55,21 @@ package() {
55 rm -rf "$pkgdir"/etc/sysusers.d 55 rm -rf "$pkgdir"/etc/sysusers.d
56} 56}
57 57
58dev() {
59 depends_dev="
60 $pkgname-tcti-device=$pkgver-r$pkgrel
61 $pkgname-tcti-mssim=$pkgver-r$pkgrel
62 "
63
64 default_dev
65
66 # Unfortunately these libraries need their solink to be in the subpackage
67 # and not in the -dev package, so add the dependency to depends_dev and
68 # move the library back
69 mv "$subpkgdir"/usr/lib/libtss2-tcti-device.so "$pkgdir"/usr/lib
70 mv "$subpkgdir"/usr/lib/libtss2-tcti-mssim.so "$pkgdir"/usr/lib
71}
72
58mu() { 73mu() {
59 pkgdesc="TPM 2.0 Marshaling libraries" 74 pkgdesc="TPM 2.0 Marshaling libraries"
60 mkdir -p "$subpkgdir"/usr/lib 75 mkdir -p "$subpkgdir"/usr/lib