aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-06-04 15:13:42 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-06-04 13:58:44 +0000
commitba01e78d21f3898540985ef84c2f3dc2fd38de77 (patch)
tree52f37be893036d0913ebfadbd90417bc6a75dd7b
parenteb57e5df2213ff0fa13783793fe765241839fd24 (diff)
downloadalpine_aports-ba01e78d21f3898540985ef84c2f3dc2fd38de77.tar.bz2
alpine_aports-ba01e78d21f3898540985ef84c2f3dc2fd38de77.tar.xz
alpine_aports-ba01e78d21f3898540985ef84c2f3dc2fd38de77.zip
community/cogl: upgrade to 1.22.8
-rw-r--r--community/cogl/17.patch62
-rw-r--r--community/cogl/APKBUILD8
2 files changed, 3 insertions, 67 deletions
diff --git a/community/cogl/17.patch b/community/cogl/17.patch
deleted file mode 100644
index e683ae442f..0000000000
--- a/community/cogl/17.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1Upstream: Yes, https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/17
2
3From 9c4764224aded552fb855b1c2b85b26d2b894adf Mon Sep 17 00:00:00 2001
4From: Alexander Tsoy <alexander@tsoy.me>
5Date: Tue, 29 Oct 2019 18:17:51 +0300
6Subject: [PATCH] Fix building against libglvnd-provided EGL headers
7
8Add missing EGL/eglmesaext.h include. When building against mesa-provided
9headers, this header is included indirectly via EGL/eglext.h.
10
11Also fix typo COGL_EGL_INCLUDE -> COGL_EGL_INCLUDES
12---
13 configure.ac | 16 ++++++++++++++--
14 1 file changed, 14 insertions(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index da188edd..b0b0c94d 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -670,10 +670,15 @@ AS_IF([test "x$enable_gles1" = "xyes"],
21 AC_SUBST([COGL_EGL_INCLUDES])
22
23 AC_CHECK_HEADERS([EGL/eglext.h],
24- [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDE
25+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
26 #include <EGL/eglext.h>"],
27 [],
28 [$COGL_EGL_INCLUDES])
29+ AC_CHECK_HEADERS([EGL/eglmesaext.h],
30+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
31+#include <EGL/eglmesaext.h>"],
32+ [],
33+ [$COGL_EGL_INCLUDES])
34
35 # Check for a GLES 1.x Common Profile library with/without EGL.
36 #
37@@ -1178,6 +1183,12 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
38 [],
39 [AC_MSG_ERROR([Unable to locate required EGL headers])],
40 [#include <EGL/egl.h>])
41+ AC_CHECK_HEADERS(
42+ [EGL/eglmesaext.h],
43+ [],
44+ [AC_MSG_ERROR([Unable to locate required EGL headers])],
45+ [#include <EGL/egl.h>
46+#include <EGL/eglext.h>])
47
48 AC_CHECK_LIB(EGL, [eglInitialize],
49 [COGL_EXTRA_LDFLAGS="$COGL_EXTRA_LDFLAGS -lEGL"],
50@@ -1188,7 +1199,8 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
51 )
52
53 COGL_EGL_INCLUDES="#include <EGL/egl.h>
54-#include <EGL/eglext.h>"
55+#include <EGL/eglext.h>
56+#include <EGL/eglmesaext.h>"
57 AC_SUBST([COGL_EGL_INCLUDES])
58 ])
59
60--
612.24.1
62
diff --git a/community/cogl/APKBUILD b/community/cogl/APKBUILD
index 8245fe3385..93c67546c6 100644
--- a/community/cogl/APKBUILD
+++ b/community/cogl/APKBUILD
@@ -3,7 +3,7 @@
3# Contributor: Natanael Copa <ncopa@alpinelinux.org> 3# Contributor: Natanael Copa <ncopa@alpinelinux.org>
4# Maintainer: Rasmus Thomsen <oss@cogitri.dev> 4# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
5pkgname=cogl 5pkgname=cogl
6pkgver=1.22.6 6pkgver=1.22.8
7pkgrel=0 7pkgrel=0
8pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer" 8pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer"
9options="!check" # All tests fail for unknown reasons 9options="!check" # All tests fail for unknown reasons
@@ -28,8 +28,7 @@ makedepends="
28# gst-plugins-base-dev 28# gst-plugins-base-dev
29# " 29# "
30subpackages="$pkgname-dev $pkgname-lang" 30subpackages="$pkgname-dev $pkgname-lang"
31source="https://download.gnome.org/sources/cogl/${pkgver%.*}/cogl-$pkgver.tar.xz 31source="https://download.gnome.org/sources/cogl/${pkgver%.*}/cogl-$pkgver.tar.xz"
32 17.patch"
33 32
34prepare() { 33prepare() {
35 default_prepare 34 default_prepare
@@ -62,5 +61,4 @@ package() {
62 make DESTDIR="$pkgdir" install 61 make DESTDIR="$pkgdir" install
63} 62}
64 63
65sha512sums="b3475fa4fff3b6725f643b0d17d2de242fce1503cd83bd18031d98495501917bf5173152fb1aba7f2614fcf6553029fbb6f26bda5a497f5f12e2849ed301a483 cogl-1.22.6.tar.xz 64sha512sums="702d5b1b22dc34bffaa82c9c57021caf036ee3a13fa7ca24a90cca1ebc0f8b7a86070cc1fe5125757132b02774fa874bb55675c96d1ccbc233fac0e6132da65f cogl-1.22.8.tar.xz"
665320cfe16eaa419aac155d86f77826076b3dfe3a018d7173220c35ba2f1a4f15254bab7336229349aa25e708f0792132572d166de5745992a4e98f662b6df0fc 17.patch"