aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-06-04 14:09:38 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-06-04 14:00:52 +0000
commitcf98f54dded9cfc9f606461e733c452f094757bd (patch)
tree5029499989bae9175875a3d053cf658160cb1c4d
parent0acb8352babbde99a25e6b910576355c5b89a486 (diff)
downloadalpine_aports-cf98f54dded9cfc9f606461e733c452f094757bd.tar.bz2
alpine_aports-cf98f54dded9cfc9f606461e733c452f094757bd.tar.xz
alpine_aports-cf98f54dded9cfc9f606461e733c452f094757bd.zip
testing/caps: new aport
http://quitte.de/dsp/caps.html the C* Audio Plugin Suite
-rw-r--r--testing/caps/APKBUILD24
-rw-r--r--testing/caps/patch-basics.h.patch36
2 files changed, 60 insertions, 0 deletions
diff --git a/testing/caps/APKBUILD b/testing/caps/APKBUILD
new file mode 100644
index 0000000000..c9ec49561a
--- /dev/null
+++ b/testing/caps/APKBUILD
@@ -0,0 +1,24 @@
1# Contributor: David Demelier <markand@malikania.fr>
2# Maintainer: David Demelier <markand@malikania.fr>
3pkgname=caps
4pkgver=0.9.26
5pkgrel=0
6pkgdesc="the C* Audio Plugin Suite"
7url="http://quitte.de/dsp/caps.html"
8arch="all"
9license="GPL-3.0-only"
10source="http://quitte.de/dsp/caps_$pkgver.tar.bz2
11 patch-basics.h.patch"
12options="!check" # No tests
13
14build() {
15 make
16}
17
18
19package() {
20 make install PREFIX=/usr DESTDIR="$pkgdir"
21}
22
23sha512sums="ce9a7219ef0c6c33a5debb407e9b6ea7432c3f50ab32c1915cf91c40cda541a812da887bf57ee536d653195158939889c4baf5fcbe3ded551abc676517e1da7a caps_0.9.26.tar.bz2
24fdf87cccfbde23e0959637e415e28b9b4e29b83fc0896506490e7e005a70bea04c073064c8b930d6050ed3f1db5b0f639425908b1e35e1307ca36339349cb435 patch-basics.h.patch"
diff --git a/testing/caps/patch-basics.h.patch b/testing/caps/patch-basics.h.patch
new file mode 100644
index 0000000000..221ed3ee47
--- /dev/null
+++ b/testing/caps/patch-basics.h.patch
@@ -0,0 +1,36 @@
1Use standard integer types instead.
2
3Upstream: proposed.
4--- a/basics.h 2020-06-04 14:05:29.657008378 +0200
5+++ b/basics.h 2020-06-04 14:05:44.430412859 +0200
6@@ -38,6 +38,7 @@
7 #define _ISOC99_SOURCE 1
8 #define _ISOC9X_SOURCE 1
9
10+#include <stdint.h>
11 #include <stdlib.h>
12 #include <string.h>
13
14@@ -49,14 +50,14 @@
15
16 #include "ladspa.h"
17
18-typedef __int8_t int8;
19-typedef __uint8_t uint8;
20-typedef __int16_t int16;
21-typedef __uint16_t uint16;
22-typedef __int32_t int32;
23-typedef __uint32_t uint32;
24-typedef __int64_t int64;
25-typedef __uint64_t uint64;
26+typedef int8_t int8;
27+typedef uint8_t uint8;
28+typedef int16_t int16;
29+typedef uint16_t uint16;
30+typedef int32_t int32;
31+typedef uint32_t uint32;
32+typedef int64_t int64;
33+typedef uint64_t uint64;
34
35 #define MIN_GAIN 1e-6 /* -120 dB */
36 /* smallest non-denormal 32 bit IEEE float is 1.18e-38 */