aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-06-05 15:26:43 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-05 13:44:18 +0000
commite1fd225efdf87ad86a33f4f60735da9fe3ed73df (patch)
tree942f6969b4c6fa9e66beb0f2ccac252711f1f949
parent53f0b4a0466adeeaae67d76cfeb20eda1d97b18f (diff)
downloadalpine_aports-e1fd225efdf87ad86a33f4f60735da9fe3ed73df.tar.bz2
alpine_aports-e1fd225efdf87ad86a33f4f60735da9fe3ed73df.tar.xz
alpine_aports-e1fd225efdf87ad86a33f4f60735da9fe3ed73df.zip
testing/amsynth: new aport
https://amsynth.github.io easy-to-use software synth with a classic subtractive synthesizer topology
-rw-r--r--testing/amsynth/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/amsynth/APKBUILD b/testing/amsynth/APKBUILD
new file mode 100644
index 0000000000..4b52732924
--- /dev/null
+++ b/testing/amsynth/APKBUILD
@@ -0,0 +1,40 @@
1# Contributor: David Demelier <markand@malikania.fr>
2# Maintainer: David Demelier <markand@malikania.fr>
3pkgname=amsynth
4pkgver=1.10.0
5pkgrel=0
6pkgdesc="easy-to-use software synth with a classic subtractive synthesizer topology"
7url="https://amsynth.github.io"
8arch="all"
9license="GPL-2.0-only"
10depends="libintl"
11makedepends="alsa-lib-dev gettext-dev gtk+2.0-dev jack-dev lv2-dev"
12subpackages="$pkgname-lang $pkgname-lv2"
13source="https://github.com/amsynth/amsynth/releases/download/release-1.10.0/amsynth-$pkgver.tar.gz"
14
15build() {
16 LDFLAGS="-lintl $LDFLAGS"
17 ./configure \
18 --build=$CBUILD \
19 --host=$CHOST \
20 --prefix=/usr \
21 --sysconfdir=/etc \
22 --mandir=/usr/share/man \
23 --localstatedir=/var
24 make
25}
26
27check() {
28 make check
29}
30
31package() {
32 make DESTDIR="$pkgdir" install
33}
34
35lv2() {
36 pkgdesc="amsynth (LV2 plugins)"
37 amove usr/lib/lv2/*
38}
39
40sha512sums="36252256f436f986336375f75f18a9381ab9616570d1a52ae575865b7c1bb9dec231e11358775055a9ef2348e5c8a3e059419a7fd6f8e27f6e269a345df4f83f amsynth-1.10.0.tar.gz"