aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Crute <mike@crute.us>2020-06-01 02:51:52 +0000
committerMike Crute <mike@crute.us>2020-06-02 18:37:05 +0000
commit526f7033df73d5b49d625df0369b502d7c2ff9b0 (patch)
treea2b5fe102d66ec6886d31cd4b2bdb3db0e5a1c93
parenta0c1b084c3f36a90a6ef89c78eb95aaccee1c31b (diff)
downloadalpine_aports-526f7033df73d5b49d625df0369b502d7c2ff9b0.tar.bz2
alpine_aports-526f7033df73d5b49d625df0369b502d7c2ff9b0.tar.xz
alpine_aports-526f7033df73d5b49d625df0369b502d7c2ff9b0.zip
main/util-linux: build runuser
-rw-r--r--main/util-linux/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index 6ae351daa6..49e930c229 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -9,14 +9,14 @@ case $pkgver in
9 *.*) _v=$pkgver;; 9 *.*) _v=$pkgver;;
10esac 10esac
11 11
12pkgrel=0 12pkgrel=1
13pkgdesc="Random collection of Linux utilities" 13pkgdesc="Random collection of Linux utilities"
14url="https://git.kernel.org/cgit/utils/util-linux/util-linux.git" 14url="https://git.kernel.org/cgit/utils/util-linux/util-linux.git"
15arch="all" 15arch="all"
16license="GPL-2.0 GPL-2.0-or-later LGPL-2.0-or-later BSD Public-Domain" 16license="GPL-2.0 GPL-2.0-or-later LGPL-2.0-or-later BSD Public-Domain"
17depends="blkid setpriv findmnt mcookie hexdump lsblk sfdisk cfdisk" 17depends="blkid setpriv findmnt mcookie hexdump lsblk sfdisk cfdisk"
18makedepends_build="autoconf automake libtool" 18makedepends_build="autoconf automake libtool"
19makedepends_host="zlib-dev ncurses-dev linux-headers libcap-ng-dev" 19makedepends_host="zlib-dev ncurses-dev linux-headers libcap-ng-dev linux-pam-dev"
20options="suid" 20options="suid"
21source="https://www.kernel.org/pub/linux/utils/util-linux/v$_v/util-linux-$pkgver.tar.xz 21source="https://www.kernel.org/pub/linux/utils/util-linux/v$_v/util-linux-$pkgver.tar.xz
22 ttydefaults.h 22 ttydefaults.h
@@ -36,6 +36,7 @@ subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion:bashcomp:noarch
36 mcookie:_mv_bin 36 mcookie:_mv_bin
37 setpriv:_mv_bin 37 setpriv:_mv_bin
38 sfdisk:_mv_bin 38 sfdisk:_mv_bin
39 runuser:_mv_bin
39 " 40 "
40if [ -z "$BOOTSTRAP" ]; then 41if [ -z "$BOOTSTRAP" ]; then
41 makedepends_host="$makedepends_host python3-dev" 42 makedepends_host="$makedepends_host python3-dev"
@@ -60,6 +61,8 @@ build() {
60 --host=$CHOST \ 61 --host=$CHOST \
61 --with-sysroot=$CBUILDROOT \ 62 --with-sysroot=$CBUILDROOT \
62 --prefix=/usr \ 63 --prefix=/usr \
64 --enable-runuser \
65 --disable-chfn-chsh \
63 --enable-raw \ 66 --enable-raw \
64 --disable-uuidd \ 67 --disable-uuidd \
65 --disable-nls \ 68 --disable-nls \
@@ -88,6 +91,7 @@ _mv_bin() {
88 sfdisk) pkgdesc="Partition table manipulator from util-linux";; 91 sfdisk) pkgdesc="Partition table manipulator from util-linux";;
89 cfdisk) pkgdesc="Curses based partition table manipulator from util-linux";; 92 cfdisk) pkgdesc="Curses based partition table manipulator from util-linux";;
90 setpriv) pkgdesc="Run a program with different Linux privilege settings";; 93 setpriv) pkgdesc="Run a program with different Linux privilege settings";;
94 runuser) pkgdesc="Run a program with substitute user and group ID";;
91 *);; 95 *);;
92 esac 96 esac
93 local _path; for _path in usr/bin usr/sbin bin sbin; do 97 local _path; for _path in usr/bin usr/sbin bin sbin; do