aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-06-01 00:29:10 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-06-01 00:29:10 +0200
commita0c1b084c3f36a90a6ef89c78eb95aaccee1c31b (patch)
treee4f375387e4d2a870097e97bd78e9ae2dabe1833
parent3577586be8fc09b3d1d46c018fc4c5116ce9a497 (diff)
downloadalpine_aports-a0c1b084c3f36a90a6ef89c78eb95aaccee1c31b.tar.bz2
alpine_aports-a0c1b084c3f36a90a6ef89c78eb95aaccee1c31b.tar.xz
alpine_aports-a0c1b084c3f36a90a6ef89c78eb95aaccee1c31b.zip
community/stlink: upgrade to 1.6.1
See also: https://github.com/stlink-org/stlink/pull/970
-rw-r--r--community/stlink/0001-doc-man-Fix-installation-directory.patch24
-rw-r--r--community/stlink/0002-CMakeLists.txt-Install-pkgconfig-files-again.patch22
-rw-r--r--community/stlink/APKBUILD13
3 files changed, 55 insertions, 4 deletions
diff --git a/community/stlink/0001-doc-man-Fix-installation-directory.patch b/community/stlink/0001-doc-man-Fix-installation-directory.patch
new file mode 100644
index 0000000000..97ee8524da
--- /dev/null
+++ b/community/stlink/0001-doc-man-Fix-installation-directory.patch
@@ -0,0 +1,24 @@
1From 2016590502558caa98c21abad2ce83c5f4804a98 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
3Date: Mon, 1 Jun 2020 00:20:26 +0200
4Subject: [PATCH] doc/man: Fix installation directory
5
6On Unix-like operating systems man pages are commonly installed to
7`/usr/share/man` not `/usr/share/stlink/man`.
8---
9 doc/man/CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/doc/man/CMakeLists.txt b/doc/man/CMakeLists.txt
13index 23da9e1..9b3c507 100644
14--- a/doc/man/CMakeLists.txt
15+++ b/doc/man/CMakeLists.txt
16@@ -30,7 +30,7 @@ foreach (manpage ${MANPAGES})
17 endif ()
18
19 if (f AND NOT WIN32)
20- install(FILES ${f} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/${PROJECT_NAME}/man/man1)
21+ install(FILES ${f} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/man/man1)
22 unset(f)
23 endif ()
24 endforeach ()
diff --git a/community/stlink/0002-CMakeLists.txt-Install-pkgconfig-files-again.patch b/community/stlink/0002-CMakeLists.txt-Install-pkgconfig-files-again.patch
new file mode 100644
index 0000000000..d39a584be8
--- /dev/null
+++ b/community/stlink/0002-CMakeLists.txt-Install-pkgconfig-files-again.patch
@@ -0,0 +1,22 @@
1From 59d0d1194d47f61db538eb6a1f451673355460a4 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
3Date: Mon, 1 Jun 2020 00:27:18 +0200
4Subject: [PATCH] CMakeLists.txt: Install pkgconfig files again
5
6---
7 CMakeLists.txt | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/CMakeLists.txt b/CMakeLists.txt
11index 8628277..60f9087 100644
12--- a/CMakeLists.txt
13+++ b/CMakeLists.txt
14@@ -49,7 +49,7 @@ find_package(libusb REQUIRED)
15
16 ## Package configuration (pkg-config) on unix-based systems
17 if (NOT WIN32 AND NOT CMAKE_CROSSCOMPILING)
18- #add_subdirectory(cmake/pkgconfig)
19+ add_subdirectory(cmake/pkgconfig)
20 find_package(PkgConfig)
21 pkg_check_modules(GTK3 gtk+-3.0)
22 endif ()
diff --git a/community/stlink/APKBUILD b/community/stlink/APKBUILD
index b4bae7cbdd..e8fd51568f 100644
--- a/community/stlink/APKBUILD
+++ b/community/stlink/APKBUILD
@@ -1,8 +1,8 @@
1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net> 1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
2# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net> 2# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
3pkgname=stlink 3pkgname=stlink
4pkgver=1.6.0 4pkgver=1.6.1
5pkgrel=2 5pkgrel=0
6pkgdesc="STM32 discovery line linux programmer" 6pkgdesc="STM32 discovery line linux programmer"
7url="https://github.com/texane/stlink" 7url="https://github.com/texane/stlink"
8arch="all" 8arch="all"
@@ -10,7 +10,9 @@ license="MIT"
10makedepends="cmake libusb-dev" 10makedepends="cmake libusb-dev"
11options="!check" # upstream doesn't have automated tests 11options="!check" # upstream doesn't have automated tests
12subpackages="$pkgname-doc $pkgname-dev" 12subpackages="$pkgname-doc $pkgname-dev"
13source="$pkgname-$pkgver.tar.gz::https://github.com/texane/stlink/archive/v$pkgver.tar.gz" 13source="$pkgname-$pkgver.tar.gz::https://github.com/texane/stlink/archive/v$pkgver.tar.gz
14 0001-doc-man-Fix-installation-directory.patch
15 0002-CMakeLists.txt-Install-pkgconfig-files-again.patch"
14 16
15build() { 17build() {
16 if [ "$CBUILD" != "$CHOST" ]; then 18 if [ "$CBUILD" != "$CHOST" ]; then
@@ -20,6 +22,7 @@ build() {
20 -DCMAKE_BUILD_TYPE=None \ 22 -DCMAKE_BUILD_TYPE=None \
21 -DCMAKE_INSTALL_PREFIX=/usr \ 23 -DCMAKE_INSTALL_PREFIX=/usr \
22 -DBUILD_SHARED_LIBS=True \ 24 -DBUILD_SHARED_LIBS=True \
25 -DSTLINK_LIBRARY_PATH=/usr/lib \
23 -DCMAKE_C_FLAGS="$CFLAGS -Wno-error=cpp" \ 26 -DCMAKE_C_FLAGS="$CFLAGS -Wno-error=cpp" \
24 $CMAKE_CROSSOPTS . 27 $CMAKE_CROSSOPTS .
25 make -C build 28 make -C build
@@ -36,4 +39,6 @@ package() {
36 mv "$pkgdir"/etc/udev/rules.d "$pkgdir"/usr/lib/udev 39 mv "$pkgdir"/etc/udev/rules.d "$pkgdir"/usr/lib/udev
37} 40}
38 41
39sha512sums="0bf2416dac69e490560063714d630c4f549568bd9047113fb334f0841f5db23b97876307be8f0b1731863a2438c9502b9916d0d652c516d50969cb8b2cfa1a15 stlink-1.6.0.tar.gz" 42sha512sums="ac7ca0c23cd82a66be3ade4fec2a3fe757e5fc2e1d5c68a81316781a59568261a363efb58f5c529921b1c97185489fca5f1c1c4681098c72fb121b0858916fbc stlink-1.6.1.tar.gz
430825e51e46b65ad5c24d18edcd301823f02e8979dd793ada292eae3ac6d61cd32945a5ba8e102bc320991bbcd2cc5015a909f41e4c0a57aeed39aaff8b96d97f 0001-doc-man-Fix-installation-directory.patch
44d31ecbbe5458ac0de20ca26277031c375da73ef600eec305b1c199d21560add6448a6b3086f3c60350d001dcc5f2a1113ed723fbc177c6bd1d02bdd868a9bfe0 0002-CMakeLists.txt-Install-pkgconfig-files-again.patch"