aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:36 +0000
commitc2507ed590b8e0b92b1c3c4f5f2dcce7bc21ac7c (patch)
treeba8415374b08cc5b3e13fa2892275e7dc2c95b6c
parentdd9345d2c53941901dcd6a93991317e4740bd8c1 (diff)
downloadalpine_aports-c2507ed590b8e0b92b1c3c4f5f2dcce7bc21ac7c.tar.bz2
alpine_aports-c2507ed590b8e0b92b1c3c4f5f2dcce7bc21ac7c.tar.xz
alpine_aports-c2507ed590b8e0b92b1c3c4f5f2dcce7bc21ac7c.zip
testing/fuse: removed from stable branch
-rw-r--r--testing/fuse/APKBUILD62
-rw-r--r--testing/fuse/fuse-iconv.patch24
-rw-r--r--testing/fuse/fuse.initd35
3 files changed, 0 insertions, 121 deletions
diff --git a/testing/fuse/APKBUILD b/testing/fuse/APKBUILD
deleted file mode 100644
index 52cf280bba..0000000000
--- a/testing/fuse/APKBUILD
+++ /dev/null
@@ -1,62 +0,0 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=fuse
3pkgver=2.8.1
4pkgrel=0
5pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
6url="http://fuse.sourceforge.net/"
7license="GPL2"
8depends=
9makedepends="pkgconfig libiconv-dev gettext-dev
10 autoconf automake libtool"
11install=
12subpackages="$pkgname-dev"
13source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
14 fuse-iconv.patch
15 fuse.initd"
16
17
18_builddir="$srcdir"/$pkgname-$pkgver
19
20prepare() {
21 cd "$_builddir"
22 patch -p1 -i "$srcdir"/fuse-iconv.patch || return 1
23 aclocal -I m4 && libtoolize && autoconf && automake
24}
25
26build() {
27 cd "$_builddir"
28 ./configure --prefix=/usr \
29 --enable-lib \
30 --enable-util \
31 --bindir=/bin \
32 || return 1
33 make || return 1
34}
35
36package() {
37 cd "$_builddir"
38 make DESTDIR="$pkgdir" install || return 1
39
40 rm -rf "$pkgdir"/dev
41 rm -rf "$pkgdir"/etc/init.d
42
43 install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
44 # create config
45 install -d "$pkgdir"/etc
46 cat >"$pkgdir"/etc/fuse.conf << _EOF_
47# Set the maximum number of FUSE mounts allowed to non-root users.
48# The default is 1000.
49#
50#mount_max = 1000
51
52# Allow non-root users to specify the 'allow_other' or 'allow_root'
53# mount options.
54#
55#user_allow_other
56_EOF_
57
58}
59
60md5sums="0e3505ce90155983f1bc995eb2cf6fa7 fuse-2.8.1.tar.gz
61e5183506aabc5bf7795da52953d38888 fuse-iconv.patch
625983726cfabf0830dffbbbf9a3abcddc fuse.initd"
diff --git a/testing/fuse/fuse-iconv.patch b/testing/fuse/fuse-iconv.patch
deleted file mode 100644
index 4710f576f2..0000000000
--- a/testing/fuse/fuse-iconv.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1diff --git a/lib/Makefile.am b/lib/Makefile.am
2index 3eec119..c7414ac 100644
3--- a/lib/Makefile.am
4+++ b/lib/Makefile.am
5@@ -11,8 +11,10 @@ else
6 mount_source = mount.c mount_util.c mount_util.h
7 endif
8
9+libfuse_la_LDFLAGS =
10 if ICONV
11 iconv_source = modules/iconv.c
12+libfuse_la_LDFLAGS += -liconv
13 else
14 iconv_source =
15 endif
16@@ -35,7 +37,7 @@ libfuse_la_SOURCES = \
17 $(iconv_source) \
18 $(mount_source)
19
20-libfuse_la_LDFLAGS = @libfuse_libs@ -version-number 2:8:1 \
21+libfuse_la_LDFLAGS += @libfuse_libs@ -version-number 2:8:1 \
22 -Wl,--version-script,$(srcdir)/fuse_versionscript
23
24 libulockmgr_la_SOURCES = ulockmgr.c
diff --git a/testing/fuse/fuse.initd b/testing/fuse/fuse.initd
deleted file mode 100644
index 30b512e8dc..0000000000
--- a/testing/fuse/fuse.initd
+++ /dev/null
@@ -1,35 +0,0 @@
1#!/sbin/runscript
2# Copyright 1999-2007 Gentoo Foundation
3# Distributed under the terms of the GNU General Public License v2
4
5MOUNTPOINT=/sys/fs/fuse/connections
6
7depend() {
8 need localmount
9}
10
11start() {
12
13 ebegin "Starting fuse"
14 if ! grep -qw fuse /proc/filesystems; then
15 modprobe fuse >/dev/null 2>&1 || eerror $? "Error loading fuse module"
16 fi
17 if grep -qw fusectl /proc/filesystems && \
18 ! grep -qw $MOUNTPOINT /proc/mounts; then
19 mount -t fusectl none $MOUNTPOINT >/dev/null 2>&1 || \
20 eerror $? "Error mounting control filesystem"
21 fi
22 eend ${?}
23
24}
25
26stop() {
27
28 ebegin "Stopping fuse"
29 if grep -qw $MOUNTPOINT /proc/mounts; then
30 umount $MOUNTPOINT >/dev/null 2>&1 || \
31 eerror $? "Error unmounting control filesystem"
32 fi
33 eend ${?}
34
35}