aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-21 14:04:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-21 14:04:28 +0000
commit417e043d467ea56abc89390c88157921c6a17f4e (patch)
treed6c94b571a6b8013edeaca98479f1544ff2b500b
parent6c08a747e94cb5a2914337f7444304ab0d3b18d3 (diff)
downloadalpine_aports-417e043d467ea56abc89390c88157921c6a17f4e.tar.bz2
alpine_aports-417e043d467ea56abc89390c88157921c6a17f4e.tar.xz
alpine_aports-417e043d467ea56abc89390c88157921c6a17f4e.zip
testing/hardinfo: new aport
A system information and benchmark tool http://hardinfo.berlios.de/wiki/index.php/Main_Page
-rw-r--r--testing/hardinfo/APKBUILD32
-rw-r--r--testing/hardinfo/fixsensors.patch13
2 files changed, 45 insertions, 0 deletions
diff --git a/testing/hardinfo/APKBUILD b/testing/hardinfo/APKBUILD
new file mode 100644
index 0000000000..ac60f1dd1f
--- /dev/null
+++ b/testing/hardinfo/APKBUILD
@@ -0,0 +1,32 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=hardinfo
3pkgver=0.5.1
4pkgrel=0
5pkgdesc="A system information and benchmark tool."
6url="http://hardinfo.berlios.de/wiki/index.php/Main_Page"
7license="GPL-2"
8makedepends="gtk+-dev libsoup-dev>=2.4.0 gnutls-dev>=2.4.1"
9depends=
10source="http://download.berlios.de/$pkgname/$pkgname-$pkgver.tar.bz2
11 fixsensors.patch"
12
13_builddir="$srcdir"/$pkgname-$pkgver
14prepare() {
15 cd "$_builddir"
16 patch -p1 < "$srcdir"/fixsensors.patch || return 1
17}
18
19build() {
20 cd "$_builddir"
21 ./configure --prefix=/usr || return 1
22 make || return 1
23}
24
25package() {
26 cd "$_builddir"
27 make DESTDIR="$pkgdir" install || return 1
28 install -d "$pkgdir"/etc
29 echo "Alpine Linux" > "$pkgdir"/etc/hardinfo.distro
30}
31md5sums="6fb38992e140f2fab16518ae1f38e188 hardinfo-0.5.1.tar.bz2
3205c212db07b9f152cdea052ff7bb28fa fixsensors.patch"
diff --git a/testing/hardinfo/fixsensors.patch b/testing/hardinfo/fixsensors.patch
new file mode 100644
index 0000000000..812c294589
--- /dev/null
+++ b/testing/hardinfo/fixsensors.patch
@@ -0,0 +1,13 @@
1 diff -upNr hardinfo-0.4.2.2.orign/util.c hardinfo-0.4.2.2/util.c
2--- hardinfo-0.4.2.2.orign/util.c 2007-07-20 16:45:08.000000000 +0200
3+++ hardinfo-0.4.2.2/util.c 2007-07-26 10:15:32.000000000 +0200
4@@ -996,7 +996,8 @@ gchar *h_strdup_cprintf(const gchar * fo
5 if (source) {
6 retn = g_strconcat(source, buffer, NULL);
7 g_free(buffer);
8- g_free(source);
9+ if(strlen(source))
10+ g_free(source);
11 } else {
12 retn = buffer;
13 }