aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 12:16:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 12:23:08 +0000
commit65595048ad399d736e296201aaced08c6b0cb8e0 (patch)
tree25b94baf20c26a775f586263d93a26bfc836cf26
parentd2e0f3a8cc9e5c0dda76a2fd7aaddad0fd07f38e (diff)
downloadalpine_aports-65595048ad399d736e296201aaced08c6b0cb8e0.tar.bz2
alpine_aports-65595048ad399d736e296201aaced08c6b0cb8e0.tar.xz
alpine_aports-65595048ad399d736e296201aaced08c6b0cb8e0.zip
main/lighttpd: fix handling of SSL_CTX_set_options() return value
fixes #329 (cherry picked from commit 192b8fad759488bbe2fea1b43acda638eb6ebe85)
-rw-r--r--main/lighttpd/APKBUILD13
-rw-r--r--main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch13
2 files changed, 22 insertions, 4 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index b70b4b5542..44125b0e94 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
2pkgname=lighttpd 2pkgname=lighttpd
3pkgver=1.4.26 3pkgver=1.4.26
4_streamver=2.2.0 4_streamver=2.2.0
5pkgrel=1 5pkgrel=2
6pkgdesc="a secure, fast, compliant and very flexible web-server" 6pkgdesc="a secure, fast, compliant and very flexible web-server"
7url="http://www.lighttpd.net/" 7url="http://www.lighttpd.net/"
8license="custom" 8license="custom"
@@ -22,14 +22,18 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
22 mod_cgi.conf 22 mod_cgi.conf
23 mod_fastcgi.conf 23 mod_fastcgi.conf
24 lighttpd-version-from-git.patch 24 lighttpd-version-from-git.patch
25 fix-handling-return-value-of-SSL_CTX_set_options.patch
25 " 26 "
26subpackages="$pkgname-dev $pkgname-doc $pkgname-h264_streaming" 27subpackages="$pkgname-dev $pkgname-doc $pkgname-h264_streaming"
27 28
28prepare() { 29prepare() {
29 cd "$srcdir"/$pkgname-$pkgver 30 cd "$srcdir"/$pkgname-$pkgver
30 31
31 # 323 32 # http://bugs.alpinelinux.org/issues/323
32 patch -p0 -i "$srcdir"/lighttpd-version-from-git.patch || return 0 33 patch -p0 -i "$srcdir"/lighttpd-version-from-git.patch || return 1
34
35 # http://bugs.alpinelinux.org/issues/329
36 patch -p2 -i "$srcdir"/fix-handling-return-value-of-SSL_CTX_set_options.patch || return 1
33 37
34 # copy over the mod-h264-streaming mod 38 # copy over the mod-h264-streaming mod
35 # http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x 39 # http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
@@ -116,4 +120,5 @@ df5b2360ea380d988bf16905ab214286 lighttpd.conf
116fef397e7bcf1b741dea211a555e1803c mime-types.conf 120fef397e7bcf1b741dea211a555e1803c mime-types.conf
1179c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf 1219c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf
118f3363e39832f1b6678468b482d121afb mod_fastcgi.conf 122f3363e39832f1b6678468b482d121afb mod_fastcgi.conf
119c2471f50eec2ce85da6dfaf8289725bc lighttpd-version-from-git.patch" 123c2471f50eec2ce85da6dfaf8289725bc lighttpd-version-from-git.patch
124770baaa9a8dae51e25db29d3561d5b76 fix-handling-return-value-of-SSL_CTX_set_options.patch"
diff --git a/main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch b/main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch
new file mode 100644
index 0000000000..40eab25e50
--- /dev/null
+++ b/main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch
@@ -0,0 +1,13 @@
1Index: branches/lighttpd-1.4.x/src/network.c
2===================================================================
3--- branches/lighttpd-1.4.x/src/network.c (revision 2715)
4+++ branches/lighttpd-1.4.x/src/network.c (revision 2716)
5@@ -525,7 +525,7 @@
6
7 if (!s->ssl_use_sslv2) {
8 /* disable SSLv2 */
9- if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
10+ if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
11 log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
12 ERR_error_string(ERR_get_error(), NULL));
13 return -1;