aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-30 17:57:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-31 07:59:05 +0000
commit94cf60513252d2bd604005fda3e2015ca23df860 (patch)
treecf10977129fc4311b965a87a55b4d4ae7156dbfe
parentb3592697ec8a16c47d62c4eeb0f2393198f32d34 (diff)
downloadalpine_aports-94cf60513252d2bd604005fda3e2015ca23df860.tar.bz2
alpine_aports-94cf60513252d2bd604005fda3e2015ca23df860.tar.xz
alpine_aports-94cf60513252d2bd604005fda3e2015ca23df860.zip
main/asterisk: upgrade to 1.6.2.6
(cherry picked from commit e2b1fa879649d88c5800f069c076803983bb9be1)
-rw-r--r--main/asterisk/200-parallel-make.patch99
-rw-r--r--main/asterisk/APKBUILD8
2 files changed, 3 insertions, 104 deletions
diff --git a/main/asterisk/200-parallel-make.patch b/main/asterisk/200-parallel-make.patch
deleted file mode 100644
index 2d216e8bdf..0000000000
--- a/main/asterisk/200-parallel-make.patch
+++ /dev/null
@@ -1,99 +0,0 @@
1diff -uNr asterisk-1.6.2.0/Makefile asterisk-1.6.2.0-r1/Makefile
2--- asterisk-1.6.2.0/Makefile 2010-01-16 18:55:43.738059027 +0100
3+++ asterisk-1.6.2.0-r1/Makefile 2010-01-16 19:32:06.898555681 +0100
4@@ -589,7 +589,7 @@
5 fi
6
7 $(SUBDIRS_INSTALL):
8- @DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" $(SUBMAKE) -C $(@:-install=) install
9+ @+DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" $(SUBMAKE) -C $(@:-install=) install
10
11 NEWMODS:=$(foreach d,$(MOD_SUBDIRS),$(notdir $(wildcard $(d)/*.so)))
12 OLDMODS=$(filter-out $(NEWMODS),$(notdir $(wildcard $(DESTDIR)$(MODULES_DIR)/*.so)))
13@@ -848,7 +848,7 @@
14 # last clean count we had
15
16 cleantest:
17- @cmp -s .cleancount .lastclean || $(MAKE) clean
18+ @+cmp -s .cleancount .lastclean || $(MAKE) clean
19
20 $(SUBDIRS_UNINSTALL):
21 @$(SUBMAKE) -C $(@:-uninstall=) uninstall
22@@ -897,7 +897,7 @@
23 nmenuconfig: nmenuselect
24
25 menuselect: menuselect/cmenuselect menuselect/nmenuselect menuselect/gmenuselect
26- @if [ -x menuselect/nmenuselect ]; then \
27+ @+if [ -x menuselect/nmenuselect ]; then \
28 $(MAKE) nmenuselect; \
29 elif [ -x menuselect/cmenuselect ]; then \
30 $(MAKE) cmenuselect; \
31diff -uNr asterisk-1.6.2.0/channels/Makefile asterisk-1.6.2.0-r1/channels/Makefile
32--- asterisk-1.6.2.0/channels/Makefile 2010-01-16 18:55:43.733055737 +0100
33+++ asterisk-1.6.2.0-r1/channels/Makefile 2010-01-16 18:57:51.589055800 +0100
34@@ -100,7 +100,7 @@
35 chan_usbradio.so: _ASTCFLAGS+=-DNDEBUG
36
37 h323/Makefile.ast:
38- $(CMD_PREFIX) $(MAKE) -C h323 Makefile.ast
39+ +$(CMD_PREFIX) $(MAKE) -C h323 Makefile.ast
40
41 h323/libchanh323.a: h323/Makefile.ast
42- $(CMD_PREFIX) $(MAKE) -C h323 libchanh323.a
43+ +$(CMD_PREFIX) $(MAKE) -C h323 libchanh323.a
44diff -uNr asterisk-1.6.2.0/codecs/gsm/Makefile asterisk-1.6.2.0-r1/codecs/gsm/Makefile
45--- asterisk-1.6.2.0/codecs/gsm/Makefile 2010-01-16 18:55:43.733055737 +0100
46+++ asterisk-1.6.2.0-r1/codecs/gsm/Makefile 2010-01-16 18:58:31.557055848 +0100
47@@ -358,12 +358,12 @@
48 # Installation
49
50 gsminstall:
51- -if [ x"$(GSM_INSTALL_ROOT)" != x ] ; then \
52+ -+if [ x"$(GSM_INSTALL_ROOT)" != x ] ; then \
53 $(MAKE) $(GSM_INSTALL_TARGETS) ; \
54 fi
55
56 toastinstall:
57- -if [ x"$(TOAST_INSTALL_ROOT)" != x ]; then \
58+ -+if [ x"$(TOAST_INSTALL_ROOT)" != x ]; then \
59 $(MAKE) $(TOAST_INSTALL_TARGETS); \
60 fi
61
62diff -uNr asterisk-1.6.2.0/main/Makefile asterisk-1.6.2.0-r1/main/Makefile
63--- asterisk-1.6.2.0/main/Makefile 2010-01-16 18:55:43.738059027 +0100
64+++ asterisk-1.6.2.0-r1/main/Makefile 2010-01-16 19:26:43.334555789 +0100
65@@ -177,7 +177,7 @@
66 clean::
67 rm -f asterisk
68 rm -f db1-ast/.*.d
69- @if [ -f editline/Makefile ]; then $(MAKE) -C editline distclean ; fi
70+ @+if [ -f editline/Makefile ]; then $(MAKE) -C editline distclean ; fi
71 @$(MAKE) -C db1-ast clean
72 @$(MAKE) -C stdtime clean
73 rm -f libresample/src/*.o
74diff -uNr asterisk-1.6.2.0/menuselect/Makefile asterisk-1.6.2.0-r1/menuselect/Makefile
75--- asterisk-1.6.2.0/menuselect/Makefile 2010-01-16 18:55:43.738059027 +0100
76+++ asterisk-1.6.2.0-r1/menuselect/Makefile 2010-01-16 19:03:34.381055693 +0100
77@@ -96,7 +96,7 @@
78 $(CC) -o $@ $^ $(M_LIBS)
79
80 mxml/libmxml.a:
81- @if test ! -f mxml/Makefile ; then cd mxml && ./configure ; fi
82+ @+if test ! -f mxml/Makefile ; then cd mxml && ./configure ; fi
83 @$(MAKE) -C mxml libmxml.a
84
85 test: menuselect
86@@ -113,11 +113,11 @@
87
88 clean:
89 rm -f menuselect cmenuselect gmenuselect nmenuselect $(OBJS) $(M_OBJS) $(C_OBJS) $(G_OBJS) $(N_OBJS)
90- @if test -f mxml/Makefile ; then $(MAKE) -C mxml clean ; fi
91+ @+if test -f mxml/Makefile ; then $(MAKE) -C mxml clean ; fi
92
93 dist-clean: distclean
94
95 distclean: clean
96- @if test -f mxml/Makefile ; then $(MAKE) -C mxml distclean ; fi
97+ @+if test -f mxml/Makefile ; then $(MAKE) -C mxml distclean ; fi
98 rm -f autoconfig.h config.status config.log makeopts
99 rm -rf autom4te.cache
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index 68d0a82757..22b9668eef 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -1,8 +1,8 @@
1# Contributor: Timo Teras <timo.teras@iki.fi> 1# Contributor: Timo Teras <timo.teras@iki.fi>
2# Maintainer: Timo Teras <timo.teras@iki.fi> 2# Maintainer: Timo Teras <timo.teras@iki.fi>
3pkgname=asterisk 3pkgname=asterisk
4pkgver=1.6.2.1 4pkgver=1.6.2.6
5pkgrel=1 5pkgrel=0
6pkgdesc="Asterisk: A Module Open Source PBX System" 6pkgdesc="Asterisk: A Module Open Source PBX System"
7url="http://www.asterisk.org/" 7url="http://www.asterisk.org/"
8license="GPL" 8license="GPL"
@@ -17,7 +17,6 @@ source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$pkgver.tar.g
17 100-uclibc-daemon.patch 17 100-uclibc-daemon.patch
18 101-caps-uclibc.patch 18 101-caps-uclibc.patch
19 102-gsm-pic.patch 19 102-gsm-pic.patch
20 200-parallel-make.patch
21 400-bug-227.patch 20 400-bug-227.patch
22 asterisk.initd 21 asterisk.initd
23 asterisk.confd 22 asterisk.confd
@@ -105,11 +104,10 @@ sample() {
105 make samples DESTDIR="$subpkgdir" 104 make samples DESTDIR="$subpkgdir"
106} 105}
107 106
108md5sums="8fbc60f9d80e686c749ae95292e225d8 asterisk-1.6.2.1.tar.gz 107md5sums="f068ef2433eebdc7f6dd635986f36d77 asterisk-1.6.2.6.tar.gz
109b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch 108b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
1106e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch 1096e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch
11197b39fd9777a2521d4f9f095482b7ac2 102-gsm-pic.patch 11097b39fd9777a2521d4f9f095482b7ac2 102-gsm-pic.patch
11280b46215bb243821d9faec55dca179b8 200-parallel-make.patch
11379e9634b5054bceb3b8dc246654bb243 400-bug-227.patch 11179e9634b5054bceb3b8dc246654bb243 400-bug-227.patch
1140ce3219e05f55af884a7dc6b99c2b276 asterisk.initd 1120ce3219e05f55af884a7dc6b99c2b276 asterisk.initd
115ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd 113ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd