aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:37 +0000
commitbd9d7de4cd2331202b7f5a0cccd0473a69e32730 (patch)
tree83affff82b5e0dcd7e487f622bf1455b92aa57f2
parentd0ef33f9b95c7ae033e4b9876d75c4e8f69031d2 (diff)
downloadalpine_aports-bd9d7de4cd2331202b7f5a0cccd0473a69e32730.tar.bz2
alpine_aports-bd9d7de4cd2331202b7f5a0cccd0473a69e32730.tar.xz
alpine_aports-bd9d7de4cd2331202b7f5a0cccd0473a69e32730.zip
testing/ucspi-tcp: removed from stable branch
-rw-r--r--testing/ucspi-tcp/APKBUILD48
-rw-r--r--testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch64
-rw-r--r--testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch12
3 files changed, 0 insertions, 124 deletions
diff --git a/testing/ucspi-tcp/APKBUILD b/testing/ucspi-tcp/APKBUILD
deleted file mode 100644
index 9cdca87524..0000000000
--- a/testing/ucspi-tcp/APKBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
1# Contributor: Francesco Colista <francesco.colista@gmail.com>
2# Maintainer: Francesco Colista <francesco.colista@gmail.com>
3
4pkgname=ucspi-tcp
5pkgver=0.88
6pkgrel=0
7pkgdesc="Easy-to-use command-line tools for building TCP client-server applications."
8url="http://cr.yp.to/ucspi-tcp.html"
9license="public-domain"
10depends=""
11makedepends=""
12install=
13subpackages=""
14source="http://cr.yp.to/$pkgname/$pkgname-$pkgver.tar.gz
15 ucspi-tcp-0.88.a_record.patch
16 ucspi-tcp-0.88.errno.patch
17 "
18
19prepare() {
20 cd "$srcdir"/$pkgname-$pkgver
21 for i in ../*.patch;
22 do
23 msg "Applying $i"
24 patch -p1 -i $i || return 1
25 done
26}
27
28build() {
29 cd "$srcdir"/$pkgname-$pkgver
30 echo "${CC:-"gcc"} ${CFLAGS}" > conf-cc
31 echo "${CC:-"gcc"} ${LDFLAGS}" > conf-ld
32 echo "/usr" > conf-home
33 make || return 1
34}
35
36package() {
37 cd "$srcdir"/$pkgname-$pkgver
38 mkdir -p "$pkgdir"/usr/bin
39 for f in tcpserver tcprules tcprulescheck argv0 recordio tcpclient \
40 *\@ tcpcat mconnect mconnect-io addcr delcr fixcrio \
41 rblsmtpd; do
42 cp $f "$pkgdir"/usr/bin/$f
43 done
44}
45
46md5sums="39b619147db54687c4a583a7a94c9163 ucspi-tcp-0.88.tar.gz
47554ec0eb60f619667efde3fb5325310d ucspi-tcp-0.88.a_record.patch
48759a11fafff188d9580be6498a028095 ucspi-tcp-0.88.errno.patch"
diff --git a/testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch b/testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch
deleted file mode 100644
index 903125eaae..0000000000
--- a/testing/ucspi-tcp/ucspi-tcp-0.88.a_record.patch
+++ /dev/null
@@ -1,64 +0,0 @@
1diff -ruN --exclude conf-* ucspi-tcp-0.88/rblsmtpd.c ucspi-tcp-0.88.fix/rblsmtpd.c
2--- ucspi-tcp-0.88/rblsmtpd.c Sat Mar 18 10:18:42 2000
3+++ ucspi-tcp-0.88.fix/rblsmtpd.c Wed Aug 9 16:42:33 2000
4@@ -60,16 +60,54 @@
5
6 void rbl(char *base)
7 {
8+ int i;
9+ char *altreply = 0;
10 if (decision) return;
11 if (!stralloc_copy(&tmp,&ip_reverse)) nomem();
12+ i = str_chr(base, ':');
13+ if (base[i]) {
14+ base[i] = 0;
15+ altreply = base+i+1;
16+ }
17 if (!stralloc_cats(&tmp,base)) nomem();
18- if (dns_txt(&text,&tmp) == -1) {
19- flagmustnotbounce = 1;
20- if (flagfailclosed) {
21- if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
22- decision = 2;
23+ if (altreply) {
24+ if (dns_ip4(&text,&tmp) == -1) {
25+ flagmustnotbounce = 1;
26+ if (flagfailclosed) {
27+ if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
28+ decision = 2;
29+ }
30+ return;
31+ }
32+ if (text.len) {
33+ if(!stralloc_copys(&text, "")) nomem();
34+ while(*altreply) {
35+ char *x;
36+ i = str_chr(altreply, '%');
37+ if(!stralloc_catb(&text, altreply, i)) nomem();
38+ if(altreply[i] &&
39+ altreply[i+1]=='I' &&
40+ altreply[i+2]=='P' &&
41+ altreply[i+3]=='%') {
42+ if(!stralloc_catb(&text, ip_env, str_len(ip_env))) nomem();
43+ altreply+=i+4;
44+ } else if(altreply[i]) {
45+ if(!stralloc_cats(&text, "%")) nomem();
46+ altreply+=i+1;
47+ } else {
48+ altreply+=i;
49+ }
50+ }
51+ }
52+ } else {
53+ if (dns_txt(&text,&tmp) == -1) {
54+ flagmustnotbounce = 1;
55+ if (flagfailclosed) {
56+ if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
57+ decision = 2;
58+ }
59+ return;
60 }
61- return;
62 }
63 if (text.len)
64 if (flagrblbounce)
diff --git a/testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch b/testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch
deleted file mode 100644
index 7654c783a6..0000000000
--- a/testing/ucspi-tcp/ucspi-tcp-0.88.errno.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -u ucspi-tcp-0.88.old/error.h ucspi-tcp-0.88/error.h
2--- ucspi-tcp-0.88.old/error.h 2000-03-18 09:18:20.000000000 -0600
3+++ ucspi-tcp-0.88/error.h 2003-01-08 13:39:12.000000000 -0600
4@@ -1,7 +1,7 @@
5 #ifndef ERROR_H
6 #define ERROR_H
7
8-extern int errno;
9+#include <errno.h>
10
11 extern int error_intr;
12 extern int error_nomem;