aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-10 09:22:43 +0000
committerTimo Teräs <timo.teras@iki.fi>2010-06-10 13:27:47 +0300
commit1d5e59ca83531f0e52bd94fbc28ec1e791020ce1 (patch)
tree1fbdad66dd4c007eccc2cce05b98f1b58126c312
parent9c54951a0024fefe80a01bba7e2a009bf369d8f6 (diff)
downloadalpine_aports-1d5e59ca83531f0e52bd94fbc28ec1e791020ce1.tar.bz2
alpine_aports-1d5e59ca83531f0e52bd94fbc28ec1e791020ce1.tar.xz
alpine_aports-1d5e59ca83531f0e52bd94fbc28ec1e791020ce1.zip
main/linux-grsec: fix for hyper-v and PaX
(cherry picked from commit f90d28dd1c6b9515696c7a08bebd6c463e81e00b)
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/hv-grsec.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 16eb88ebb8..67b03001e6 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
4pkgname=linux-${_flavor} 4pkgname=linux-${_flavor}
5pkgver=2.6.32.15 5pkgver=2.6.32.15
6_kernver=2.6.32 6_kernver=2.6.32
7pkgrel=4 7pkgrel=5
8pkgdesc="Linux kernel with grsecurity" 8pkgdesc="Linux kernel with grsecurity"
9url=http://grsecurity.net 9url=http://grsecurity.net
10depends="mkinitfs linux-firmware" 10depends="mkinitfs linux-firmware"
@@ -34,6 +34,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
34 r8169-fix-random-mdio_write-failures.patch 34 r8169-fix-random-mdio_write-failures.patch
35 r8169-fix-mdio_read-and-update-mdio_write-according-to-hw-specs.patch 35 r8169-fix-mdio_read-and-update-mdio_write-according-to-hw-specs.patch
36 x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch 36 x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
37 hv-grsec.patch
37 kernelconfig.x86 38 kernelconfig.x86
38 " 39 "
39subpackages="$pkgname-dev linux-firmware:firmware" 40subpackages="$pkgname-dev linux-firmware:firmware"
@@ -165,4 +166,5 @@ c7e606c11c05ff03012b21c3fe0ece47 xfrm-fix-policy-unreferencing-on-larval-drop.p
165ce4a74190febe13713bab1b886dd5bee r8169-fix-random-mdio_write-failures.patch 166ce4a74190febe13713bab1b886dd5bee r8169-fix-random-mdio_write-failures.patch
166b41ee19f13498fb25992fd60cd1126d4 r8169-fix-mdio_read-and-update-mdio_write-according-to-hw-specs.patch 167b41ee19f13498fb25992fd60cd1126d4 r8169-fix-mdio_read-and-update-mdio_write-according-to-hw-specs.patch
167a1bcf76870b63a4a4035a8948fb758e2 x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch 168a1bcf76870b63a4a4035a8948fb758e2 x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
169bf14850a0036d14bc6177adbdec23a17 hv-grsec.patch
168442d7174a9755ed7bba22ebd4918bbe5 kernelconfig.x86" 170442d7174a9755ed7bba22ebd4918bbe5 kernelconfig.x86"
diff --git a/main/linux-grsec/hv-grsec.patch b/main/linux-grsec/hv-grsec.patch
new file mode 100644
index 0000000000..6fde341990
--- /dev/null
+++ b/main/linux-grsec/hv-grsec.patch
@@ -0,0 +1,13 @@
1diff --git a/drivers/staging/hv/Hv.c b/drivers/staging/hv/Hv.c
2index b12237f..9d47edb 100644
3--- a/drivers/staging/hv/Hv.c
4+++ b/drivers/staging/hv/Hv.c
5@@ -133,7 +133,7 @@ static u64 HvDoHypercall(u64 Control, void *Input, void *Output)
6 u64 hvStatus = 0;
7 u64 inputAddress = (Input) ? virt_to_phys(Input) : 0;
8 u64 outputAddress = (Output) ? virt_to_phys(Output) : 0;
9- volatile void *hypercallPage = gHvContext.HypercallPage;
10+ volatile void *hypercallPage = ktva_ktla(gHvContext.HypercallPage);
11
12 DPRINT_DBG(VMBUS, "Hypercall <control %llx input phys %llx virt %p "
13 "output phys %llx virt %p hypercall %p>",