aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-16 07:45:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-16 10:07:59 +0000
commit99c3764deae9f493e6e1ac91442e84c5519126db (patch)
treea1c7833bef2fabcb9ac3e61e11e7644a2b9ed3b0
parenteada7d92ef7d9e40235e783fc3d2df5092ba3c0a (diff)
downloadalpine_aports-99c3764deae9f493e6e1ac91442e84c5519126db.tar.bz2
alpine_aports-99c3764deae9f493e6e1ac91442e84c5519126db.tar.xz
alpine_aports-99c3764deae9f493e6e1ac91442e84c5519126db.zip
main/apk-tools: build fix
added missing patch (cherry picked from commit cb0a6194fe8a614e7b91ce6772005d924031e438)
-rw-r--r--main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch b/main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
new file mode 100644
index 0000000000..52ef141863
--- /dev/null
+++ b/main/apk-tools/0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
@@ -0,0 +1,42 @@
1From fc4c60f233ebe9fe85b7b03d0cf5deec4ab1b32d Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Wed, 16 Jun 2010 07:37:17 +0000
4Subject: [PATCH] Makefile: do not require lua pkgconfig unless you intend build lua module
5
6---
7 src/Makefile | 11 ++++++-----
8 1 files changed, 6 insertions(+), 5 deletions(-)
9
10diff --git a/src/Makefile b/src/Makefile
11index 50f9664..bea288e 100644
12--- a/src/Makefile
13+++ b/src/Makefile
14@@ -1,12 +1,9 @@
15-PKGDEPS := openssl zlib lua
16-
17-ifeq ($(shell pkg-config --print-errors --exists $(PKGDEPS) || echo fail),fail)
18-$(error Build dependencies are not met)
19-endif
20+PKGDEPS := openssl zlib
21
22 # lua module
23 ifneq ($(LUAAPK),)
24 LIBAPK := YesPlease
25+PKGDEPS += lua
26 shlibs-y += apk.so
27 apk.so-objs := lua-apk.o
28 CFLAGS_lua-apk.o := -DAPK_VERSION=\"$(FULL_VERSION)\"
29@@ -16,6 +13,10 @@ install-LUA_LIB-y := $(INSTALLDIR) $(DESTDIR)$(LUA_LIBDIR) \
30 $(INSTALL) $(LUA_LIB-y) $(DESTDIR)$(LUA_LIBDIR)
31 endif
32
33+ifeq ($(shell pkg-config --print-errors --exists $(PKGDEPS) || echo fail),fail)
34+$(error Build dependencies are not met)
35+endif
36+
37 progs-y += apk
38 apk-objs := apk.o add.o del.o fix.o update.o info.o \
39 search.o upgrade.o cache.o ver.o index.o fetch.o \
40--
411.7.1
42