aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-08 13:10:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-08 13:35:12 +0000
commit8548d6c936344a59341c1c4362172407bf2149c2 (patch)
treeac69d64c86e35ba4e94f0e4b2d45887dc73ee1ed
parent5ea25ba4daccca0752a55705b06ac502b23ee597 (diff)
downloadalpine_aports-8548d6c936344a59341c1c4362172407bf2149c2.tar.bz2
alpine_aports-8548d6c936344a59341c1c4362172407bf2149c2.tar.xz
alpine_aports-8548d6c936344a59341c1c4362172407bf2149c2.zip
main/chrony: provide ntp-client and ntp-server
fixes #260 (cherry picked from commit 580b1e991fe7b5c58be1c045379bae23e190fc7d)
-rw-r--r--main/chrony/APKBUILD16
-rw-r--r--main/chrony/chronyd.initd1
2 files changed, 13 insertions, 4 deletions
diff --git a/main/chrony/APKBUILD b/main/chrony/APKBUILD
index da80937172..54d94e51d4 100644
--- a/main/chrony/APKBUILD
+++ b/main/chrony/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=chrony 2pkgname=chrony
3pkgver=1.23 3pkgver=1.23
4pkgrel=4 4pkgrel=5
5pkgdesc="NTP client and server programs" 5pkgdesc="NTP client and server programs"
6url="http://chrony.sunsite.dk/" 6url="http://chrony.sunsite.dk/"
7license="GPL-2" 7license="GPL-2"
@@ -20,9 +20,10 @@ source="http://www.sfr-fresh.com/linux/misc/chrony-$pkgver.tar.gz
20 chrony.conf 20 chrony.conf
21 " 21 "
22 22
23build() { 23_builddir="$srcdir"/$pkgname-$pkgver
24prepare() {
24 local i 25 local i
25 cd "$srcdir/$pkgname-$pkgver" 26 cd "$_builddir"
26 27
27 for i in ../*.diff; do 28 for i in ../*.diff; do
28 msg "Applying $i" 29 msg "Applying $i"
@@ -30,13 +31,20 @@ build() {
30 done 31 done
31 sed -i "s:/etc/chrony:/etc/chrony/chrony:g" \ 32 sed -i "s:/etc/chrony:/etc/chrony/chrony:g" \
32 chrony*.[158] faq.txt chrony.texi || die "sed failed" 33 chrony*.[158] faq.txt chrony.texi || die "sed failed"
34}
33 35
36build() {
37 cd "$_builddir"
34 ./configure --prefix=/usr \ 38 ./configure --prefix=/usr \
35 --infodir=/usr/share/info \ 39 --infodir=/usr/share/info \
36 --mandir=/usr/share/man \ 40 --mandir=/usr/share/man \
37 --disable-readline 41 --disable-readline
38 42
39 make all docs || return 1 43 make all docs || return 1
44}
45
46package() {
47 cd "$_builddir"
40 make DESTDIR="$pkgdir" install 48 make DESTDIR="$pkgdir" install
41 49
42 mv "$pkgdir"/usr/doc "$pkgdir"/usr/share/ 50 mv "$pkgdir"/usr/doc "$pkgdir"/usr/share/
@@ -57,6 +65,6 @@ d47015a34b6b2f9eebca77ef939cec72 chrony-1.21-makefile.diff
5739cbce9f66638b67623e1ee6bb0f943f chrony-1.23-sources.diff 6539cbce9f66638b67623e1ee6bb0f943f chrony-1.23-sources.diff
58caa6589a1a1cd56f64957e312d1ef84c chrony-1.23-reply-ip.diff 66caa6589a1a1cd56f64957e312d1ef84c chrony-1.23-reply-ip.diff
59d5c09be46226774d22c08c5a4c28093a chronyd.confd 67d5c09be46226774d22c08c5a4c28093a chronyd.confd
60348532411bb4b7139a0609676e15da66 chronyd.initd 68becc5e2bb407d8d03da7f5d8b3904fb7 chronyd.initd
61468eaf2b5465d60b3ee021ce3f948ab1 chrony.logrotate 69468eaf2b5465d60b3ee021ce3f948ab1 chrony.logrotate
6246f42c52953d398ca44d6baa449618d7 chrony.conf" 7046f42c52953d398ca44d6baa449618d7 chrony.conf"
diff --git a/main/chrony/chronyd.initd b/main/chrony/chronyd.initd
index 457c1ef382..bf19f31980 100644
--- a/main/chrony/chronyd.initd
+++ b/main/chrony/chronyd.initd
@@ -6,6 +6,7 @@
6depend() { 6depend() {
7 need net 7 need net
8 after firewall 8 after firewall
9 provide ntp-client ntp-server
9 use dns 10 use dns
10} 11}
11 12