aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-24 17:29:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-24 18:28:15 +0000
commit080defa78257ee25c663b18b59faa58f74afb6d4 (patch)
treea6af4504669bcdd77c1327d6a2138b8e988c099d
parent920035803039b60522a9aeec73e3f67fa9dba208 (diff)
downloadalpine_aports-080defa78257ee25c663b18b59faa58f74afb6d4.tar.bz2
alpine_aports-080defa78257ee25c663b18b59faa58f74afb6d4.tar.xz
alpine_aports-080defa78257ee25c663b18b59faa58f74afb6d4.zip
main/dpkg: new aport
The Debian Package Manager http://packages.debian.org/dpkg (cherry picked from commit 6236ed9a188fa2c0d8a7ede1ca08e9dd9521fea4)
-rw-r--r--main/dpkg/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/main/dpkg/APKBUILD b/main/dpkg/APKBUILD
new file mode 100644
index 0000000000..5710f9c5ad
--- /dev/null
+++ b/main/dpkg/APKBUILD
@@ -0,0 +1,60 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=dpkg
3pkgver=1.15.5.6
4pkgrel=0
5pkgdesc="The Debian Package Manager"
6url="http://packages.debian.org/dpkg"
7license="GPL"
8makedepends="bzip2-dev zlib-dev perl"
9subpackages="$pkgname-doc $pkgname-dev"
10source="http://ftp.de.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.bz2"
11
12_builddir="$srcdir"/$pkgname-$pkgver
13prepare() {
14 cd "$_builddir"
15 sed -i "s|<ncursesw/curses.h>|<curses.h>|g" dselect/dselect.h \
16 dselect/Makefile.in || return 1
17 sed -i "s|<ncursesw/term.h>|<term.h>|g" dselect/main.cc || return 1
18}
19
20build() {
21 cd "$_builddir"
22 ./configure --prefix=/usr \
23 --with-zlib \
24 --without-dselect \
25 --without-start-stop-daemon \
26 || return 1
27 make || return 1
28}
29
30package() {
31 cd "$_builddir"
32 make DESTDIR="$pkgdir" install || return 1
33}
34
35dev() {
36 pkgdesc="Debian package development tools"
37 depends="perl"
38 mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/share \
39 "$subpkgdir"/usr/lib/dpkg
40
41 mv "$pkgdir"/usr/bin/dpkg-architecture \
42 "$pkgdir"/usr/bin/dpkg-buildpackage \
43 "$pkgdir"/usr/bin/dpkg-checkbuilddeps \
44 "$pkgdir"/usr/bin/dpkg-distaddfile \
45 "$pkgdir"/usr/bin/dpkg-genchanges \
46 "$pkgdir"/usr/bin/dpkg-gencontrol \
47 "$pkgdir"/usr/bin/dpkg-gensymbols \
48 "$pkgdir"/usr/bin/dpkg-name \
49 "$pkgdir"/usr/bin/dpkg-parsechangelog \
50 "$pkgdir"/usr/bin/dpkg-scanpackages \
51 "$pkgdir"/usr/bin/dpkg-scansources \
52 "$pkgdir"/usr/bin/dpkg-shlibdeps \
53 "$pkgdir"/usr/bin/dpkg-source \
54 "$pkgdir"/usr/bin/dpkg-vendor \
55 "$subpkgdir"/usr/bin/
56 mv "$pkgdir"/usr/share/perl* "$subpkgdir"/usr/share/
57 mv "$pkgdir"/usr/lib/dpkg/parsechangelog "$subpkgdir"/usr/lib/dpkg/
58}
59
60md5sums="4dcb0de9af234d16a62272bcc61b8873 dpkg_1.15.5.6.tar.bz2"