aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-16 18:44:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-16 18:44:54 +0000
commit4260f178c04e97acbe19190d97760115c7b83de2 (patch)
tree5e8ea4c22a0505ce053c4400872bbc4e906864ca
parent422d8de2e356ab2b9db3428c474de3f375fd91a3 (diff)
downloadalpine_aports-4260f178c04e97acbe19190d97760115c7b83de2.tar.bz2
alpine_aports-4260f178c04e97acbe19190d97760115c7b83de2.tar.xz
alpine_aports-4260f178c04e97acbe19190d97760115c7b83de2.zip
extra/libusb: new aport
Library to enable user space application programs to communicate with USB devices http://libusb.sourceforge.net/
-rw-r--r--extra/libusb/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/extra/libusb/APKBUILD b/extra/libusb/APKBUILD
new file mode 100644
index 0000000000..7234ad31df
--- /dev/null
+++ b/extra/libusb/APKBUILD
@@ -0,0 +1,20 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=libusb
3pkgver=1.0.1
4pkgrel=0
5pkgdesc="Library to enable user space application programs to communicate with USB devices"
6url="http://libusb.sourceforge.net/"
7license="LGPL"
8subpackages="$pkgname-dev"
9depends="uclibc"
10makedepends=""
11source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
12
13build ()
14{
15 cd "$srcdir"/$pkgname-$pkgver
16 ./configure --prefix=/usr --disable-build-docs
17 make || return 1
18 make DESTDIR="$pkgdir" install
19}
20md5sums="8fb0e066678a0d294894b5b2969cb4b3 libusb-1.0.1.tar.bz2"