aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-16 06:08:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-16 06:08:02 +0000
commit2ab1d1c7c89a02d9f5efd2703b00cf2ee94d9ea6 (patch)
tree47eb98f32c0bd453c034ccc77fe7d4076b403419
parent49797c5f1cbe61f87e9cb8dcce7368ce794a0d50 (diff)
downloadalpine_aports-2ab1d1c7c89a02d9f5efd2703b00cf2ee94d9ea6.tar.bz2
alpine_aports-2ab1d1c7c89a02d9f5efd2703b00cf2ee94d9ea6.tar.xz
alpine_aports-2ab1d1c7c89a02d9f5efd2703b00cf2ee94d9ea6.zip
core/busybox: fixes from upstream. enable blkid
-rw-r--r--core/busybox/APKBUILD10
-rw-r--r--core/busybox/busybox-1.14.2-df.patch134
-rw-r--r--core/busybox/busybox-1.14.2-ls.patch152
-rw-r--r--core/busybox/busybox-1.14.2-udhcpd.patch12
-rw-r--r--core/busybox/busyboxconfig36
5 files changed, 324 insertions, 20 deletions
diff --git a/core/busybox/APKBUILD b/core/busybox/APKBUILD
index 4eb47a589b..2673881e50 100644
--- a/core/busybox/APKBUILD
+++ b/core/busybox/APKBUILD
@@ -1,13 +1,16 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=busybox 2pkgname=busybox
3pkgver=1.14.2 3pkgver=1.14.2
4pkgrel=0 4pkgrel=1
5pkgdesc="Size optimized toolbox of many common UNIX utilities" 5pkgdesc="Size optimized toolbox of many common UNIX utilities"
6url=http://busybox.net 6url=http://busybox.net
7license=GPL-2 7license=GPL-2
8depends= 8depends=
9install="$pkgname.post-install $pkgname.post-upgrade" 9install="$pkgname.post-install $pkgname.post-upgrade"
10source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2 10source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
11 busybox-1.14.2-df.patch
12 busybox-1.14.2-ls.patch
13 busybox-1.14.2-udhcpd.patch
11 $pkgname-1.12.1-vi-path.patch 14 $pkgname-1.12.1-vi-path.patch
12 $pkgname-1.11.1-bb.patch 15 $pkgname-1.11.1-bb.patch
13 bb-tar-numeric-owner.patch 16 bb-tar-numeric-owner.patch
@@ -41,9 +44,12 @@ build() {
41} 44}
42 45
43md5sums="c13b09b4125688d5fca5c95a79bf814a busybox-1.14.2.tar.bz2 46md5sums="c13b09b4125688d5fca5c95a79bf814a busybox-1.14.2.tar.bz2
47a34c5e72c3f5308838ddc3bf70642136 busybox-1.14.2-df.patch
48b261df2f193bb97d8e3e59e02c957780 busybox-1.14.2-ls.patch
49ca9a77bd4f6000d2b031a2cee555fcd6 busybox-1.14.2-udhcpd.patch
44f5a8ae3145aa249868c1a1abc319c228 busybox-1.12.1-vi-path.patch 50f5a8ae3145aa249868c1a1abc319c228 busybox-1.12.1-vi-path.patch
454c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch 514c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
460b5b2d7db201f90cd08f4a3164ee29a1 bb-tar-numeric-owner.patch 520b5b2d7db201f90cd08f4a3164ee29a1 bb-tar-numeric-owner.patch
4756b78c358797cd15fb64719a48939267 busybox.post-install 5356b78c358797cd15fb64719a48939267 busybox.post-install
4856b78c358797cd15fb64719a48939267 busybox.post-upgrade 5456b78c358797cd15fb64719a48939267 busybox.post-upgrade
496d9cd13b546d9c6063d36c0d3d963887 busyboxconfig" 550be49dc673a849b5bf5e670db8c8c7b6 busyboxconfig"
diff --git a/core/busybox/busybox-1.14.2-df.patch b/core/busybox/busybox-1.14.2-df.patch
new file mode 100644
index 0000000000..7829f5fb7c
--- /dev/null
+++ b/core/busybox/busybox-1.14.2-df.patch
@@ -0,0 +1,134 @@
1--- busybox-1.14.2/coreutils/df.c Sun Jul 5 22:59:28 2009
2+++ busybox-1.14.2-df/coreutils/df.c Sun Jul 5 23:00:09 2009
3@@ -44,7 +44,6 @@
4 FILE *mount_table;
5 struct mntent *mount_entry;
6 struct statfs s;
7- static const char ignored_mounts[] ALIGN1 = "rootfs\0";
8
9 enum {
10 OPT_KILO = (1 << 0),
11@@ -120,7 +119,7 @@
12 mount_point = *argv++;
13 if (!mount_point)
14 break;
15- mount_entry = find_mount_point(mount_point, bb_path_mtab_file);
16+ mount_entry = find_mount_point(mount_point);
17 if (!mount_entry) {
18 bb_error_msg("%s: can't find mount point", mount_point);
19 set_error:
20@@ -154,8 +153,8 @@
21 ) / (blocks_used + s.f_bavail);
22 }
23
24- /* GNU coreutils 6.10 skip certain mounts, try to be compatible. */
25- if (index_in_strings(device, ignored_mounts) != -1)
26+ /* GNU coreutils 6.10 skips certain mounts, try to be compatible. */
27+ if (strcmp(device, "rootfs") == 0)
28 continue;
29
30 #ifdef WHY_WE_DO_IT_FOR_DEV_ROOT_ONLY
31--- busybox-1.14.2/include/libbb.h Sun Jul 5 22:59:31 2009
32+++ busybox-1.14.2-df/include/libbb.h Sun Jul 5 23:00:09 2009
33@@ -1025,7 +1025,7 @@
34
35 #ifdef HAVE_MNTENT_H
36 extern int match_fstype(const struct mntent *mt, const char *fstypes) FAST_FUNC;
37-extern struct mntent *find_mount_point(const char *name, const char *table) FAST_FUNC;
38+extern struct mntent *find_mount_point(const char *name) FAST_FUNC;
39 #endif
40 extern void erase_mtab(const char * name) FAST_FUNC;
41 extern unsigned int tty_baud_to_value(speed_t speed) FAST_FUNC;
42--- busybox-1.14.2/libbb/find_mount_point.c Sun Jul 5 22:59:24 2009
43+++ busybox-1.14.2-df/libbb/find_mount_point.c Sun Jul 5 23:00:09 2009
44@@ -17,7 +17,7 @@
45 * Given any other file (or directory), find the mount table entry for its
46 * filesystem.
47 */
48-struct mntent* FAST_FUNC find_mount_point(const char *name, const char *table)
49+struct mntent* FAST_FUNC find_mount_point(const char *name)
50 {
51 struct stat s;
52 dev_t mountDevice;
53@@ -25,27 +25,35 @@
54 struct mntent *mountEntry;
55
56 if (stat(name, &s) != 0)
57- return 0;
58+ return NULL;
59
60- if ((s.st_mode & S_IFMT) == S_IFBLK)
61+ if (S_ISBLK(s.st_mode))
62 mountDevice = s.st_rdev;
63 else
64 mountDevice = s.st_dev;
65
66
67- mountTable = setmntent(table ? table : bb_path_mtab_file, "r");
68+ mountTable = setmntent(bb_path_mtab_file, "r");
69 if (!mountTable)
70 return 0;
71
72- while ((mountEntry = getmntent(mountTable)) != 0) {
73+ while ((mountEntry = getmntent(mountTable)) != NULL) {
74+ /* rootfs mount in Linux 2.6 exists always,
75+ * and it makes sense to always ignore it.
76+ * Otherwise people can't reference their "real" root! */
77+ if (strcmp(mountEntry->mnt_fsname, "rootfs") == 0)
78+ continue;
79+
80 if (strcmp(name, mountEntry->mnt_dir) == 0
81 || strcmp(name, mountEntry->mnt_fsname) == 0
82 ) { /* String match. */
83 break;
84 }
85- if (stat(mountEntry->mnt_fsname, &s) == 0 && s.st_rdev == mountDevice) /* Match the device. */
86+ /* Match the device. */
87+ if (stat(mountEntry->mnt_fsname, &s) == 0 && s.st_rdev == mountDevice)
88 break;
89- if (stat(mountEntry->mnt_dir, &s) == 0 && s.st_dev == mountDevice) /* Match the directory's mount point. */
90+ /* Match the directory's mount point. */
91+ if (stat(mountEntry->mnt_dir, &s) == 0 && s.st_dev == mountDevice)
92 break;
93 }
94 endmntent(mountTable);
95--- busybox-1.14.2/util-linux/mkfs_minix.c Sun Jul 5 22:59:30 2009
96+++ busybox-1.14.2-df/util-linux/mkfs_minix.c Sun Jul 5 23:00:09 2009
97@@ -624,7 +624,6 @@
98 int mkfs_minix_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
99 int mkfs_minix_main(int argc UNUSED_PARAM, char **argv)
100 {
101- struct mntent *mp;
102 unsigned opt;
103 char *tmp;
104 struct stat statbuf;
105@@ -683,11 +682,8 @@
106 G.total_blocks = 65535;
107
108 /* Check if it is mounted */
109- mp = find_mount_point(G.device_name, NULL);
110- if (mp && strcmp(G.device_name, mp->mnt_fsname) == 0)
111- bb_error_msg_and_die("%s is mounted on %s; "
112- "refusing to make a filesystem",
113- G.device_name, mp->mnt_dir);
114+ if (find_mount_point(G.device_name))
115+ bb_error_msg_and_die("can't format mounted filesystem");
116
117 xmove_fd(xopen(G.device_name, O_RDWR), dev_fd);
118 if (fstat(dev_fd, &statbuf) < 0)
119--- busybox-1.14.2/util-linux/mkfs_vfat.c Sun Jul 5 22:59:30 2009
120+++ busybox-1.14.2-df/util-linux/mkfs_vfat.c Sun Jul 5 23:00:35 2009
121@@ -273,10 +273,10 @@
122 device_num == 0x0d00 || // xd
123 device_num == 0x1600 ) // hdc, hdd
124 )
125- bb_error_msg_and_die("Will not try to make filesystem on full-disk device (use -I if wanted)");
126+ bb_error_msg_and_die("will not try to make filesystem on full-disk device (use -I if wanted)");
127 // can't work on mounted filesystems
128- if (find_mount_point(device_name, NULL))
129- bb_error_msg_and_die("Can't format mounted filesystem");
130+ if (find_mount_point(device_name))
131+ bb_error_msg_and_die("can't format mounted filesystem");
132 #endif
133 // get true sector size
134 // (parameter must be int*, not long* or size_t*)
diff --git a/core/busybox/busybox-1.14.2-ls.patch b/core/busybox/busybox-1.14.2-ls.patch
new file mode 100644
index 0000000000..64e0a94f37
--- /dev/null
+++ b/core/busybox/busybox-1.14.2-ls.patch
@@ -0,0 +1,152 @@
1diff -urpN busybox-1.14.2/coreutils/ls.c busybox-1.14.2-ls/coreutils/ls.c
2--- busybox-1.14.2/coreutils/ls.c 2009-06-22 00:40:29.000000000 +0200
3+++ busybox-1.14.2-ls/coreutils/ls.c 2009-07-03 12:46:16.000000000 +0200
4@@ -144,8 +144,7 @@ static const char ls_options[] ALIGN1 =
5 USE_FEATURE_LS_FOLLOWLINKS("L") /* 1, 24 */
6 USE_FEATURE_LS_RECURSIVE("R") /* 1, 25 */
7 USE_FEATURE_HUMAN_READABLE("h") /* 1, 26 */
8- USE_SELINUX("K") /* 1, 27 */
9- USE_SELINUX("Z") /* 1, 28 */
10+ USE_SELINUX("KZ") /* 2, 28 */
11 USE_FEATURE_AUTOWIDTH("T:w:") /* 2, 30 */
12 ;
13 enum {
14@@ -162,6 +161,16 @@ enum {
15 OPT_Q = (1 << 10),
16 //OPT_A = (1 << 11),
17 //OPT_k = (1 << 12),
18+ OPTBIT_color = 13
19+ + 4 * ENABLE_FEATURE_LS_TIMESTAMPS
20+ + 4 * ENABLE_FEATURE_LS_SORTFILES
21+ + 2 * ENABLE_FEATURE_LS_FILETYPES
22+ + 1 * ENABLE_FEATURE_LS_FOLLOWLINKS
23+ + 1 * ENABLE_FEATURE_LS_RECURSIVE
24+ + 1 * ENABLE_FEATURE_HUMAN_READABLE
25+ + 2 * ENABLE_SELINUX
26+ + 2 * ENABLE_FEATURE_AUTOWIDTH,
27+ OPT_color = 1 << OPTBIT_color,
28 };
29
30 enum {
31@@ -889,16 +898,6 @@ static int list_single(const struct dnod
32 }
33
34
35-/* colored LS support by JaWi, janwillem.janssen@lxtreme.nl */
36-#if ENABLE_FEATURE_LS_COLOR
37-/* long option entry used only for --color, which has no short option
38- * equivalent */
39-static const char ls_color_opt[] ALIGN1 =
40- "color\0" Optional_argument "\xff" /* no short equivalent */
41- ;
42-#endif
43-
44-
45 int ls_main(int argc UNUSED_PARAM, char **argv)
46 {
47 struct dnode **dnd;
48@@ -911,8 +910,25 @@ int ls_main(int argc UNUSED_PARAM, char
49 int dnfiles;
50 int dndirs;
51 int i;
52+#if ENABLE_FEATURE_LS_COLOR
53+ /* colored LS support by JaWi, janwillem.janssen@lxtreme.nl */
54+ /* coreutils 6.10:
55+ * # ls --color=BOGUS
56+ * ls: invalid argument 'BOGUS' for '--color'
57+ * Valid arguments are:
58+ * 'always', 'yes', 'force'
59+ * 'never', 'no', 'none'
60+ * 'auto', 'tty', 'if-tty'
61+ * (and substrings: "--color=alwa" work too)
62+ */
63+ static const char ls_longopts[] ALIGN1 =
64+ "color\0" Optional_argument "\xff"; /* no short equivalent */
65+ static const char color_str[] ALIGN1 =
66+ "always\0""yes\0""force\0"
67+ "auto\0""tty\0""if-tty\0";
68 /* need to initialize since --color has _an optional_ argument */
69- USE_FEATURE_LS_COLOR(const char *color_opt = "always";)
70+ const char *color_opt = color_str; /* "always" */
71+#endif
72
73 INIT_G();
74
75@@ -927,7 +943,7 @@ int ls_main(int argc UNUSED_PARAM, char
76 #endif
77
78 /* process options */
79- USE_FEATURE_LS_COLOR(applet_long_options = ls_color_opt;)
80+ USE_FEATURE_LS_COLOR(applet_long_options = ls_longopts;)
81 #if ENABLE_FEATURE_AUTOWIDTH
82 opt_complementary = "T+:w+"; /* -T N, -w N */
83 opt = getopt32(argv, ls_options, &tabstops, &terminal_width
84@@ -966,13 +982,20 @@ int ls_main(int argc UNUSED_PARAM, char
85 if (!p || (p[0] && strcmp(p, "none") != 0))
86 show_color = 1;
87 }
88- if (opt & (1 << i)) { /* next flag after short options */
89- if (strcmp("always", color_opt) == 0)
90- show_color = 1;
91- else if (strcmp("never", color_opt) == 0)
92+ if (opt & OPT_color) {
93+ if (color_opt[0] == 'n')
94 show_color = 0;
95- else if (strcmp("auto", color_opt) == 0 && isatty(STDOUT_FILENO))
96- show_color = 1;
97+ else switch (index_in_substrings(color_str, color_opt)) {
98+ case 3:
99+ case 4:
100+ case 5:
101+ if (isatty(STDOUT_FILENO)) {
102+ case 0:
103+ case 1:
104+ case 2:
105+ show_color = 1;
106+ }
107+ }
108 }
109 #endif
110
111diff -urpN busybox-1.14.2/testsuite/ls/ls-1-works busybox-1.14.2-ls/testsuite/ls/ls-1-works
112--- busybox-1.14.2/testsuite/ls/ls-1-works 2009-06-22 00:32:00.000000000 +0200
113+++ busybox-1.14.2-ls/testsuite/ls/ls-1-works 2009-07-02 14:28:45.000000000 +0200
114@@ -1,4 +1,4 @@
115 [ -n "$d" ] || d=..
116-ls -1 "$d" > logfile.gnu
117-busybox ls -1 "$d" > logfile.bb
118-cmp logfile.gnu logfile.bb
119+LC_ALL=C ls -1 "$d" > logfile.gnu
120+LC_ALL=C busybox ls -1 "$d" > logfile.bb
121+diff -ubw logfile.gnu logfile.bb
122diff -urpN busybox-1.14.2/testsuite/ls/ls-h-works busybox-1.14.2-ls/testsuite/ls/ls-h-works
123--- busybox-1.14.2/testsuite/ls/ls-h-works 2009-06-22 00:32:00.000000000 +0200
124+++ busybox-1.14.2-ls/testsuite/ls/ls-h-works 2009-07-02 14:28:45.000000000 +0200
125@@ -1,4 +1,4 @@
126 [ -n "$d" ] || d=..
127-ls -h "$d" > logfile.gnu
128-busybox ls -h "$d" > logfile.bb
129-cmp logfile.gnu logfile.bb
130+LC_ALL=C ls -h "$d" > logfile.gnu
131+LC_ALL=C busybox ls -h "$d" > logfile.bb
132+diff -ubw logfile.gnu logfile.bb
133diff -urpN busybox-1.14.2/testsuite/ls/ls-l-works busybox-1.14.2-ls/testsuite/ls/ls-l-works
134--- busybox-1.14.2/testsuite/ls/ls-l-works 2009-06-22 00:32:00.000000000 +0200
135+++ busybox-1.14.2-ls/testsuite/ls/ls-l-works 2009-07-02 14:28:45.000000000 +0200
136@@ -1,4 +1,4 @@
137 [ -n "$d" ] || d=..
138 LC_ALL=C ls -l "$d" > logfile.gnu
139-busybox ls -l "$d" > logfile.bb
140-diff -w logfile.gnu logfile.bb
141+LC_ALL=C busybox ls -l "$d" > logfile.bb
142+diff -ubw logfile.gnu logfile.bb
143diff -urpN busybox-1.14.2/testsuite/ls/ls-s-works busybox-1.14.2-ls/testsuite/ls/ls-s-works
144--- busybox-1.14.2/testsuite/ls/ls-s-works 2009-06-22 00:32:00.000000000 +0200
145+++ busybox-1.14.2-ls/testsuite/ls/ls-s-works 2009-07-02 14:28:45.000000000 +0200
146@@ -1,4 +1,4 @@
147 [ -n "$d" ] || d=..
148 LC_ALL=C ls -1s "$d" > logfile.gnu
149-busybox ls -1s "$d" > logfile.bb
150-cmp logfile.gnu logfile.bb
151+LC_ALL=C busybox ls -1s "$d" > logfile.bb
152+diff -ubw logfile.gnu logfile.bb
diff --git a/core/busybox/busybox-1.14.2-udhcpd.patch b/core/busybox/busybox-1.14.2-udhcpd.patch
new file mode 100644
index 0000000000..a1502b41f6
--- /dev/null
+++ b/core/busybox/busybox-1.14.2-udhcpd.patch
@@ -0,0 +1,12 @@
1diff -urpN busybox-1.14.2/networking/udhcp/files.c busybox-1.14.2-udhcpd/networking/udhcp/files.c
2--- busybox-1.14.2/networking/udhcp/files.c 2009-06-22 00:40:29.000000000 +0200
3+++ busybox-1.14.2-udhcpd/networking/udhcp/files.c 2009-07-07 14:58:39.000000000 +0200
4@@ -420,7 +420,7 @@ void FAST_FUNC read_leases(const char *f
5 continue;
6 /* NB: add_lease takes "relative time", IOW,
7 * lease duration, not lease deadline. */
8- if (!(add_lease(lease.chaddr, lease.yiaddr, expires, lease.hostname))) {
9+ if (!(add_lease(lease.chaddr, lease.yiaddr, expires, NULL /* was lease.hostname. bug in add_lease, disabled */ ))) {
10 bb_error_msg("too many leases while loading %s", file);
11 break;
12 }
diff --git a/core/busybox/busyboxconfig b/core/busybox/busyboxconfig
index 514886170e..38f0a19f4c 100644
--- a/core/busybox/busyboxconfig
+++ b/core/busybox/busyboxconfig
@@ -1,7 +1,7 @@
1# 1#
2# Automatically generated make config: don't edit 2# Automatically generated make config: don't edit
3# Busybox version: 1.14.1 3# Busybox version: 1.14.2
4# Fri Jun 12 06:14:14 2009 4# Wed Jul 15 18:07:16 2009
5# 5#
6CONFIG_HAVE_DOT_CONFIG=y 6CONFIG_HAVE_DOT_CONFIG=y
7 7
@@ -458,7 +458,7 @@ CONFIG_DEFAULT_DEPMOD_FILE="modules.dep"
458# 458#
459CONFIG_ACPID=y 459CONFIG_ACPID=y
460CONFIG_FEATURE_ACPID_COMPAT=y 460CONFIG_FEATURE_ACPID_COMPAT=y
461# CONFIG_BLKID is not set 461CONFIG_BLKID=y
462CONFIG_DMESG=y 462CONFIG_DMESG=y
463CONFIG_FEATURE_DMESG_PRETTY=y 463CONFIG_FEATURE_DMESG_PRETTY=y
464CONFIG_FBSET=y 464CONFIG_FBSET=y
@@ -474,7 +474,7 @@ CONFIG_FEATURE_SGI_LABEL=y
474CONFIG_FEATURE_SUN_LABEL=y 474CONFIG_FEATURE_SUN_LABEL=y
475CONFIG_FEATURE_OSF_LABEL=y 475CONFIG_FEATURE_OSF_LABEL=y
476CONFIG_FEATURE_FDISK_ADVANCED=y 476CONFIG_FEATURE_FDISK_ADVANCED=y
477# CONFIG_FINDFS is not set 477CONFIG_FINDFS=y
478# CONFIG_FREERAMDISK is not set 478# CONFIG_FREERAMDISK is not set
479# CONFIG_FSCK_MINIX is not set 479# CONFIG_FSCK_MINIX is not set
480# CONFIG_MKFS_MINIX is not set 480# CONFIG_MKFS_MINIX is not set
@@ -500,28 +500,28 @@ CONFIG_MKSWAP=y
500# CONFIG_FEATURE_MKSWAP_V0 is not set 500# CONFIG_FEATURE_MKSWAP_V0 is not set
501CONFIG_MORE=y 501CONFIG_MORE=y
502CONFIG_FEATURE_USE_TERMIOS=y 502CONFIG_FEATURE_USE_TERMIOS=y
503# CONFIG_VOLUMEID is not set 503CONFIG_VOLUMEID=y
504# CONFIG_FEATURE_VOLUMEID_EXT is not set 504CONFIG_FEATURE_VOLUMEID_EXT=y
505# CONFIG_FEATURE_VOLUMEID_REISERFS is not set 505CONFIG_FEATURE_VOLUMEID_REISERFS=y
506# CONFIG_FEATURE_VOLUMEID_FAT is not set 506CONFIG_FEATURE_VOLUMEID_FAT=y
507# CONFIG_FEATURE_VOLUMEID_HFS is not set 507# CONFIG_FEATURE_VOLUMEID_HFS is not set
508# CONFIG_FEATURE_VOLUMEID_JFS is not set 508# CONFIG_FEATURE_VOLUMEID_JFS is not set
509# CONFIG_FEATURE_VOLUMEID_XFS is not set 509CONFIG_FEATURE_VOLUMEID_XFS=y
510# CONFIG_FEATURE_VOLUMEID_NTFS is not set 510CONFIG_FEATURE_VOLUMEID_NTFS=y
511# CONFIG_FEATURE_VOLUMEID_ISO9660 is not set 511CONFIG_FEATURE_VOLUMEID_ISO9660=y
512# CONFIG_FEATURE_VOLUMEID_UDF is not set 512CONFIG_FEATURE_VOLUMEID_UDF=y
513# CONFIG_FEATURE_VOLUMEID_LUKS is not set 513CONFIG_FEATURE_VOLUMEID_LUKS=y
514# CONFIG_FEATURE_VOLUMEID_LINUXSWAP is not set 514CONFIG_FEATURE_VOLUMEID_LINUXSWAP=y
515# CONFIG_FEATURE_VOLUMEID_CRAMFS is not set 515CONFIG_FEATURE_VOLUMEID_CRAMFS=y
516# CONFIG_FEATURE_VOLUMEID_ROMFS is not set 516# CONFIG_FEATURE_VOLUMEID_ROMFS is not set
517# CONFIG_FEATURE_VOLUMEID_SYSV is not set 517# CONFIG_FEATURE_VOLUMEID_SYSV is not set
518# CONFIG_FEATURE_VOLUMEID_OCFS2 is not set 518CONFIG_FEATURE_VOLUMEID_OCFS2=y
519# CONFIG_FEATURE_VOLUMEID_LINUXRAID is not set 519CONFIG_FEATURE_VOLUMEID_LINUXRAID=y
520CONFIG_MOUNT=y 520CONFIG_MOUNT=y
521CONFIG_FEATURE_MOUNT_FAKE=y 521CONFIG_FEATURE_MOUNT_FAKE=y
522CONFIG_FEATURE_MOUNT_VERBOSE=y 522CONFIG_FEATURE_MOUNT_VERBOSE=y
523CONFIG_FEATURE_MOUNT_HELPERS=y 523CONFIG_FEATURE_MOUNT_HELPERS=y
524# CONFIG_FEATURE_MOUNT_LABEL is not set 524CONFIG_FEATURE_MOUNT_LABEL=y
525CONFIG_FEATURE_MOUNT_NFS=y 525CONFIG_FEATURE_MOUNT_NFS=y
526CONFIG_FEATURE_MOUNT_CIFS=y 526CONFIG_FEATURE_MOUNT_CIFS=y
527CONFIG_FEATURE_MOUNT_FLAGS=y 527CONFIG_FEATURE_MOUNT_FLAGS=y