aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-17 11:05:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-17 11:05:46 +0000
commit3ac865d7266d2b58c2c6222114b9263e4e27654d (patch)
tree9643c181d820554b6fbec01ad356658a4a7a9e6b
parentb1461e068f3ce595a1ca40f038f40e906e89a0a5 (diff)
downloadalpine_aports-3ac865d7266d2b58c2c6222114b9263e4e27654d.tar.bz2
alpine_aports-3ac865d7266d2b58c2c6222114b9263e4e27654d.tar.xz
alpine_aports-3ac865d7266d2b58c2c6222114b9263e4e27654d.zip
extra/postfix: pcre handles regexp as well
Fixes #66
-rw-r--r--extra/postfix/APKBUILD6
-rw-r--r--extra/postfix/dynamicmaps.cf3
-rw-r--r--extra/postfix/postfix-pcre.post-install6
3 files changed, 11 insertions, 4 deletions
diff --git a/extra/postfix/APKBUILD b/extra/postfix/APKBUILD
index 534bffb21b..0cddde296e 100644
--- a/extra/postfix/APKBUILD
+++ b/extra/postfix/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=postfix 2pkgname=postfix
3pkgver=2.6.2 3pkgver=2.6.2
4pkgrel=0 4pkgrel=2
5pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)" 5pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
6url="http://www.postfix.org/" 6url="http://www.postfix.org/"
7license="IPL-1" 7license="IPL-1"
@@ -144,8 +144,8 @@ md5sums="1f0edbd521d2b0473626f4d61e8bb4eb postfix-2.6.2.tar.gz
1442bfc3864183694e5484ac073bb0cb7ef postfix.pre-install 1442bfc3864183694e5484ac073bb0cb7ef postfix.pre-install
1450064d45c2c8a46c374b55c4abc46cfb2 postfix.post-install 1450064d45c2c8a46c374b55c4abc46cfb2 postfix.post-install
146d45552cfdcd911d0934c0cb7816c4011 postfix-2.6.1-dynamicmaps.patch 146d45552cfdcd911d0934c0cb7816c4011 postfix-2.6.1-dynamicmaps.patch
1470efff9b4bb493ad2ff0b9915cb244d14 dynamicmaps.cf 147c653c222c8504c6f36d67eb342c8bf51 dynamicmaps.cf
1482ebe51a882eb9d6d7866583eb6af3969 postfix-ldap.post-install 1482ebe51a882eb9d6d7866583eb6af3969 postfix-ldap.post-install
1492ebe51a882eb9d6d7866583eb6af3969 postfix-mysql.post-install 1492ebe51a882eb9d6d7866583eb6af3969 postfix-mysql.post-install
1502ebe51a882eb9d6d7866583eb6af3969 postfix-pcre.post-install 1505b00c3b4c463102c1876bf343b88189c postfix-pcre.post-install
1512ebe51a882eb9d6d7866583eb6af3969 postfix-pgsql.post-install" 1512ebe51a882eb9d6d7866583eb6af3969 postfix-pgsql.post-install"
diff --git a/extra/postfix/dynamicmaps.cf b/extra/postfix/dynamicmaps.cf
index 49d25480c0..b8b8cd25b2 100644
--- a/extra/postfix/dynamicmaps.cf
+++ b/extra/postfix/dynamicmaps.cf
@@ -8,7 +8,8 @@
8#ldap /usr/lib/postfix/dict_ldap.so dict_ldap_open 8#ldap /usr/lib/postfix/dict_ldap.so dict_ldap_open
9#mysql /usr/lib/postfix/dict_mysql.so dict_mysql_open 9#mysql /usr/lib/postfix/dict_mysql.so dict_mysql_open
10#pcre /usr/lib/postfix/dict_pcre.so dict_pcre_open 10#pcre /usr/lib/postfix/dict_pcre.so dict_pcre_open
11#pgsq /usr/lib/postfix/dict_pgsql.so dict_pgsql_open 11#regexp /usr/lib/postfix/dict_pcre.so dict_pcre_open
12#pgsql /usr/lib/postfix/dict_pgsql.so dict_pgsql_open
12 13
13# apk tools will manage the lines below 14# apk tools will manage the lines below
14## AUTO BEGIN ## 15## AUTO BEGIN ##
diff --git a/extra/postfix/postfix-pcre.post-install b/extra/postfix/postfix-pcre.post-install
index b8d23833b6..6962486fe1 100644
--- a/extra/postfix/postfix-pcre.post-install
+++ b/extra/postfix/postfix-pcre.post-install
@@ -12,8 +12,14 @@ if cd /usr/lib/postfix/; then
12 m=${i#dict_} 12 m=${i#dict_}
13 m=${m%.so} 13 m=${m%.so}
14 echo -e "$m\t/usr/lib/postfix/$i\tdict_${m}_open" 14 echo -e "$m\t/usr/lib/postfix/$i\tdict_${m}_open"
15 # pcre also handles regexp
16 if [ "$m" = "pcre" ]; then
17 echo -e "regexp\t/usr/lib/postfix/$i\tdict_${m}_open"
18 fi
19
15 done 20 done
16fi 21fi
17 22
18echo '## AUTO END ##' 23echo '## AUTO END ##'
19) >> $conf 24) >> $conf
25