aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-16 19:47:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-16 19:47:19 +0000
commitb1aa63bbcc26e272aedc0b1097728d3d599b907e (patch)
treebc7739cce8d437def41698b1f107b65d60c59f0f
parent95cb6b291e5e60abb8c8e68da3a11ecfd8895281 (diff)
downloadalpine_aports-b1aa63bbcc26e272aedc0b1097728d3d599b907e.tar.bz2
alpine_aports-b1aa63bbcc26e272aedc0b1097728d3d599b907e.tar.xz
alpine_aports-b1aa63bbcc26e272aedc0b1097728d3d599b907e.zip
x11/feh: new aport
feh is a fast, lightweight image viewer which uses imlib2 http://www.linuxbrit.co.uk/feh/
-rw-r--r--x11/feh/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11/feh/APKBUILD b/x11/feh/APKBUILD
new file mode 100644
index 0000000000..a609b8d994
--- /dev/null
+++ b/x11/feh/APKBUILD
@@ -0,0 +1,22 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=feh
3pkgver=1.3.4
4pkgrel=0
5pkgdesc="feh is a fast, lightweight image viewer which uses imlib2"
6url="http://www.linuxbrit.co.uk/feh/"
7license="MIT"
8subpackages="$pkgname-doc"
9depends=
10makedepends="libxt-dev libpng-dev giblib-dev imlib2-dev jpeg-dev"
11source="http://linuxbrit.co.uk/downloads/$pkgname-$pkgver.tar.gz"
12
13build ()
14{
15 cd $srcdir/$pkgname-$pkgver
16 ./configure --prefix=/usr \
17 --mandir=/usr/share/man || return 1
18 make || return 1
19 make DESTDIR=$pkgdir docsdir=/usr/share/doc/feh install || return 1
20 install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
21}
22md5sums="3d35ba3d2f0693b019800787f1103891 feh-1.3.4.tar.gz"