aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-14 14:39:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-14 14:39:29 +0000
commitca234242ab0e36b80dc6ee23d6a7b37ebe5332f4 (patch)
tree3610c0694484698bac8ae1732f9ff97229ce0afe
parent65798fc55f1477913f38d8b6c8c153ba54e1f835 (diff)
downloadalpine_aports-ca234242ab0e36b80dc6ee23d6a7b37ebe5332f4.tar.bz2
alpine_aports-ca234242ab0e36b80dc6ee23d6a7b37ebe5332f4.tar.xz
alpine_aports-ca234242ab0e36b80dc6ee23d6a7b37ebe5332f4.zip
core/abuild: fix stupid bug
-rw-r--r--core/abuild/0001-core-abuild-fix-options-order-to-apk-add.patch25
-rw-r--r--core/abuild/APKBUILD9
2 files changed, 32 insertions, 2 deletions
diff --git a/core/abuild/0001-core-abuild-fix-options-order-to-apk-add.patch b/core/abuild/0001-core-abuild-fix-options-order-to-apk-add.patch
new file mode 100644
index 0000000000..7a5c25a815
--- /dev/null
+++ b/core/abuild/0001-core-abuild-fix-options-order-to-apk-add.patch
@@ -0,0 +1,25 @@
1From 7c45a9dcafa1b4cd1f30c6453b76a3a29f6b9c8f Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Tue, 14 Jul 2009 14:37:33 +0000
4Subject: [PATCH] core/abuild: fix options order to apk add
5
6---
7 abuild.in | 2 +-
8 1 files changed, 1 insertions(+), 1 deletions(-)
9
10diff --git a/abuild.in b/abuild.in
11index 6dc2fb4..43cf68e 100755
12--- a/abuild.in
13+++ b/abuild.in
14@@ -724,7 +724,7 @@ builddeps() {
15 msg "Entering $dir"
16 cd "$dir" && $0 -k -r apkcache || return 1
17 done
18- $SUDO apk add --repo -u "$apkcache" \
19+ $SUDO apk add -u --repo "$apkcache" \
20 --virtual .makedepends-$pkgname $deps
21 }
22
23--
241.6.3.3
25
diff --git a/core/abuild/APKBUILD b/core/abuild/APKBUILD
index ab5f200b05..4122b36fd2 100644
--- a/core/abuild/APKBUILD
+++ b/core/abuild/APKBUILD
@@ -2,9 +2,10 @@
2pkgdesc="Script to build Alpine Packages" 2pkgdesc="Script to build Alpine Packages"
3pkgname=abuild 3pkgname=abuild
4pkgver=1.16 4pkgver=1.16
5pkgrel=0 5pkgrel=1
6url=http://git.alpinelinux.org/cgit/abuild/ 6url=http://git.alpinelinux.org/cgit/abuild/
7source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2 7source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
8 0001-core-abuild-fix-options-order-to-apk-add.patch
8 " 9 "
9depends="fakeroot file sudo pax-utils" 10depends="fakeroot file sudo pax-utils"
10license=GPL-2 11license=GPL-2
@@ -12,8 +13,12 @@ license=GPL-2
12build() { 13build() {
13 cd "$srcdir/$pkgname-$pkgver" 14 cd "$srcdir/$pkgname-$pkgver"
14 15
16 patch -p1 < ../0001-core-abuild-fix-options-order-to-apk-add.patch \
17 || return 1
18
15 make install DESTDIR="$pkgdir" 19 make install DESTDIR="$pkgdir"
16 install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf 20 install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
17} 21}
18 22
19md5sums="d6aa9ae0b28491c687f6575a6b219780 abuild-1.16.tar.bz2" 23md5sums="d6aa9ae0b28491c687f6575a6b219780 abuild-1.16.tar.bz2
2413ea88d46143b30d5c4fe261d6e80228 0001-core-abuild-fix-options-order-to-apk-add.patch"