aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 09:51:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 09:51:34 +0000
commit0837a73950a2461c249c24e1d2ec5e8bdcdedf52 (patch)
treead859f315ab779188a18c7959d321579dfce0dd3
parent8afe14323eecd84ed146fe7afbe13176ba595fbd (diff)
downloadalpine_aports-0837a73950a2461c249c24e1d2ec5e8bdcdedf52.tar.bz2
alpine_aports-0837a73950a2461c249c24e1d2ec5e8bdcdedf52.tar.xz
alpine_aports-0837a73950a2461c249c24e1d2ec5e8bdcdedf52.zip
core/file: upgrade to 5.00
disabled useless check for C++ while there
-rw-r--r--core/file/APKBUILD19
-rw-r--r--core/file/nocxx.patch15
2 files changed, 26 insertions, 8 deletions
diff --git a/core/file/APKBUILD b/core/file/APKBUILD
index a7fd0ffb28..50b9b8e6c4 100644
--- a/core/file/APKBUILD
+++ b/core/file/APKBUILD
@@ -1,19 +1,22 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=file 2pkgname=file
3pkgver=4.26 3pkgver=5.00
4pkgrel=1 4pkgrel=0
5pkgdesc="File type identification utility" 5pkgdesc="File type identification utility"
6url="http://www.darwinsys.com/file/" 6url="http://www.darwinsys.com/file/"
7license="custom" 7license="custom"
8depends="uclibc zlib" 8depends="uclibc zlib"
9source="ftp://ftp.astron.com/pub/file/file-4.26.tar.gz" 9source="ftp://ftp.astron.com/pub/file/file-$pkgver.tar.gz
10 nocxx.patch"
10subpackages="$pkgname-dev $pkgname-doc" 11subpackages="$pkgname-dev $pkgname-doc"
11 12
12build () 13build ()
13{ 14{
14 cd ${srcdir}/$pkgname-$pkgver; 15 cd "$srcdir"/$pkgname-$pkgver
15 ./configure --prefix=/usr --datadir=/usr/share/misc; 16 patch configure < ../nocxx.patch || return 1
16 make || return 1; 17 ./configure --prefix=/usr --datadir=/usr/share/misc
17 make DESTDIR=${pkgdir} install; 18 make || return 1
19 make DESTDIR="$pkgdir" install
18} 20}
19md5sums="74cd5466416136da30a4e69f74dbc7a0 file-4.26.tar.gz" 21md5sums="fd0b4ce55a756151629e06eaa3411e0c file-5.00.tar.gz
2228513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/core/file/nocxx.patch b/core/file/nocxx.patch
new file mode 100644
index 0000000000..beb1ab9006
--- /dev/null
+++ b/core/file/nocxx.patch
@@ -0,0 +1,15 @@
1--- a/configure 2004-12-07 21:34:23.205172545 +0000
2+++ b/configure 2004-12-07 21:37:17.726654782 +0000
3@@ -5148,10 +5148,8 @@
4 :
5 else
6 { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
7-See \`config.log' for more details." >&5
8-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
9-See \`config.log' for more details." >&2;}
10- { (exit 1); exit 1; }; }
11+See \`config.log' for more details." >&5;}
12+ { echo "C++ sucks, ignoring ..." >&5; }; }
13 fi
14
15 ac_ext=cc