aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-10 14:10:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-10 14:10:57 +0000
commit2a42d9d6eea91f6cb7458b1620d784dd83cdc188 (patch)
treecd0a73538d8333152e706101327a3d48bec59fcd
parent8f65ab9a12b89e9a504c136cca17d03771aca346 (diff)
downloadalpine_aports-2a42d9d6eea91f6cb7458b1620d784dd83cdc188.tar.bz2
alpine_aports-2a42d9d6eea91f6cb7458b1620d784dd83cdc188.tar.xz
alpine_aports-2a42d9d6eea91f6cb7458b1620d784dd83cdc188.zip
extra/v86d: new aport
userspace helper for uvesafb that runs x86 code in an emulated environment http://dev.gentoo.org/~spock/projects/uvesafb/
-rw-r--r--extra/v86d/APKBUILD20
-rw-r--r--extra/v86d/modprobe.uvesafb10
2 files changed, 30 insertions, 0 deletions
diff --git a/extra/v86d/APKBUILD b/extra/v86d/APKBUILD
new file mode 100644
index 0000000000..6a0b80c9b2
--- /dev/null
+++ b/extra/v86d/APKBUILD
@@ -0,0 +1,20 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=v86d
3pkgver=0.1.9
4pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
5url="http://dev.gentoo.org/~spock/projects/uvesafb/"
6license="GPL2"
7depends="uclibc"
8source="http://dev.gentoo.org/~spock/projects/uvesafb/archive/$pkgname-$pkgver.tar.bz2
9 modprobe.uvesafb"
10
11build ()
12{
13 cd "$srcdir"/v86d-$pkgver
14 ./configure --with-x86emu
15 make || return 1
16 make DESTDIR="$pkgdir" install || return 1
17 install -D -m644 "$srcdir"/modprobe.uvesafb "$pkgdir"/etc/modprobe.d/uvesafb || return 1
18}
19md5sums="ebbbc8e7013c9544b6ba6981add43831 v86d-0.1.9.tar.bz2
202d7cc8dc6a41916a13869212d0191147 modprobe.uvesafb"
diff --git a/extra/v86d/modprobe.uvesafb b/extra/v86d/modprobe.uvesafb
new file mode 100644
index 0000000000..5e46e10883
--- /dev/null
+++ b/extra/v86d/modprobe.uvesafb
@@ -0,0 +1,10 @@
1#
2# This file sets the parameters for uvesafb module.
3# The following format should be used:
4# options uvesafb mode=<xres>x<yres>[-<bpp>][@<refresh>] scroll=<ywrap|ypan|redraw> ...
5#
6# For more details see:
7# http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/fb/uvesafb.txt
8#
9
10options uvesafb mode_option=1024x768-32 scroll=ywrap