aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 12:27:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 12:27:09 +0000
commit6e046733632ba478e65e663f1bd3cc7aa1e237cc (patch)
tree7ff0ad78af75b626eac660c9c2cf5867eb6b4ebd
parent5382336f51a760bc177904ce8c14125bfe6a1f27 (diff)
downloadalpine_aports-6e046733632ba478e65e663f1bd3cc7aa1e237cc.tar.bz2
alpine_aports-6e046733632ba478e65e663f1bd3cc7aa1e237cc.tar.xz
alpine_aports-6e046733632ba478e65e663f1bd3cc7aa1e237cc.zip
extra/tdb: removed. provided by samba
-rw-r--r--extra/tdb/APKBUILD24
-rw-r--r--extra/tdb/tdb-1.0.6-gcc3.patch41
-rw-r--r--extra/tdb/tdb-1.0.6-no-gdbm.patch16
3 files changed, 0 insertions, 81 deletions
diff --git a/extra/tdb/APKBUILD b/extra/tdb/APKBUILD
deleted file mode 100644
index 4e9c2b8360..0000000000
--- a/extra/tdb/APKBUILD
+++ /dev/null
@@ -1,24 +0,0 @@
1pkgdesc="A Trivial Database"
2pkgname=tdb
3pkgver=1.0.6
4pkgrel=1
5url="http://sourceforge.net/projects/tdb"
6source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
7 $pkgname-1.0.6-gcc3.patch
8 $pkgname-1.0.6-no-gdbm.patch"
9license="GPL-2"
10
11subpackages="$pkgname-dev $pkgname-doc"
12depends="uclibc"
13
14build() {
15 cd $srcdir/$pkgname-$pkgver
16 patch -p1 -i $srcdir/$pkgname-1.0.6-gcc3.patch || return 1
17 patch -p0 -i $srcdir/$pkgname-1.0.6-no-gdbm.patch || return 1
18 ./configure --prefix=/usr --mandir=/usr/share/man
19 make || return 1
20 make install DESTDIR=$pkgdir
21}
22md5sums="6b643fdeb48304010dcd5f675e458b58 tdb-1.0.6.tar.gz
233dbbde1145303ad43730f2bc1bb3b82b tdb-1.0.6-gcc3.patch
248a4247a9e3c5af757cfa1d5c20733642 tdb-1.0.6-no-gdbm.patch"
diff --git a/extra/tdb/tdb-1.0.6-gcc3.patch b/extra/tdb/tdb-1.0.6-gcc3.patch
deleted file mode 100644
index a17afbac95..0000000000
--- a/extra/tdb/tdb-1.0.6-gcc3.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1--- tdb-1.0.6/tdbtool.c.old 2001-12-10 22:45:47.000000000 -0500
2+++ tdb-1.0.6/tdbtool.c 2003-10-02 22:41:51.000000000 -0400
3@@ -169,22 +169,22 @@
4
5 static void help(void)
6 {
7- printf("
8-tdbtool:
9- create dbname : create a database
10- open dbname : open an existing database
11- erase : erase the database
12- dump dumpname : dump the database as strings
13- insert key data : insert a record
14- store key data : store a record (replace)
15- show key : show a record by key
16- delete key : delete a record by key
17- list : print the database hash table and freelist
18- free : print the database freelist
19- 1 | first : print the first record
20- n | next : print the next record
21- q | quit : terminate
22- \\n : repeat 'next' command
23+ printf("\n\
24+tdbtool:\n\
25+ create dbname : create a database\n\
26+ open dbname : open an existing database\n\
27+ erase : erase the database\n\
28+ dump dumpname : dump the database as strings\n\
29+ insert key data : insert a record\n\
30+ store key data : store a record (replace)\n\
31+ show key : show a record by key\n\
32+ delete key : delete a record by key\n\
33+ list : print the database hash table and freelist\n\
34+ free : print the database freelist\n\
35+ 1 | first : print the first record\n\
36+ n | next : print the next record\n\
37+ q | quit : terminate\n\
38+ \\n : repeat 'next' command\n\
39 ");
40 }
41
diff --git a/extra/tdb/tdb-1.0.6-no-gdbm.patch b/extra/tdb/tdb-1.0.6-no-gdbm.patch
deleted file mode 100644
index 0f47030767..0000000000
--- a/extra/tdb/tdb-1.0.6-no-gdbm.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1gdbm is only used in tdbspeed and tdbtest which never get
2installed, so lets go ahead and force disable gdbm "support"
3
4http://bugs.gentoo.org/113824
5
6--- Makefile.in
7+++ Makefile.in
8@@ -80,7 +80,7 @@
9 @BUILD_TDBTORTURE_TRUE@TDBTORTURE = tdbtorture
10 @BUILD_TDBTORTURE_FALSE@TDBTORTURE =
11
12-noinst_PROGRAMS = tdbspeed tdbiterate $(TDBTEST) $(TDBTORTURE)
13+noinst_PROGRAMS = tdbiterate $(TDBTORTURE)
14 bin_PROGRAMS = tdbtool tdbdump
15
16 lib_LTLIBRARIES = libtdb.la