aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-10 13:44:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-10 13:44:15 +0000
commite88a1a6950ebb56009db8eaf1756dd6b54a04107 (patch)
tree2c97071653a281ad12ad603debf5e2b072a3e4dc
parent46b98efa7d3fa629fb1819ce0cbebb700c862550 (diff)
downloadalpine_aports-e88a1a6950ebb56009db8eaf1756dd6b54a04107.tar.bz2
alpine_aports-e88a1a6950ebb56009db8eaf1756dd6b54a04107.tar.xz
alpine_aports-e88a1a6950ebb56009db8eaf1756dd6b54a04107.zip
testing/ucarp: added patch for useless C++ configure test
-rw-r--r--testing/ucarp/APKBUILD3
-rw-r--r--testing/ucarp/nocxx.patch15
2 files changed, 18 insertions, 0 deletions
diff --git a/testing/ucarp/APKBUILD b/testing/ucarp/APKBUILD
index ed35064f11..4deee45da9 100644
--- a/testing/ucarp/APKBUILD
+++ b/testing/ucarp/APKBUILD
@@ -11,11 +11,13 @@ makedepends="libpcap-dev"
11install= 11install=
12subpackages="" 12subpackages=""
13source="http://download.pureftpd.org/pub/ucarp/$pkgname-$pkgver.tar.gz 13source="http://download.pureftpd.org/pub/ucarp/$pkgname-$pkgver.tar.gz
14 nocxx.patch
14 ucarp.initd 15 ucarp.initd
15 ucarp.confd" 16 ucarp.confd"
16 17
17build() { 18build() {
18 cd "$srcdir/$pkgname-$pkgver" 19 cd "$srcdir/$pkgname-$pkgver"
20 patch configure < ../nocxx.patch || return 1
19 21
20 ./configure --prefix=/usr \ 22 ./configure --prefix=/usr \
21 --sysconfdir=/etc \ 23 --sysconfdir=/etc \
@@ -29,5 +31,6 @@ build() {
29} 31}
30 32
31md5sums="ba585233e73f0dbce80427d04f431048 ucarp-1.5.tar.gz 33md5sums="ba585233e73f0dbce80427d04f431048 ucarp-1.5.tar.gz
3428513788ba4d556ccd538867dc6205ab nocxx.patch
32e8f1e2fd144797524025343603dbe2b8 ucarp.initd 35e8f1e2fd144797524025343603dbe2b8 ucarp.initd
33bf914f6ce4fe4fea33a45d4d5b2c1fff ucarp.confd" 36bf914f6ce4fe4fea33a45d4d5b2c1fff ucarp.confd"
diff --git a/testing/ucarp/nocxx.patch b/testing/ucarp/nocxx.patch
new file mode 100644
index 0000000000..beb1ab9006
--- /dev/null
+++ b/testing/ucarp/nocxx.patch
@@ -0,0 +1,15 @@
1--- a/configure 2004-12-07 21:34:23.205172545 +0000
2+++ b/configure 2004-12-07 21:37:17.726654782 +0000
3@@ -5148,10 +5148,8 @@
4 :
5 else
6 { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
7-See \`config.log' for more details." >&5
8-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
9-See \`config.log' for more details." >&2;}
10- { (exit 1); exit 1; }; }
11+See \`config.log' for more details." >&5;}
12+ { echo "C++ sucks, ignoring ..." >&5; }; }
13 fi
14
15 ac_ext=cc