aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-25 08:30:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-25 08:30:58 +0000
commit050e7af13e12b166050838451dac0960e009465d (patch)
tree39ee4bcccd328384ef84bea88a566e0dad0f7822
parentb3e795d697b4ff477ecc7960dbc455d8d7568112 (diff)
downloadalpine_aports-050e7af13e12b166050838451dac0960e009465d.tar.bz2
alpine_aports-050e7af13e12b166050838451dac0960e009465d.tar.xz
alpine_aports-050e7af13e12b166050838451dac0960e009465d.zip
testing/vlc: new aport
A multi-platform MPEG, VCD/DVD, and DivX player http://www.videolan.org/vlc/
-rw-r--r--testing/vlc/APKBUILD90
-rw-r--r--testing/vlc/uclibc.patch65
2 files changed, 155 insertions, 0 deletions
diff --git a/testing/vlc/APKBUILD b/testing/vlc/APKBUILD
new file mode 100644
index 0000000000..d28ddf074c
--- /dev/null
+++ b/testing/vlc/APKBUILD
@@ -0,0 +1,90 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=vlc
3pkgver=1.0.0
4pkgrel=0
5pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
6url="http://www.videolan.org/vlc/"
7license="GPL-2"
8subpackages="$pkgname-dev $pkgname-doc"
9#depends="libnotify a52dec fluidsynth zvbi libdvbpsi lirc-utils libdca hal
10# libproxy sdl_image libdvdnav>=4.1.3 lua libxv libv4l libcddb smbclient
11# libmatroska taglib sysfsutils libmpcdec ffmpeg>=0.5 libshout libmad
12# qt fribidi libmpeg2 libmodplug avahi ttf-dejavu"
13depends="ttf-dejavu"
14makedepends="
15 a52dec-dev
16 alsa-lib-dev
17 dbus-dev
18 ffmpeg-dev
19 fribidi-dev
20 gtk+-dev
21 libgcrypt-dev
22 libice-dev
23 libiconv-dev
24 libmad-dev
25 libmpeg2-dev
26 libnotify-dev
27 libogg-dev
28 libsm-dev
29 libx11-dev
30 libxext-dev
31 libxv-dev
32 lua-dev
33 mesa-dev
34 pkgconfig
35 sdl-dev
36 sysfsutils-dev
37 x264-dev
38 "
39source="http://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
40 uclibc.patch
41 "
42
43build ()
44{
45 cd "$srcdir"/$pkgname-$pkgver
46 sed -i -e 's:/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf:/usr/share/fonts/TTF/DejaVuSerif-Bold.ttf:' modules/misc/freetype.c
47
48 patch -p1 < ../uclibc.patch || return 1
49 export CFLAGS="$CFLAGS -D_GNU_SOURCE"
50
51 ./configure --prefix=/usr \
52 --disable-mmx \
53 --disable-nls \
54 --disable-optimizations \
55 --disable-qt4 --disable-skins2 \
56 --disable-rpath \
57 --enable-httpd \
58 --enable-realrtsp \
59 --enable-sout \
60 --enable-vlm \
61 || return 1
62
63# --enable-dvdread \
64# --enable-dvdnav \
65# --enable-qt4 \
66# --enable-faad \
67# --enable-skins2 \
68# --enable-dvb \
69# --enable-v4l \
70# --enable-theora \
71# --enable-flac \
72# --enable-snapshot \
73# --enable-hal \
74# --enable-dbus \
75# --enable-dbus-control \
76# --enable-lirc \
77# --enable-shout \
78# --enable-pvr \
79
80 make || return 1
81 make DESTDIR="$pkgdir"/ install || return 1
82 for res in 16 32 48 128; do
83 install -D -m644 share/vlc${res}x${res}.png \
84 "$pkgdir"/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png || return 1
85 done
86 rm -rf "$pkgdir"/usr/lib/mozilla
87}
88
89md5sums="fc78904ab5fa73f518d8fe4e852e7f67 vlc-1.0.0.tar.bz2
902a16bf6c14a94f41490872aa189db755 uclibc.patch"
diff --git a/testing/vlc/uclibc.patch b/testing/vlc/uclibc.patch
new file mode 100644
index 0000000000..f71b189a4c
--- /dev/null
+++ b/testing/vlc/uclibc.patch
@@ -0,0 +1,65 @@
1--- a/src/misc/linux_specific.c 2009-07-08 09:29:41.000000000 +0000
2+++ b/src/misc/linux_specific.c 2009-07-08 09:30:47.000000000 +0000
3@@ -72,14 +72,14 @@
4 }
5 #endif
6
7-#ifdef __GLIBC__
8+#if defined(__GLIBC__) && !defined(__UCLIBC__)
9 # include <gnu/libc-version.h>
10 # include <stdlib.h>
11 #endif
12
13 void system_Init (libvlc_int_t *libvlc, int *argc, const char *argv[])
14 {
15-#ifdef __GLIBC__
16+#if defined(__GLIBC__) && !defined(__UCLIBC__)
17 const char *glcv = gnu_get_libc_version ();
18
19 /* gettext in glibc 2.5-2.7 is not thread-safe. LibVLC keeps crashing,
20--- a/src/control/vlm.c 2009-07-09 09:21:55.000000000 +0000
21+++ b/src/control/vlm.c 2009-07-09 09:22:24.000000000 +0000
22@@ -21,6 +21,10 @@
23 * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston MA 02110-1301, USA.
24 *****************************************************************************/
25
26+#ifdef HAVE_CONFIG_H
27+# include "config.h"
28+#endif
29+
30 #include <vlc/libvlc.h>
31 #include <vlc/libvlc_vlm.h>
32 #include <vlc_es.h>
33--- a/src/misc/mtime.c 2009-07-09 11:57:46.000000000 +0000
34+++ b/src/misc/mtime.c 2009-07-09 13:48:16.000000000 +0000
35@@ -78,7 +78,7 @@
36 # define _POSIX_CLOCK_SELECTION (-1)
37 #endif
38
39-# if (_POSIX_CLOCK_SELECTION < 0)
40+# if (_POSIX_CLOCK_SELECTION < 0) || defined(__UCLIBC__)
41 /*
42 * We cannot use the monotonic clock is clock selection is not available,
43 * as it would screw vlc_cond_timedwait() completely. Instead, we have to
44--- a/src/misc/threads.c 2009-07-09 13:54:08.000000000 +0000
45+++ b/src/misc/threads.c 2009-07-09 13:54:32.000000000 +0000
46@@ -474,7 +474,7 @@
47 /* Fairly outdated POSIX support (that was defined in 2001) */
48 # define _POSIX_CLOCK_SELECTION (-1)
49 # endif
50-# if (_POSIX_CLOCK_SELECTION >= 0)
51+# if (_POSIX_CLOCK_SELECTION >= 0) && !defined(__UCLIBC__)
52 /* NOTE: This must be the same clock as the one in mtime.c */
53 pthread_condattr_setclock (&attr, CLOCK_MONOTONIC);
54 # endif
55--- a/modules/stream_filter/decomp.c 2009-07-09 14:10:09.000000000 +0000
56+++ b/modules/stream_filter/decomp.c 2009-07-09 14:11:37.000000000 +0000
57@@ -28,7 +28,7 @@
58 #include <vlc_network.h>
59 #include <assert.h>
60 #include <unistd.h>
61-#ifndef _POSIX_SPAWN
62+#if !defined(_POSIX_SPAWN) || defined(__UCLIBC__)
63 # define _POSIX_SPAWN (-1)
64 #endif
65 #include <fcntl.h>