aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-29 06:55:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-29 06:55:24 +0000
commit6c7a24f551b4cdb93544d32703edc5ea6f3ca646 (patch)
treebc4356ced51611d4d04c51369de8832874c7be23
parentd0ae7df44e537e35f48c2b0024effc1b59d3bb90 (diff)
downloadalpine_aports-6c7a24f551b4cdb93544d32703edc5ea6f3ca646.tar.bz2
alpine_aports-6c7a24f551b4cdb93544d32703edc5ea6f3ca646.tar.xz
alpine_aports-6c7a24f551b4cdb93544d32703edc5ea6f3ca646.zip
main/gross: upgrade to 1.0.2
-rw-r--r--main/gross/APKBUILD15
-rw-r--r--main/gross/gross-1.0.1-configure.ac.patch20
-rw-r--r--main/gross/gross-1.0.1-user.patch72
3 files changed, 4 insertions, 103 deletions
diff --git a/main/gross/APKBUILD b/main/gross/APKBUILD
index 73b587a4db..7e6953d951 100644
--- a/main/gross/APKBUILD
+++ b/main/gross/APKBUILD
@@ -1,8 +1,8 @@
1# Contributor: Carlo Landmeter <clandmeter@gmail.com> 1# Contributor: Carlo Landmeter <clandmeter@gmail.com>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=gross 3pkgname=gross
4pkgver=1.0.1 4pkgver=1.0.2
5pkgrel=5 5pkgrel=0
6pkgdesc="Greylisting of suspicious sources" 6pkgdesc="Greylisting of suspicious sources"
7url="http://code.google.com/p/gross/" 7url="http://code.google.com/p/gross/"
8license="BSD" 8license="BSD"
@@ -14,9 +14,7 @@ subpackages="$pkgname-doc $pkgname-dev"
14source="http://gross.googlecode.com/files/$pkgname-$pkgver.tar.gz 14source="http://gross.googlecode.com/files/$pkgname-$pkgver.tar.gz
15 grossd.initd 15 grossd.initd
16 grossd.confd 16 grossd.confd
17 gross-1.0.1-configure.ac.patch
18 gross-1.0.1-default-conf.patch 17 gross-1.0.1-default-conf.patch
19 gross-1.0.1-user.patch
20 " 18 "
21 19
22build() { 20build() {
@@ -26,9 +24,6 @@ build() {
26 msg "Applying $_i..." 24 msg "Applying $_i..."
27 patch -p1 < $_i || return 1 25 patch -p1 < $_i || return 1
28 done 26 done
29 msg "Running autotools..."
30 aclocal --force && autoconf && automake --add-missing \
31 && libtoolize --force --copy || return 1
32 27
33 export lt_SED='/bin/sed' 28 export lt_SED='/bin/sed'
34 export lt_cv_path_SED='/bin/sed' 29 export lt_cv_path_SED='/bin/sed'
@@ -45,9 +40,7 @@ build() {
45 install -m644 -D "$srcdir"/grossd.confd "$pkgdir"/etc/conf.d/grossd 40 install -m644 -D "$srcdir"/grossd.confd "$pkgdir"/etc/conf.d/grossd
46} 41}
47 42
48md5sums="f8f81b36850dcda30cb81799b9cee3b6 gross-1.0.1.tar.gz 43md5sums="cb88d88553161c01e9bed7a74c3e9263 gross-1.0.2.tar.gz
496e8a2626c0c9f0e98e950a67a55a7040 grossd.initd 446e8a2626c0c9f0e98e950a67a55a7040 grossd.initd
505ca1c6e51c3243236e6564480b20279b grossd.confd 455ca1c6e51c3243236e6564480b20279b grossd.confd
51bb75b119ac96b8f99831ce6df810003f gross-1.0.1-configure.ac.patch 467c504b653c71dcf7b192bc487b3516fd gross-1.0.1-default-conf.patch"
527c504b653c71dcf7b192bc487b3516fd gross-1.0.1-default-conf.patch
5316e184d59d520db565388f010cc75e83 gross-1.0.1-user.patch"
diff --git a/main/gross/gross-1.0.1-configure.ac.patch b/main/gross/gross-1.0.1-configure.ac.patch
deleted file mode 100644
index 80f9ea7762..0000000000
--- a/main/gross/gross-1.0.1-configure.ac.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1--- a/configure.ac.orig 2008-05-29 16:18:56 +0000
2+++ b/configure.ac 2008-05-30 09:10:48 +0000
3@@ -52,7 +52,7 @@
4 then
5 AC_DEFINE([USE_SEM_OPEN], [], [Use sem_open() instead of sem_init()])
6 else
7- AC_SEARCH_LIBS(sem_init, [rt], ,
8+ AC_SEARCH_LIBS(sem_init, [rt pthread], ,
9 AC_MSG_ERROR([Can't compile without semaphores.])
10 )
11 fi
12@@ -101,7 +101,7 @@
13 AC_MSG_CHECKING([whether to disable dnsbl checking])
14 AC_ARG_ENABLE(dnsbl,
15 AC_HELP_STRING([--disable-dnsbl], [Disable dnsbl checking]),
16- [AC_MSG_RESULT([yes]) ; dnsbl="no"],
17+ [AC_MSG_RESULT([yes]) ; dnsbl="$enableval"],
18 [AC_MSG_RESULT([no]) ; dnsbl="yes"]
19 )
20
diff --git a/main/gross/gross-1.0.1-user.patch b/main/gross/gross-1.0.1-user.patch
deleted file mode 100644
index a20279f003..0000000000
--- a/main/gross/gross-1.0.1-user.patch
+++ /dev/null
@@ -1,72 +0,0 @@
1Index: src/gross.c
2===================================================================
3--- a/src/gross.c (revision 491)
4+++ b/src/gross.c (working copy)
5@@ -553,7 +553,7 @@
6 void
7 usage(void)
8 {
9- printf("Usage: grossd [-CDdhnPprV] [-f configfile]\n");
10+ printf("Usage: grossd [-CDdhnPpruV] [-f configfile]\n");
11 printf(" -C create statefile and exit\n");
12 printf(" -D Enable debug logging (insane verbosity with -DD)\n");
13 printf(" -d Run grossd as a foreground process\n");
14@@ -563,6 +563,7 @@
15 printf(" -p file write the process id in a pidfile\n");
16 printf(" -P file same as -p, but pid file must not exist\n");
17 printf(" -r disable replication\n");
18+ printf(" -u user run gross as user\n");
19 printf(" -V version information\n");
20 exit(EXIT_USAGE);
21 }
22@@ -612,6 +613,7 @@
23 pool_limits_t limits;
24 sigset_t mask, oldmask;
25 struct passwd *pwd;
26+ char *user = "nobody";
27
28 #ifdef DNSBL
29 dns_check_info_t *dns_check_info;
30@@ -623,7 +625,7 @@
31 daemon_shutdown(EXIT_FATAL, "Couldn't initialize context");
32
33 /* command line arguments */
34- while ((c = getopt(argc, argv, ":drf:VCDnp:P:")) != -1) {
35+ while ((c = getopt(argc, argv, ":drf:VCDnp:P:u:")) != -1) {
36 switch (c) {
37 case 'd':
38 ctx->config.flags |= FLG_NODAEMON;
39@@ -663,6 +665,9 @@
40 ctx->config.flags |= FLG_CHECK_PIDFILE;
41 ctx->config.flags |= FLG_CREATE_PIDFILE;
42 break;
43+ case 'u':
44+ user = optarg;
45+ break;
46 case 'h':
47 usage();
48 break;
49@@ -675,16 +680,16 @@
50
51 /* grossd doesn't need to be running as root */
52 if (geteuid() == 0) {
53- logstr(GLOG_DEBUG, "Running as root: setuid() to 'nobody'");
54- pwd = getpwnam("nobody");
55+ logstr(GLOG_DEBUG, "Running as root: setuid() to '%s'", user);
56+ pwd = getpwnam(user);
57 if (NULL == pwd)
58- daemon_shutdown(EXIT_FATAL, "Running as root: can't find user 'nobody'");
59+ daemon_shutdown(EXIT_FATAL, "Running as root: can't find user '%s'", user);
60 if (setgid(pwd->pw_gid) != 0)
61- daemon_shutdown(EXIT_FATAL, "Running as root: can't setgid(%d) to 'nobody': %s",
62- pwd->pw_gid, strerror(errno));
63+ daemon_shutdown(EXIT_FATAL, "Running as root: can't setgid(%d) to '%s': %s",
64+ pwd->pw_gid, user, strerror(errno));
65 if (setuid(pwd->pw_uid) != 0)
66- daemon_shutdown(EXIT_FATAL, "Running as root: can't setuid(%d) to 'nobody': %s",
67- pwd->pw_uid, strerror(errno));
68+ daemon_shutdown(EXIT_FATAL, "Running as root: can't setuid(%d) to '%s': %s",
69+ pwd->pw_uid, user, strerror(errno));
70 }
71
72 config = default_config();