aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Teras <timo.teras@iki.fi>2009-10-07 10:33:07 +0300
committerTimo Teras <timo.teras@iki.fi>2009-10-07 10:51:47 +0300
commit740cef6664153c9eaff1f11ec549bb3c6ea05adc (patch)
treeae2e9274bb9b60f6470055e1792f9a8ba985ad31
parent25f1e109e654f01ee6156899b95c4fd6cbe80e1b (diff)
downloadalpine_aports-740cef6664153c9eaff1f11ec549bb3c6ea05adc.tar.bz2
alpine_aports-740cef6664153c9eaff1f11ec549bb3c6ea05adc.tar.xz
alpine_aports-740cef6664153c9eaff1f11ec549bb3c6ea05adc.zip
main/squid: update to 2.7.STABLE7
additionally add a patch that prevents modification of Content-Type header on If-Modified-Since request 304 replies. RFC says those replies are invalid, but some broken servers return bogus data anyway, so ignoring the reply fixes some issues. (cherry picked from commit c447b3590d5fb3500e9ee67936893091cf1d565a)
-rw-r--r--main/squid/APKBUILD11
-rw-r--r--main/squid/squid-2.7-ims-content-type.patch11
2 files changed, 18 insertions, 4 deletions
diff --git a/main/squid/APKBUILD b/main/squid/APKBUILD
index 01f7bfa743..66be7961f9 100644
--- a/main/squid/APKBUILD
+++ b/main/squid/APKBUILD
@@ -1,9 +1,9 @@
1# Contributor: Carlo Landmeter <clandmeter@gmail.com> 1# Contributor: Carlo Landmeter <clandmeter@gmail.com>
2# Maintainer: Carlo Landmeter <clandmeter@gmail.com> 2# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
3pkgname=squid 3pkgname=squid
4pkgver=2.7.6 4pkgver=2.7.7
5_ver=2.7.STABLE6 5_ver=2.7.STABLE7
6pkgrel=12 6pkgrel=0
7pkgdesc="A full-featured Web proxy cache server." 7pkgdesc="A full-featured Web proxy cache server."
8url="http://www.squid-cache.org" 8url="http://www.squid-cache.org"
9install="squid.pre-install squid.pre-upgrade squid.post-install" 9install="squid.pre-install squid.pre-upgrade squid.post-install"
@@ -52,6 +52,7 @@ source="http://www.squid-cache.org/Versions/v2/2.7/${pkgname}-${_ver}.tar.bz2
52 squid.initd 52 squid.initd
53 squid.confd 53 squid.confd
54 squid-2.7-gentoo.patch 54 squid-2.7-gentoo.patch
55 squid-2.7-ims-content-type.patch
55 $pkgname.logrotate 56 $pkgname.logrotate
56 " 57 "
57pkgusers="squid" 58pkgusers="squid"
@@ -61,6 +62,7 @@ build() {
61 cd "$srcdir/$pkgname-$_ver" 62 cd "$srcdir/$pkgname-$_ver"
62 63
63 patch -p1 -i "$srcdir"/squid-2.7-gentoo.patch || return 1 64 patch -p1 -i "$srcdir"/squid-2.7-gentoo.patch || return 1
65 patch -p1 -i "$srcdir"/squid-2.7-ims-content-type.patch || return 1
64 66
65 touch NEWS AUTHORS 67 touch NEWS AUTHORS
66 aclocal && autoconf && automake -a || return 1 68 aclocal && autoconf && automake -a || return 1
@@ -278,8 +280,9 @@ errors_ukrainian_utf8() {
278} 280}
279 281
280 282
281md5sums="6de3a6a7a56a7ecae092f2d31a04f039 squid-2.7.STABLE6.tar.bz2 283md5sums="c18b0371fca813d5e7c7e0baf87baa22 squid-2.7.STABLE7.tar.bz2
28257fed05adc40acab6a5480ec7a014154 squid.initd 28457fed05adc40acab6a5480ec7a014154 squid.initd
28344b052db7910f386ef88ddcf69c9ba4e squid.confd 28544b052db7910f386ef88ddcf69c9ba4e squid.confd
2843827f71d940b47eb385a1a1d92a51d66 squid-2.7-gentoo.patch 2863827f71d940b47eb385a1a1d92a51d66 squid-2.7-gentoo.patch
287549377b5a6b673bf19ea6c34003d122c squid-2.7-ims-content-type.patch
28558823e0b86bc2dc71d270208b7b284b4 squid.logrotate" 28858823e0b86bc2dc71d270208b7b284b4 squid.logrotate"
diff --git a/main/squid/squid-2.7-ims-content-type.patch b/main/squid/squid-2.7-ims-content-type.patch
new file mode 100644
index 0000000000..8b66197e7c
--- /dev/null
+++ b/main/squid/squid-2.7-ims-content-type.patch
@@ -0,0 +1,11 @@
1--- a/src/HttpReply.c.orig Wed Oct 7 07:08:08 2009
2+++ b/src/HttpReply.c Wed Oct 7 07:08:20 2009
3@@ -43,7 +43,7 @@
4 static http_hdr_type Denied304HeadersArr[] =
5 {
6 HDR_CONTENT_ENCODING, HDR_CONTENT_LANGUAGE, HDR_CONTENT_LENGTH,
7- HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE
8+ HDR_CONTENT_LOCATION, HDR_CONTENT_RANGE, HDR_CONTENT_TYPE
9 };
10
11 /* local routines */