aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2010-12-14 23:37:38 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-16 10:30:59 +0000
commit064c9f35cc947da1a133c06cfdd8094b5a2c815c (patch)
treed831d9efd06290076fce9486cb9bb3f164fe44a9
parentbf29f568b8e8d3c2049fde5ae86e94a281ba26b1 (diff)
downloadalpine_aports-064c9f35cc947da1a133c06cfdd8094b5a2c815c.tar.bz2
alpine_aports-064c9f35cc947da1a133c06cfdd8094b5a2c815c.tar.xz
alpine_aports-064c9f35cc947da1a133c06cfdd8094b5a2c815c.zip
testing/py-sphinx: new aport
-rw-r--r--testing/py-sphinx/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/py-sphinx/APKBUILD b/testing/py-sphinx/APKBUILD
new file mode 100644
index 0000000000..3b43e52d2b
--- /dev/null
+++ b/testing/py-sphinx/APKBUILD
@@ -0,0 +1,54 @@
1# Contributor: Matt Smith <mcs@darkregion.net>
2# Maintainer: Matt Smith <mcs@darkregion.net>
3pkgname=py-sphinx
4_pkgname=Sphinx
5pkgver=1.0.5
6pkgrel=0
7pkgdesc="Python Documentation Generator"
8url="http://sphinx.pocoo.org/"
9arch="x86 x86_64"
10license="BSD"
11depends="python py-docutils py-jinja2 py-pygments"
12makedepends="python-dev py-setuptools"
13install=
14subpackages="$pkgname-doc"
15source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
16
17_builddir="$srcdir"/$_pkgname-$pkgver
18
19prepare() {
20 cd "$_builddir"
21 # apply patches here
22}
23
24build() {
25 cd "$_builddir"
26 python setup.py build || return 1
27}
28
29package() {
30 cd "$_builddir"
31 python setup.py install --root "$pkgdir"
32}
33
34doc() {
35 cd "$_builddir"
36
37 mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
38 for doc in AUTHORS CHANGES EXAMPLES LICENSE README TODO; do
39 install -Dm644 $doc "$subpkgdir"/usr/share/doc/$pkgname/
40 done
41
42 # Note: Documentation in the 'doc' directory (below), needs to be built
43 # with sphinx-build once sphinx is installed (see README for details).
44 #
45 # Leaving as-is; will be up to the individual user that's interested.
46 mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/doc/
47 cp -R ./doc/* "$subpkgdir"/usr/share/doc/$pkgname/doc/
48 chmod -R 644 "$subpkgdir"/usr/share/doc/$pkgname/doc/
49
50 # Fix subdir perms
51 find "$subpkgdir"/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
52}
53
54md5sums="9c2cbfb4f520c49cedd10d0b26196832 Sphinx-1.0.5.tar.gz"