aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2010-12-15 03:48:58 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-16 10:59:04 +0000
commit10fdcd7caa1b09e87dad3aac157ac18f280ff1ef (patch)
tree802655ff3816e370b14eaa0f5fdbe93d710d4ddc
parent5f3d3104b805379479a2b85f1892d6c58a29e0a2 (diff)
downloadalpine_aports-10fdcd7caa1b09e87dad3aac157ac18f280ff1ef.tar.bz2
alpine_aports-10fdcd7caa1b09e87dad3aac157ac18f280ff1ef.tar.xz
alpine_aports-10fdcd7caa1b09e87dad3aac157ac18f280ff1ef.zip
testing/duplicity: new aport
-rw-r--r--testing/duplicity/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/duplicity/APKBUILD b/testing/duplicity/APKBUILD
new file mode 100644
index 0000000000..a380eea858
--- /dev/null
+++ b/testing/duplicity/APKBUILD
@@ -0,0 +1,33 @@
1# Contributor: Matt Smith <mcs@darkregion.net>
2# Maintainer: Matt Smith <mcs@darkregion.net>
3pkgname=duplicity
4pkgver=0.6.11
5pkgrel=0
6pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
7url="http://duplicity.nongnu.org/"
8arch="x86 x86_64"
9license="GPL"
10depends="python py-boto ncftp librsync gnupg"
11makedepends="wget python-dev py-setuptools librsync-dev"
12install=
13subpackages="$pkgname-doc"
14source="https://code.launchpad.net/$pkgname/${pkgver:0:3}-series/$pkgver/+download/$pkgname-$pkgver.tar.gz"
15
16_builddir="$srcdir"/$pkgname-$pkgver
17
18prepare() {
19 cd "$_builddir"
20 # apply patches here
21}
22
23build() {
24 cd "$_builddir"
25 python setup.py build || return 1
26}
27
28package() {
29 cd "$_builddir"
30 python setup.py install --root "$pkgdir"
31}
32
33md5sums="1116be7aababa467336eac2092f66ab7 duplicity-0.6.11.tar.gz"