aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2010-12-14 23:38:42 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-16 10:31:01 +0000
commitca05ea0f3aff143eeb90a4eda95aadc024d6ca74 (patch)
treea7be67eb51ba3688b292010c3fa4106a17c061f9
parent064c9f35cc947da1a133c06cfdd8094b5a2c815c (diff)
downloadalpine_aports-ca05ea0f3aff143eeb90a4eda95aadc024d6ca74.tar.bz2
alpine_aports-ca05ea0f3aff143eeb90a4eda95aadc024d6ca74.tar.xz
alpine_aports-ca05ea0f3aff143eeb90a4eda95aadc024d6ca74.zip
testing/py-boto: new aport
-rw-r--r--testing/py-boto/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/py-boto/APKBUILD b/testing/py-boto/APKBUILD
new file mode 100644
index 0000000000..00b3fe9d99
--- /dev/null
+++ b/testing/py-boto/APKBUILD
@@ -0,0 +1,51 @@
1# Contributor: Matt Smith <mcs@darkregion.net>
2# Maintainer: Matt Smith <mcs@darkregion.net>
3pkgname=py-boto
4_pkgname=boto
5pkgver=1.9b
6pkgrel=0
7pkgdesc="An integrated interface to current and future infrastructural services offered by Amazon Web Services."
8url="http://code.google.com/p/boto/"
9arch="x86 x86_64"
10license="MIT"
11depends="python"
12makedepends="python-dev py-setuptools"
13install=
14subpackages="$pkgname-doc"
15source="http://$_pkgname.googlecode.com/files/$_pkgname-$pkgver.tar.gz"
16
17_builddir="$srcdir"/$_pkgname-$pkgver
18
19prepare() {
20 cd "$_builddir"
21 # apply patches here
22}
23
24build() {
25 cd "$_builddir"
26 python setup.py build || return 1
27}
28
29package() {
30 cd "$_builddir"
31 python setup.py install --root "$pkgdir"
32}
33
34doc() {
35 cd "$_builddir"
36
37 mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
38 install -Dm644 README "$subpkgdir"/usr/share/doc/$pkgname/README
39
40 # Note: The documentation in the 'docs' directory can only be generated
41 # (via sphinx-build from the py-sphinx package) once this package has
42 # been installed. Copying it off for the user.
43 mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/docs
44 cp -R ./docs/* "$subpkgdir"/usr/share/doc/$pkgname/docs/
45 chmod -R 644 "$subpkgdir"/usr/share/doc/$pkgname/docs/
46
47 # Fix subdir perms
48 find "$subpkgdir"/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
49}
50
51md5sums="4fc2fd7b70a971b1363f8465aafe7091 boto-1.9b.tar.gz"