aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-12-21 14:46:16 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2010-12-21 14:46:16 +0100
commit3ccb251e15e3a5692f737149080eecf48c25519a (patch)
treee7d2943d1e040cbaf8984fc0f90364c83802b6a6
parentac01c4ab99a130bcbcec089506ffe19374cea59d (diff)
downloadalpine_aports-3ccb251e15e3a5692f737149080eecf48c25519a.tar.bz2
alpine_aports-3ccb251e15e3a5692f737149080eecf48c25519a.tar.xz
alpine_aports-3ccb251e15e3a5692f737149080eecf48c25519a.zip
testing/scstadmin: remove svn name and update to latest 2.0.0 svn r3161
-rw-r--r--testing/scstadmin-svn/APKBUILD31
-rw-r--r--testing/scstadmin/APKBUILD39
-rw-r--r--testing/scstadmin/scst-init-ash-comapt.patch35
3 files changed, 74 insertions, 31 deletions
diff --git a/testing/scstadmin-svn/APKBUILD b/testing/scstadmin-svn/APKBUILD
deleted file mode 100644
index e92ae2ccd2..0000000000
--- a/testing/scstadmin-svn/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
1# Contributor:
2# Maintainer:
3pkgname=scstadmin-svn
4pkgver=1713
5pkgrel=0
6pkgdesc="SCST administration tool written in perl"
7url="http://scst.sourceforge.net"
8arch="x86 x86_64"
9license="GPL-2"
10depends="perl"
11makedepends="perl-dev"
12install=
13subpackages="$pkgname-doc"
14source="http://alpine.nethq.org/clandmeter/src/$pkgname-$pkgver.tar.gz"
15
16_builddir="$srcdir"/scstadmin
17
18prepare() {
19 cd "$_builddir"/scst-0.9.00
20 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
21}
22
23package() {
24 cd "$_builddir"/scst-0.9.00
25 make DESTDIR="$pkgdir" install || return 1
26 cd "$_builddir"
27 install -Dm755 scstadmin.sysfs "$pkgdir"/usr/sbin/scstadmin || return 1
28 install -Dm755 init.d/scst.gentoo "$pkgdir"/etc/init.d/scstadmin
29}
30
31md5sums="5c78c6d4d4079a8d2c2b55f3e3119105 scstadmin-svn-1713.tar.gz"
diff --git a/testing/scstadmin/APKBUILD b/testing/scstadmin/APKBUILD
new file mode 100644
index 0000000000..85350e0675
--- /dev/null
+++ b/testing/scstadmin/APKBUILD
@@ -0,0 +1,39 @@
1# Contributor: Carlo Landmeter
2# Maintainer:
3pkgname=scstadmin
4pkgver=2.0.0
5pkgrel=0
6pkgdesc="SCST administration tool written in perl"
7url="http://scst.sourceforge.net"
8arch="x86_64"
9license="GPL-2"
10depends="perl"
11makedepends="perl-dev"
12install=
13subpackages="$pkgname-doc"
14# increase pkgrel when updating svn rev
15_svn="3161"
16source="http://alpine.nethq.org/distfiles/$pkgname-$pkgver-svn-$_svn.tar.gz
17 scst-init-ash-comapt.patch
18 "
19
20_builddir="$srcdir"/$pkgname
21
22prepare() {
23 cd "$_builddir"/scstadmin.sysfs/scst-0.9.00
24 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
25 cd "$_builddir"
26 patch -p1 < "$srcdir"/scst-init-ash-comapt.patch
27}
28
29package() {
30 cd "$_builddir"/scstadmin.sysfs/scst-0.9.00
31 make DESTDIR="$pkgdir" install || return 1
32
33 cd "$_builddir"
34 install -Dm755 scstadmin.sysfs/scstadmin "$pkgdir"/usr/sbin/scstadmin || return 1
35 install -Dm755 init.d/scst.gentoo "$pkgdir"/etc/init.d/scstadmin || return 1
36}
37
38md5sums="8f60857b6545dd60d7d26342aba038f1 scstadmin-2.0.0-svn-3161.tar.gz
39061580b8ec84b5f7da0b1332601f505a scst-init-ash-comapt.patch"
diff --git a/testing/scstadmin/scst-init-ash-comapt.patch b/testing/scstadmin/scst-init-ash-comapt.patch
new file mode 100644
index 0000000000..67cd7adf17
--- /dev/null
+++ b/testing/scstadmin/scst-init-ash-comapt.patch
@@ -0,0 +1,35 @@
1--- scstadmin/init.d/scst.gentoo
2+++ scstadmin/init.d/scst.gentoo
3@@ -12,13 +12,11 @@
4 # Note: on most Linux distributions /bin/sh is a soft link to /bin/bash, while
5 # on a default Ubuntu setup /bin/sh is a soft link to /bin/dash !
6
7-opts="${opts} try-restart reload force-reload"
8+opts="${opts} try_restart reload force_reload"
9 depend() {
10 use logger
11 }
12
13-PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/local/bin
14-
15 DEFAULTFILE="/etc/conf.d/scst"
16 SCST_CFG=/etc/scst.conf
17 MODPROBE="/sbin/modprobe"
18@@ -121,7 +119,7 @@
19 start
20 }
21
22-try-restart() {
23+try_restart() {
24 ## Restart the service if the service is already running.
25 status >/dev/null 2>&1 && restart
26 }
27@@ -140,7 +138,7 @@
28 fi
29 }
30
31-force-reload() {
32+force_reload() {
33 ## Cause the configuration to be reloaded if the service supports this,
34 ## otherwise restart the service if it is running.
35 einfo "Reloading SCST configuration"