aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-23 17:08:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-23 17:09:04 +0000
commitcd089916834f1a0fa77a93ecb028e3582497ac41 (patch)
tree892d23ba52096d1467d94f4181ff951e92230d42
parent7bb9f040d8cc5ba95b30e8b9ba2ae4ae252a2a03 (diff)
downloadalpine_aports-cd089916834f1a0fa77a93ecb028e3582497ac41.tar.bz2
alpine_aports-cd089916834f1a0fa77a93ecb028e3582497ac41.tar.xz
alpine_aports-cd089916834f1a0fa77a93ecb028e3582497ac41.zip
main/mkinitfs: upgrade to 2.2.0
ref #486
-rw-r--r--main/mkinitfs/0001-init-mount-devices-as-read-only.patch53
-rw-r--r--main/mkinitfs/APKBUILD13
2 files changed, 4 insertions, 62 deletions
diff --git a/main/mkinitfs/0001-init-mount-devices-as-read-only.patch b/main/mkinitfs/0001-init-mount-devices-as-read-only.patch
deleted file mode 100644
index e0077dd7f5..0000000000
--- a/main/mkinitfs/0001-init-mount-devices-as-read-only.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From 13cfce8f525fcb656044da419e03747892abd174 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Tue, 21 Dec 2010 10:08:39 +0000
4Subject: [PATCH] init: mount devices as read-only
5
6---
7 initramfs-init.in | 9 +++++----
8 1 files changed, 5 insertions(+), 4 deletions(-)
9
10diff --git a/initramfs-init.in b/initramfs-init.in
11index 2fb2626..9acf1c7 100755
12--- a/initramfs-init.in
13+++ b/initramfs-init.in
14@@ -138,7 +138,7 @@ find_ovl_dev() {
15 # wait for usb to settle if needed
16 wait_usb
17 for i in usb floppy cdrom; do
18- mount /media/$i 2>/dev/null || continue
19+ mount -o ro /media/$i 2>/dev/null || continue
20 ovl=$(find_ovl /media/$i)
21 [ -f "$ovl" ] && return
22 umount /media/$i 2>/dev/null
23@@ -276,7 +276,7 @@ if [ -n "$KOPT_root" ]; then
24 ;;
25 esac
26 ebegin "Mounting root"
27- retry_mount $KOPT_root $sysroot 2>/dev/null
28+ retry_mount -o ro $KOPT_root $sysroot 2>/dev/null
29 eend $?
30 cat /proc/mounts | while read DEV DIR TYPE OPTS ; do
31 if [ "$DIR" != "/" -a "$DIR" != "$sysroot" -a -d "$DIR" ]; then
32@@ -302,7 +302,7 @@ if [ -n "$ALPINE_DEV_FS" ]; then
33 mount_opts="-t $ALPINE_DEV_FS"
34 fi
35
36-retry_mount $mount_opts $ALPINE_DEV $ALPINE_MNT >/dev/null 2>&1
37+retry_mount -o ro $mount_opts $ALPINE_DEV $ALPINE_MNT >/dev/null 2>&1
38 eend $?
39
40 # generate apk repositories file
41@@ -329,7 +329,8 @@ if [ -n "$OVL_DEV" ]; then
42 mount_opts="-t $OVL_DEV_FS"
43 fi
44
45- retry_mount $mount_opts /dev/$OVL_DEV /media/$OVL_DEV >/dev/null 2>&1
46+ retry_mount -o ro $mount_opts /dev/$OVL_DEV /media/$OVL_DEV \
47+ >/dev/null 2>&1
48 ovl=$(find_ovl /media/$OVL_DEV)
49 else
50 find_ovl_dev
51--
521.7.3.4
53
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index a18c4e8496..03edd8f643 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -1,14 +1,13 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=mkinitfs 2pkgname=mkinitfs
3pkgver=2.1.3 3pkgver=2.2.0
4pkgrel=1 4pkgrel=0
5pkgdesc="Tool to generate initramfs images for Alpine" 5pkgdesc="Tool to generate initramfs images for Alpine"
6url=http://git.alpinelinux.org/cgit/mkinitfs 6url=http://git.alpinelinux.org/cgit/mkinitfs
7depends="busybox apk-tools>=2.0" 7depends="busybox apk-tools>=2.0"
8triggers="$pkgname.trigger:/usr/share/kernel/*" 8triggers="$pkgname.trigger:/usr/share/kernel/*"
9source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2 9source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
10 eglibc.patch 10 eglibc.patch
11 0001-init-mount-devices-as-read-only.patch
12 " 11 "
13arch="x86 x86_64" 12arch="x86 x86_64"
14license="GPL-2" 13license="GPL-2"
@@ -16,9 +15,6 @@ license="GPL-2"
16prepare() { 15prepare() {
17 cd "$srcdir"/$pkgname-$pkgver 16 cd "$srcdir"/$pkgname-$pkgver
18 17
19 patch -p1 -i "$srcdir"/0001-init-mount-devices-as-read-only.patch \
20 || return 1
21
22 # If we are using eglibc/glibc we need to include eglibc libs 18 # If we are using eglibc/glibc we need to include eglibc libs
23 # instead of uclibc libs. 19 # instead of uclibc libs.
24 case "$CHOST" in 20 case "$CHOST" in
@@ -37,6 +33,5 @@ package() {
37 cd "$srcdir"/$pkgname-$pkgver 33 cd "$srcdir"/$pkgname-$pkgver
38 make install DESTDIR="$pkgdir" || return 1 34 make install DESTDIR="$pkgdir" || return 1
39} 35}
40md5sums="36bea9db1d83d2fd9860130b1cdec0d0 mkinitfs-2.1.3.tar.bz2 36md5sums="b3abed1ee80ae69947350b795c7211e5 mkinitfs-2.2.0.tar.bz2
41e59c2f7de496fe430b07e32fd812ebe0 eglibc.patch 37e59c2f7de496fe430b07e32fd812ebe0 eglibc.patch"
4296cfe927afb70e1af94a9c6fe8f5acca 0001-init-mount-devices-as-read-only.patch"