aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-12 09:52:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-12 09:52:34 +0000
commit45e9081bdb50f0897961644409a65da93a708e55 (patch)
treed6bd87928bf33eeb9968d4ce6bb8bf37b0785708
parent39de1d2f2faeab7a49f7d921ae510e4889ae4a5f (diff)
downloadalpine_aports-45e9081bdb50f0897961644409a65da93a708e55.tar.bz2
alpine_aports-45e9081bdb50f0897961644409a65da93a708e55.tar.xz
alpine_aports-45e9081bdb50f0897961644409a65da93a708e55.zip
testing/glade: new aport
User Interface Designer for GTK+ and GNOME http://glade.gnome.org/
-rw-r--r--testing/glade/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/glade/APKBUILD b/testing/glade/APKBUILD
new file mode 100644
index 0000000000..25b7244ea9
--- /dev/null
+++ b/testing/glade/APKBUILD
@@ -0,0 +1,34 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=glade
3pkgver=3.10.0
4pkgrel=0
5pkgdesc="User Interface Designer for GTK+ and GNOME"
6url="http://glade.gnome.org/"
7arch="all"
8license="GPL"
9depends=
10makedepends="gtk+3.0-dev libxml2-dev"
11install=
12subpackages="$pkgname-dev $pkgname-doc"
13source="http://ftp.gnome.org/pub/GNOME/sources/glade/${pkgver%.*}/glade-$pkgver.tar.bz2"
14
15_builddir="$srcdir"/$pkgname-$pkgver
16prepare() {
17 cd "$_builddir"
18}
19
20build() {
21 cd "$_builddir"
22 ./configure --prefix=/usr \
23 --sysconfdir=/etc \
24 --mandir=/usr/share/man \
25 --infodir=/usr/share/info
26 make || return 1
27}
28
29package() {
30 cd "$_builddir"
31 make DESTDIR="$pkgdir" install
32}
33
34md5sums="70c61582bdc6e9a852b29f3d172ddd4e glade-3.10.0.tar.bz2"