aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-04-12 02:39:33 -0500
committerMatt Smith <mcs@darkregion.net>2011-04-12 02:40:19 -0500
commit53910ad269e87131ee1096e651743b88f69aadfe (patch)
treefcc06361ba0dedf12db5d4307809bff6e2707c12
parentc42298ac37128c5ebc1b68399d1ef15908a1134a (diff)
downloadalpine_aports-53910ad269e87131ee1096e651743b88f69aadfe.tar.bz2
alpine_aports-53910ad269e87131ee1096e651743b88f69aadfe.tar.xz
alpine_aports-53910ad269e87131ee1096e651743b88f69aadfe.zip
testing/apache2-mod-perl: new aport
Perl Module for Apache2 http://perl.apache.org/
-rw-r--r--testing/apache2-mod-perl/APKBUILD58
-rw-r--r--testing/apache2-mod-perl/apache2-mod-perl.apache2.conf11
-rw-r--r--testing/apache2-mod-perl/apache2-mod-perl.post-install10
3 files changed, 79 insertions, 0 deletions
diff --git a/testing/apache2-mod-perl/APKBUILD b/testing/apache2-mod-perl/APKBUILD
new file mode 100644
index 0000000000..43ffe184d7
--- /dev/null
+++ b/testing/apache2-mod-perl/APKBUILD
@@ -0,0 +1,58 @@
1# Contributor: Matt Smith <mcs@darkregion.net>
2# Maintainer: Matt Smith <mcs@darkregion.net>
3pkgname=apache2-mod-perl
4_realname=mod_perl
5pkgver=2.0.5
6pkgrel=0
7pkgdesc="Perl Module for Apache2"
8url="http://perl.apache.org/"
9arch="all"
10license="APACHE"
11depends="apache2 perl"
12depends_dev=
13makedepends="$depends_dev apache2-dev perl-dev"
14install="$pkgname.post-install"
15subpackages="$pkgname-doc $pkgname-dev"
16source="http://search.cpan.org/CPAN/authors/id/P/PH/PHRED/${_realname}-${pkgver}.tar.gz
17 $pkgname.apache2.conf
18 "
19
20_builddir="$srcdir"/${_realname}-${pkgver}
21build() {
22 cd "$_builddir"
23 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor \
24 MP_APXS=/usr/sbin/apxs || return 1
25 make || return 1
26}
27
28package() {
29 cd "$_builddir"
30 make DESTDIR="$pkgdir" install || return 1
31 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
32
33 # install the apache2 config
34 install -Dm644 "$srcdir"/$pkgname.apache2.conf \
35 "$pkgdir"/etc/apache2/conf.d/perl-module.conf || return 1
36}
37
38doc() {
39 arch="noarch"
40
41 # man pages
42 mkdir -p "$subpkgdir"/usr/share/man || return 1
43 mv "$pkgdir"/usr/share/man/man* "$subpkgdir"/usr/share/man/ \
44 || return 1
45
46 # doc files
47 _docs="BRANCHING Changes INSTALL LICENSE MANIFEST NOTICE README \
48 README-SVN RELEASE STATUS SVN-MOVE"
49 for _doc in $_docs; do
50 install -Dm644 "$_builddir"/$_doc \
51 "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
52 done
53 cp -ra "$_builddir"/docs/ "$subpkgdir"/usr/share/doc/$pkgname/ \
54 || return 1
55}
56
57md5sums="03d01d135a122bd8cebd0cd5b185d674 mod_perl-2.0.5.tar.gz
5886b84bb56b49a95772a7f773fc019043 apache2-mod-perl.apache2.conf"
diff --git a/testing/apache2-mod-perl/apache2-mod-perl.apache2.conf b/testing/apache2-mod-perl/apache2-mod-perl.apache2.conf
new file mode 100644
index 0000000000..c1a75c76ff
--- /dev/null
+++ b/testing/apache2-mod-perl/apache2-mod-perl.apache2.conf
@@ -0,0 +1,11 @@
1LoadModule perl_module modules/mod_perl.so
2
3# For mod_perl 1.0 compatibility, uncomment:
4#PerlModule Apache2::compat
5
6<Location /cgi-bin>
7 AddHandler perl-script .pl
8 PerlResponseHandler ModPerl::Registry
9 PerlOptions +ParseHeaders
10 Options +ExecCGI
11</Location>
diff --git a/testing/apache2-mod-perl/apache2-mod-perl.post-install b/testing/apache2-mod-perl/apache2-mod-perl.post-install
new file mode 100644
index 0000000000..8cfc5a86e4
--- /dev/null
+++ b/testing/apache2-mod-perl/apache2-mod-perl.post-install
@@ -0,0 +1,10 @@
1#!/bin/sh
2
3echo "*" >&2
4echo "* To finish installing apache2-mod-perl:" >&2
5echo "* 1) See if you need to modify the apache2 config:" >&2
6echo "* /etc/apache2/conf.d/perl-module.conf" >&2
7echo "* 2) Restart apache2 when done." >&2
8echo "*" >&2
9
10exit 0