aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-04-12 05:30:00 -0500
committerMatt Smith <mcs@darkregion.net>2011-04-12 05:30:00 -0500
commit6288394c61a6a6af98b1eb40e20e1f3ccf6c850e (patch)
tree1965de25fbe3c9168833cfa5fa05bf437f4f39d3
parentc3833d0cb48b3282425065ccf6d59d96ee60a54e (diff)
downloadalpine_aports-6288394c61a6a6af98b1eb40e20e1f3ccf6c850e.tar.bz2
alpine_aports-6288394c61a6a6af98b1eb40e20e1f3ccf6c850e.tar.xz
alpine_aports-6288394c61a6a6af98b1eb40e20e1f3ccf6c850e.zip
testing/apache2-mod-wsgi: new aport (rebuild; pkgrel -r1)
Python WSGI Module for Apache2 http://code.google.com/p/modwsgi/
-rw-r--r--testing/apache2-mod-wsgi/APKBUILD51
-rw-r--r--testing/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf1
-rw-r--r--testing/apache2-mod-wsgi/apache2-mod-wsgi.post-install10
3 files changed, 62 insertions, 0 deletions
diff --git a/testing/apache2-mod-wsgi/APKBUILD b/testing/apache2-mod-wsgi/APKBUILD
new file mode 100644
index 0000000000..89c04f2c24
--- /dev/null
+++ b/testing/apache2-mod-wsgi/APKBUILD
@@ -0,0 +1,51 @@
1# Contributor: Matt Smith <mcs@darkregion.net>
2# Maintainer: Matt Smith <mcs@darkregion.net>
3pkgname=apache2-mod-wsgi
4_realname=mod_wsgi
5pkgver=3.3
6pkgrel=1
7pkgdesc="Python WSGI Module for Apache2"
8url="http://code.google.com/p/modwsgi/"
9arch="all"
10license="APACHE"
11depends="apache2 python"
12depends_dev=
13makedepends="$depends_dev apache2-dev python-dev"
14install="$pkgname.post-install"
15subpackages="$pkgname-doc"
16source="http://modwsgi.googlecode.com/files/$_realname-$pkgver.tar.gz
17 $pkgname.apache2.conf
18 "
19
20_builddir="$srcdir"/$_realname-$pkgver
21build() {
22 cd "$_builddir"
23 CFLAGS="" CXXFLAGS="" CPPFLAGS="" \
24 ./configure --prefix=/usr \
25 --with-apxs=/usr/sbin/apxs \
26 --with-python=/usr/bin/python || return 1
27 make || return 1
28}
29
30package() {
31 cd "$_builddir"
32 make DESTDIR="$pkgdir" install || return 1
33
34 # install the apache2 config
35 install -Dm644 "$srcdir"/$pkgname.apache2.conf \
36 "$pkgdir"/etc/apache2/conf.d/wsgi-module.conf || return 1
37}
38
39doc() {
40 arch="noarch"
41
42 # doc files
43 _docs="LICENCE README"
44 for _doc in $_docs; do
45 install -Dm644 "$_builddir"/$_doc \
46 "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
47 done
48}
49
50md5sums="6172bb2bbabcd0c25867c2bc06f99dbb mod_wsgi-3.3.tar.gz
51e1795e051e7aae1f865fde0d3b86a507 apache2-mod-wsgi.apache2.conf"
diff --git a/testing/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf b/testing/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf
new file mode 100644
index 0000000000..19f356756b
--- /dev/null
+++ b/testing/apache2-mod-wsgi/apache2-mod-wsgi.apache2.conf
@@ -0,0 +1 @@
LoadModule wsgi_module modules/mod_wsgi.so
diff --git a/testing/apache2-mod-wsgi/apache2-mod-wsgi.post-install b/testing/apache2-mod-wsgi/apache2-mod-wsgi.post-install
new file mode 100644
index 0000000000..327b0156b9
--- /dev/null
+++ b/testing/apache2-mod-wsgi/apache2-mod-wsgi.post-install
@@ -0,0 +1,10 @@
1#!/bin/sh
2
3echo "*" >&2
4echo "* To finish installing apache2-mod-wsgi:" >&2
5echo "* 1) See if you need to modify the apache2 config:" >&2
6echo "* /etc/apache2/conf.d/wsgi-module.conf" >&2
7echo "* 2) Restart apache2 when done." >&2
8echo "*" >&2
9
10exit 0