aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-25 15:54:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-25 15:54:28 +0000
commit3567d03ac26894e2537a32fb487ea2728b7cd421 (patch)
tree4cb32fa2b202cb63c282845a66c1e41062ac1215
parentbf4fb0398fb761d5a811271186db7e0a1a16a668 (diff)
downloadalpine_aports-3567d03ac26894e2537a32fb487ea2728b7cd421.tar.bz2
alpine_aports-3567d03ac26894e2537a32fb487ea2728b7cd421.tar.xz
alpine_aports-3567d03ac26894e2537a32fb487ea2728b7cd421.zip
testing/edje: new aport
Enlightenment's graphical layout and animation library http://trac.enlightenment.org/e/wiki/Edje
-rw-r--r--testing/edje/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/edje/APKBUILD b/testing/edje/APKBUILD
new file mode 100644
index 0000000000..689977fdfb
--- /dev/null
+++ b/testing/edje/APKBUILD
@@ -0,0 +1,40 @@
1# Contributor: Natanael Copa <ncopa@alpinelinux.org>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=edje
4pkgver=1.0.0
5pkgrel=0
6pkgdesc="Enlightenment's graphical layout and animation library"
7url="http://trac.enlightenment.org/e/wiki/Edje"
8arch="all"
9license="BSD"
10depends=
11depends_dev="lua-dev eina-dev eet-dev embryo-dev ecore-dev evas-dev"
12makedepends="$depends_dev"
13install=""
14subpackages="$pkgname-dev"
15source="http://download.enlightenment.org/releases/edje-$pkgver.tar.gz"
16
17_builddir="$srcdir"/edje-$pkgver
18prepare() {
19 local i
20 cd "$_builddir"
21 for i in $source; do
22 case $i in
23 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "$_builddir"
30 ./configure --prefix=/usr \
31 || return 1
32 make || return 1
33}
34
35package() {
36 cd "$_builddir"
37 make DESTDIR="$pkgdir" install || return 1
38}
39
40md5sums="14c33c2b9d1bd36d8507d55597c77991 edje-1.0.0.tar.gz"