aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-25 07:09:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-25 07:09:56 +0000
commit66f1463a36f397cc142f861d7327586ce9e59730 (patch)
treed864b930f9edd3c93a857c3c46892fe2a8a3ae00
parent151bdfe1775c0b9ed6782bde97c5e9fb5353d0d6 (diff)
downloadalpine_aports-66f1463a36f397cc142f861d7327586ce9e59730.tar.bz2
alpine_aports-66f1463a36f397cc142f861d7327586ce9e59730.tar.xz
alpine_aports-66f1463a36f397cc142f861d7327586ce9e59730.zip
main/imagemagick: upgrade to 6.7.0.0
and enable libwebp support
-rw-r--r--main/imagemagick/APKBUILD22
-rw-r--r--main/imagemagick/locale.patch61
2 files changed, 78 insertions, 5 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index d232ba27d7..0e6b686893 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -1,17 +1,28 @@
1# Contributor: Carlo Landmeter <clandmeter@gmail.com> 1# Contributor: Carlo Landmeter <clandmeter@gmail.com>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=imagemagick 3pkgname=imagemagick
4pkgver=6.6.9.9 4pkgver=6.7.0.0
5_pkgver=${pkgver%.*}-${pkgver##*.} 5_pkgver=${pkgver%.*}-${pkgver##*.}
6pkgrel=1 6pkgrel=0
7pkgdesc="A collection of tools and libraries for many image formats" 7pkgdesc="A collection of tools and libraries for many image formats"
8url="http://www.imagemagick.org/" 8url="http://www.imagemagick.org/"
9arch="all" 9arch="all"
10license="GPL" 10license="GPL"
11depends= 11depends=
12makedepends="zlib-dev libpng-dev jpeg-dev freetype-dev perl-dev ghostscript-dev" 12makedepends="zlib-dev libpng-dev jpeg-dev freetype-dev perl-dev ghostscript-dev
13 libwebp-dev"
13subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx" 14subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx"
14source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.gz" 15source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.gz
16 locale.patch"
17
18prepare() {
19 cd "$srcdir/ImageMagick-${_pkgver}"
20 for i in $source; do
21 case $i in
22 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
23 esac
24 done
25}
15 26
16build() { 27build() {
17 cd "$srcdir/ImageMagick-${_pkgver}" 28 cd "$srcdir/ImageMagick-${_pkgver}"
@@ -54,4 +65,5 @@ _cxx() {
54 mv "$pkgdir"/usr/lib/libMagick++.so.* "$subpkgdir"/usr/lib/ 65 mv "$pkgdir"/usr/lib/libMagick++.so.* "$subpkgdir"/usr/lib/
55} 66}
56 67
57md5sums="3b240b7316a96cd6a168c14fe670eafc ImageMagick-6.6.9-9.tar.gz" 68md5sums="f845395f6b1c849462c2d55357d8d863 ImageMagick-6.7.0-0.tar.gz
69d8aac6ac384d32184b21bbf0a0e8c57e locale.patch"
diff --git a/main/imagemagick/locale.patch b/main/imagemagick/locale.patch
new file mode 100644
index 0000000000..9d83f11693
--- /dev/null
+++ b/main/imagemagick/locale.patch
@@ -0,0 +1,61 @@
1From dcc53fb77f056ffb5c2eb66922b389af65adbfaf Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Wed, 25 May 2011 07:00:00 +0000
4Subject: [PATCH] uclibc locale
5
6uclibc might not have locale_t. We only activate the staic c_locale code
7when we have vprintf_l() which is the only time we will use it.
8---
9 magick/locale.c | 6 ++++++
10 1 files changed, 6 insertions(+), 0 deletions(-)
11
12diff --git a/magick/locale.c b/magick/locale.c
13index 4b84b2e..ee1c11b 100644
14--- a/magick/locale.c
15+++ b/magick/locale.c
16@@ -90,8 +90,10 @@ static SemaphoreInfo
17 static SplayTreeInfo
18 *locale_list = (SplayTreeInfo *) NULL;
19
20+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
21 static volatile locale_t
22 c_locale = (locale_t) NULL;
23+#endif
24
25 static volatile MagickBooleanType
26 instantiate_locale = MagickFalse;
27@@ -122,6 +124,7 @@ static MagickBooleanType
28 % locale_t AcquireCLocale(void)
29 %
30 */
31+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
32 static locale_t AcquireCLocale(void)
33 {
34 #if defined(MAGICKCORE_HAVE_NEWLOCALE)
35@@ -133,6 +136,7 @@ static locale_t AcquireCLocale(void)
36 #endif
37 return(c_locale);
38 }
39+#endif
40
41 /*
42 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
43@@ -155,6 +159,7 @@ static locale_t AcquireCLocale(void)
44 */
45 static void DestroyCLocale(void)
46 {
47+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
48 #if defined(MAGICKCORE_HAVE_NEWLOCALE)
49 if (c_locale != (locale_t) NULL)
50 freelocale(c_locale);
51@@ -163,6 +168,7 @@ static void DestroyCLocale(void)
52 _free_locale(c_locale);
53 #endif
54 c_locale=(locale_t) NULL;
55+#endif
56 }
57
58 /*
59--
601.7.5.2
61