aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-25 16:07:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-25 16:09:12 +0000
commit97fafd794f6f4b4574408e5cffa74d23c4deed72 (patch)
tree00b7074397db6cb76e0128fa99796da5ee74812b
parent9542db515b80865c7f3b474ed4c236ea513c2711 (diff)
downloadalpine_aports-97fafd794f6f4b4574408e5cffa74d23c4deed72.tar.bz2
alpine_aports-97fafd794f6f4b4574408e5cffa74d23c4deed72.tar.xz
alpine_aports-97fafd794f6f4b4574408e5cffa74d23c4deed72.zip
testing/e_dbus: new aport
Enlightenment's (Ecore) integration to DBus http://trac.enlightenment.org/e/wiki/E_Dbus
-rw-r--r--testing/e_dbus/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/e_dbus/APKBUILD b/testing/e_dbus/APKBUILD
new file mode 100644
index 0000000000..8cde465ec2
--- /dev/null
+++ b/testing/e_dbus/APKBUILD
@@ -0,0 +1,44 @@
1# Contributor: Natanael Copa <ncopa@alpinelinux.org>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=e_dbus
4pkgver=1.0.0
5pkgrel=0
6pkgdesc="Enlightenment's (Ecore) integration to DBus"
7url="http://trac.enlightenment.org/e/wiki/E_Dbus"
8arch="all"
9license="BSD"
10depends=
11depends_dev="dbus-dev eina-dev ecore-dev"
12makedepends="$depends_dev"
13install=""
14subpackages="$pkgname-dev"
15source="http://download.enlightenment.org/releases/e_dbus-$pkgver.tar.gz"
16
17_builddir="$srcdir"/e_dbus-$pkgver
18prepare() {
19 local i
20 cd "$_builddir"
21 for i in $source; do
22 case $i in
23 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "$_builddir"
30 ./configure --prefix=/usr \
31 --sysconfdir=/etc \
32 --mandir=/usr/share/man \
33 --infodir=/usr/share/info \
34 --localstatedir=/var \
35 || return 1
36 make || return 1
37}
38
39package() {
40 cd "$_builddir"
41 make DESTDIR="$pkgdir" install || return 1
42}
43
44md5sums="4a3031a41e7e33f843cf104bf84cd4ee e_dbus-1.0.0.tar.gz"