aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-15 12:57:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-15 14:32:38 +0000
commit0c96f83bef7f3cf30ffab693dd90126bb87e8ce1 (patch)
tree237d806ec5f037cd89ba8cb4658d52124533e4b6
parenta50fdbd9146b48006f82f69422e9c475d52a14d6 (diff)
downloadalpine_aports-0c96f83bef7f3cf30ffab693dd90126bb87e8ce1.tar.bz2
alpine_aports-0c96f83bef7f3cf30ffab693dd90126bb87e8ce1.tar.xz
alpine_aports-0c96f83bef7f3cf30ffab693dd90126bb87e8ce1.zip
main/xulrunner: upgrade to 6.0
-rw-r--r--main/xulrunner/0001-Use-C99-math-isfinite.patch39
-rw-r--r--main/xulrunner/APKBUILD20
-rw-r--r--main/xulrunner/mozilla-bsdiff-libbz2.patch33
-rw-r--r--main/xulrunner/mozjs-c99math.patch21
-rw-r--r--main/xulrunner/xpcom-c99math.patch10
5 files changed, 65 insertions, 58 deletions
diff --git a/main/xulrunner/0001-Use-C99-math-isfinite.patch b/main/xulrunner/0001-Use-C99-math-isfinite.patch
new file mode 100644
index 0000000000..b9ead9117c
--- /dev/null
+++ b/main/xulrunner/0001-Use-C99-math-isfinite.patch
@@ -0,0 +1,39 @@
1From f7c52ff6334ce158da23750e63655df41e73fc31 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Mon, 15 Aug 2011 07:57:16 +0000
4Subject: [PATCH] Use C99 math isfinite
5
6---
7 content/base/public/nsContentUtils.h | 2 +-
8 js/src/ctypes/CTypes.cpp | 2 +-
9 2 files changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/content/base/public/nsContentUtils.h b/content/base/public/nsContentUtils.h
12index a69d4ef..b4d8e67 100644
13--- a/content/base/public/nsContentUtils.h
14+++ b/content/base/public/nsContentUtils.h
15@@ -1994,7 +1994,7 @@ inline NS_HIDDEN_(PRBool) NS_FloatIsFinite(jsdouble f) {
16 #ifdef WIN32
17 return _finite(f);
18 #else
19- return finite(f);
20+ return isfinite(f);
21 #endif
22 }
23
24diff --git a/js/src/ctypes/CTypes.cpp b/js/src/ctypes/CTypes.cpp
25index 0644817..5dbb906 100644
26--- a/js/src/ctypes/CTypes.cpp
27+++ b/js/src/ctypes/CTypes.cpp
28@@ -467,7 +467,7 @@ static inline bool FloatIsFinite(jsdouble f) {
29 #ifdef WIN32
30 return _finite(f) != 0;
31 #else
32- return finite(f);
33+ return isfinite(f);
34 #endif
35 }
36
37--
381.7.6
39
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index c33e79cc3f..03ddc34a8d 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,8 +1,8 @@
1# Contributor: William Pitcock <nenolod@dereferenced.org> 1# Contributor: William Pitcock <nenolod@dereferenced.org>
2# Maintainer: William Pitcock <nenolod@dereferenced.org> 2# Maintainer: William Pitcock <nenolod@dereferenced.org>
3pkgname=xulrunner 3pkgname=xulrunner
4pkgver=5.0.1 4pkgver=6.0
5_ffoxver=5.0.1 5_ffoxver=6.0
6pkgrel=0 6pkgrel=0
7pkgdesc="runtime environment for xul-based applications" 7pkgdesc="runtime environment for xul-based applications"
8url="http://developer.mozilla.org/en/XULRunner" 8url="http://developer.mozilla.org/en/XULRunner"
@@ -55,8 +55,7 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
55 55
56 mozjs-c99math.patch 56 mozjs-c99math.patch
57 xpcom-c99math.patch 57 xpcom-c99math.patch
58 58 "
59 mozilla-bsdiff-libbz2.patch"
60 59
61_builddir="${srcdir}/mozilla-release" 60_builddir="${srcdir}/mozilla-release"
62prepare() { 61prepare() {
@@ -88,6 +87,11 @@ package() {
88 cd "$_builddir" 87 cd "$_builddir"
89 make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1 88 make -j1 DESTDIR="$pkgdir" -f client.mk install || return 1
90 89
90 # make install does not install xpt.py but its needed by firefox
91 mkdir -p "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin
92 cp xpcom/typelib/xpt/tools/xpt.py \
93 "$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin/
94
91 msg "Setting up compatibility symlinks..." 95 msg "Setting up compatibility symlinks..."
92 ln -sf /usr/lib/xulrunner-${pkgver}/libxul.so "${pkgdir}"/usr/lib/libxul.so 96 ln -sf /usr/lib/xulrunner-${pkgver}/libxul.so "${pkgdir}"/usr/lib/libxul.so
93 ln -sf /usr/lib/xulrunner-${pkgver}/libxpcom.so "${pkgdir}"/usr/lib/libxpcom.so 97 ln -sf /usr/lib/xulrunner-${pkgver}/libxpcom.so "${pkgdir}"/usr/lib/libxpcom.so
@@ -96,6 +100,7 @@ package() {
96 100
97dev() { 101dev() {
98 replaces="xulrunner" 102 replaces="xulrunner"
103 depends="xulrunner"
99 104
100 mkdir -p "${subpkgdir}"/usr/lib 105 mkdir -p "${subpkgdir}"/usr/lib
101 mv "${pkgdir}"/usr/lib/xulrunner-devel-${pkgver} "${subpkgdir}"/usr/lib 106 mv "${pkgdir}"/usr/lib/xulrunner-devel-${pkgver} "${subpkgdir}"/usr/lib
@@ -103,12 +108,11 @@ dev() {
103 mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include 108 mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
104} 109}
105 110
106md5sums="6d1f43e402cec84459a3d7f950bd5192 firefox-5.0.1.source.tar.bz2 111md5sums="1840185865a1a8975df4a3db59080ddc firefox-6.0.source.tar.bz2
107cc43a2bd96bd2395aa72d0bbb88e5594 mozconfig 112cc43a2bd96bd2395aa72d0bbb88e5594 mozconfig
10886d33a17286131d9ef4cdfb35ee56f1f fix-xulrunner-launcher.patch 11386d33a17286131d9ef4cdfb35ee56f1f fix-xulrunner-launcher.patch
10902c23dc4ebd88e445533314716331818 mozilla-pkgconfig.patch 11402c23dc4ebd88e445533314716331818 mozilla-pkgconfig.patch
11030053b8b5811cc0676bfe7d7d7ffaa4a xulrunner-jemalloc-aslr.patch 11530053b8b5811cc0676bfe7d7d7ffaa4a xulrunner-jemalloc-aslr.patch
111d38ecbb7bb31032d3e1ced8939e26abd xulrunner-mozalloc.patch 116d38ecbb7bb31032d3e1ced8939e26abd xulrunner-mozalloc.patch
112b187440207e773e9be606594d2c99216 mozjs-c99math.patch 117abbef7f783ad5d99a9cdbf9e358fafcd mozjs-c99math.patch
113128d37fab6fbcb1d0b994e8023e701e0 xpcom-c99math.patch 11868709c9aad5b7e46e63787fc648d7ae7 xpcom-c99math.patch"
11488c5b4db4e7910b7b99cdee96847c13d mozilla-bsdiff-libbz2.patch"
diff --git a/main/xulrunner/mozilla-bsdiff-libbz2.patch b/main/xulrunner/mozilla-bsdiff-libbz2.patch
deleted file mode 100644
index 52e4c92996..0000000000
--- a/main/xulrunner/mozilla-bsdiff-libbz2.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1# HG changeset patch
2# User Mike Hommey <mh+mozilla@glandium.org>
3# Date 1302680663 -7200
4# Node ID 0583d58b20a3a0789c46f19ed505cb6e96602ec9
5# Parent 0138798a072ad15edce15d614923a03256946218
6Bug 644692 - Fix bsdiff build failure with system bzip2. r=ted
7
8diff --git a/other-licenses/bsdiff/Makefile.in b/other-licenses/bsdiff/Makefile.in
9--- a/other-licenses/bsdiff/Makefile.in
10+++ b/other-licenses/bsdiff/Makefile.in
11@@ -43,17 +43,21 @@ VPATH = @srcdir@
12
13 include $(DEPTH)/config/autoconf.mk
14
15 # This program is output to dist/host/bin because it is only needed by the
16 # build system and is not intended to be included in Mozilla distributions.
17 HOST_PROGRAM = mbsdiff$(BIN_SUFFIX)
18 HOST_CSRCS = bsdiff.c
19
20+ifdef MOZ_NATIVE_BZ2
21+HOST_LIBS += $(BZ2_LIBS)
22+else
23 HOST_LIBS += $(DIST)/host/lib/$(LIB_PREFIX)hostbz2.$(LIB_SUFFIX)
24+endif
25
26 ifneq (,$(filter WINCE WINNT,$(HOST_OS_ARCH)))
27 HOST_EXTRA_LIBS += $(call EXPAND_LIBNAME,Ws2_32)
28 endif
29
30 LOCAL_INCLUDES += -I$(topsrcdir)/toolkit/mozapps/update/updater
31
32 include $(topsrcdir)/config/rules.mk
33
diff --git a/main/xulrunner/mozjs-c99math.patch b/main/xulrunner/mozjs-c99math.patch
index fdf346e495..a4f81b62c7 100644
--- a/main/xulrunner/mozjs-c99math.patch
+++ b/main/xulrunner/mozjs-c99math.patch
@@ -1,14 +1,3 @@
1--- mozilla-1.9.2.orig/js/src/jsnum.h
2+++ mozilla-1.9.2/js/src/jsnum.h
3@@ -98,7 +98,7 @@
4 #ifdef WIN32
5 return _finite(d);
6 #else
7- return finite(d);
8+ return isfinite(d);
9 #endif
10 }
11
12--- mozilla-2.0.orig/js/src/ctypes/CTypes.cpp 1--- mozilla-2.0.orig/js/src/ctypes/CTypes.cpp
13+++ mozilla-2.0/js/src/ctypes/CTypes.cpp 2+++ mozilla-2.0/js/src/ctypes/CTypes.cpp
14@@ -464,7 +464,7 @@ 3@@ -464,7 +464,7 @@
@@ -20,14 +9,18 @@
20 #endif 9 #endif
21 } 10 }
22 11
23--- mozilla-2.0.orig/content/base/public/nsContentUtils.h 12--- ./content/base/public/nsContentUtils.h.orig
24+++ mozilla-2.0/content/base/public/nsContentUtils.h 13+++ ./content/base/public/nsContentUtils.h
25@@ -1942,7 +1942,7 @@ 14@@ -1994,7 +1994,11 @@
26 #ifdef WIN32 15 #ifdef WIN32
27 return _finite(f); 16 return _finite(f);
28 #else 17 #else
29- return finite(f); 18- return finite(f);
19+#ifdef _GLIBCXX_CMATH
20+ return std::isfinite(f);
21+#else
30+ return isfinite(f); 22+ return isfinite(f);
23+#endif
31 #endif 24 #endif
32 } 25 }
33 26
diff --git a/main/xulrunner/xpcom-c99math.patch b/main/xulrunner/xpcom-c99math.patch
index 955f964eb8..3222c7f206 100644
--- a/main/xulrunner/xpcom-c99math.patch
+++ b/main/xulrunner/xpcom-c99math.patch
@@ -1,11 +1,15 @@
1--- mozilla-release.orig/xpcom/ds/nsMathUtils.h 1--- ./xpcom/ds/nsMathUtils.h.orig
2+++ mozilla-release/xpcom/ds/nsMathUtils.h 2+++ ./xpcom/ds/nsMathUtils.h
3@@ -170,7 +170,7 @@ 3@@ -151,7 +151,11 @@
4 // NOTE: '!!' casts an int to bool without spamming MSVC warning C4800. 4 // NOTE: '!!' casts an int to bool without spamming MSVC warning C4800.
5 return !!_finite(d); 5 return !!_finite(d);
6 #else 6 #else
7- return finite(d); 7- return finite(d);
8+#ifdef _GLIBCXX_CMATH
9+ return std::isfinite(d);
10+#else
8+ return isfinite(d); 11+ return isfinite(d);
12+#endif
9 #endif 13 #endif
10 } 14 }
11 15