aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMika Havela <mika.havela@gmail.com>2011-08-13 15:02:45 +0000
committerMika Havela <mika.havela@gmail.com>2011-08-15 16:02:36 +0000
commit9f671feee05e2ac8da716d5a466cd4358a52cf3d (patch)
tree2dae0fb432734e5deb8db5f3865a4e7581655117
parent3a3fa35fadd11ac3025c02db19ce6a3cac3ee92d (diff)
downloadalpine_aports-9f671feee05e2ac8da716d5a466cd4358a52cf3d.tar.bz2
alpine_aports-9f671feee05e2ac8da716d5a466cd4358a52cf3d.tar.xz
alpine_aports-9f671feee05e2ac8da716d5a466cd4358a52cf3d.zip
testing/prosody: Upgrade to 0.8.2
Using original prosody.cfg.lua config and patch it
-rw-r--r--testing/prosody/APKBUILD11
-rw-r--r--testing/prosody/prosody.cfg.lua107
-rw-r--r--testing/prosody/prosody.cfg.lua.patch32
3 files changed, 38 insertions, 112 deletions
diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
index 0f7b02bc75..4672f435ba 100644
--- a/testing/prosody/APKBUILD
+++ b/testing/prosody/APKBUILD
@@ -1,18 +1,18 @@
1# Contributor: Mika Havela <mika.havela@gmail.com> 1# Contributor: Mika Havela <mika.havela@gmail.com>
2# Maintainer: Mika Havela <mika.havela@gmail.com> 2# Maintainer: Mika Havela <mika.havela@gmail.com>
3pkgname=prosody 3pkgname=prosody
4pkgver=0.8.1 4pkgver=0.8.2
5pkgrel=0 5pkgrel=0
6pkgdesc="Lua based Jabber/XMPP server" 6pkgdesc="Lua based Jabber/XMPP server"
7url="http://prosody.im/" 7url="http://prosody.im/"
8arch="all" 8arch="all"
9license="MIT" 9license="MIT"
10depends="lua-socket lua-expat" 10depends="lua-socket lua-expat lua-filesystem lua-sec"
11makedepends="lua-dev libidn-dev openssl-dev" 11makedepends="lua-dev libidn-dev openssl-dev"
12install="prosody.pre-install prosody.post-install" 12install="prosody.pre-install prosody.post-install"
13subpackages="" 13subpackages=""
14source="http://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz 14source="http://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz
15 $pkgname.cfg.lua 15 $pkgname.cfg.lua.patch
16 $pkgname.initd 16 $pkgname.initd
17 " 17 "
18 18
@@ -33,11 +33,12 @@ package() {
33 33
34 install -d "$pkgdir/var/log/prosody" || return 1 34 install -d "$pkgdir/var/log/prosody" || return 1
35 install -d "$pkgdir/var/run/prosody" || return 1 35 install -d "$pkgdir/var/run/prosody" || return 1
36 patch "$pkgdir/etc/prosody/prosody.cfg.lua" "$srcdir/prosody.cfg.lua.patch" || return 1
36 install -D -m755 "$srcdir"/"$pkgname".initd "$pkgdir"/etc/init.d/"$pkgname" 37 install -D -m755 "$srcdir"/"$pkgname".initd "$pkgdir"/etc/init.d/"$pkgname"
37 38
38 install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING 39 install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
39} 40}
40 41
41md5sums="2be3e9deed0b96f109efc5707d7728ba prosody-0.8.1.tar.gz 42md5sums="6e907bf0d0acf24f1011083020ba6ffb prosody-0.8.2.tar.gz
42f42039e5a342fe62cd7e491546338aaa prosody.cfg.lua 435a415bb85fb1e00a17cb3ad951e3b889 prosody.cfg.lua.patch
43c0e647e872e30f71fa03faab189ae287 prosody.initd" 44c0e647e872e30f71fa03faab189ae287 prosody.initd"
diff --git a/testing/prosody/prosody.cfg.lua b/testing/prosody/prosody.cfg.lua
deleted file mode 100644
index 99df66add6..0000000000
--- a/testing/prosody/prosody.cfg.lua
+++ /dev/null
@@ -1,107 +0,0 @@
1-- Prosody Configuration File
2--
3-- If it wasn't already obvious, -- starts a comment, and all text after it on
4-- a line is ignored by Prosody.
5--
6-- The config is split into sections, a global section, and one for each
7-- defined host that we serve. You can add as many host sections as you like.
8--
9-- Lists are written { "like", "this", "one" }
10-- Lists can also be of { 1, 2, 3 } numbers, etc.
11-- Either commas, or semi-colons; may be used as seperators.
12--
13-- A table is a list of values, except each value has a name. An example would
14-- be:
15--
16-- logging = { type = "html", directory = "/var/logs", rotate = "daily" }
17--
18-- Whitespace (that is tabs, spaces, line breaks) is mostly insignificant, so
19-- can
20-- be placed anywhere
21-- that you deem fitting.
22--
23-- Tip: You can check that the syntax of this file is correct when you have
24-- finished by running: luac -p prosody.cfg.lua
25-- If there are any errors, it will let you know what and where they are,
26-- otherwise it will keep quiet.
27--
28-- Good luck, and happy Jabbering!
29
30-- Global settings go in this section
31Host "*"
32 -- This is the list of modules Prosody will load on startup.
33 -- It looks for mod_modulename.lua in the plugins folder, so make sure that
34 -- exists too.
35 modules_enabled = {
36 -- Generally required
37 "roster"; -- Allow users to have a roster. Recommended ;)
38 "saslauth"; -- Authentication for clients and servers. Recommended
39 -- if you want to log in.
40 "tls"; -- Add support for secure TLS on c2s/s2s connections
41 "dialback"; -- s2s dialback support
42 "disco"; -- Service discovery
43
44 -- Not essential, but recommended
45 "private"; -- Private XML storage (for room bookmarks, etc.)
46 "vcard"; -- Allow users to set vCards
47
48 -- Nice to have
49 "legacyauth"; -- Legacy authentication. Only used by some old
50 -- clients and bots.
51 "version"; -- Replies to server version requests
52 "uptime"; -- Report how long server has been running
53 "time"; -- Let others know the time here on this server
54 "ping"; -- Replies to XMPP pings with pongs
55
56 -- Required for daemonizing and logging
57 "posix"; -- POSIX functionality, sends server to background,
58 -- enables syslog, etc.
59
60 -- Other specific functionality
61 "register"; -- Allow users to register on this server using a
62 -- client
63 --"console"; -- telnet to port 5582 (needs console_enabled = true)
64 --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
65 --"httpserver"; -- Serve static files from a directory over HTTP
66 }
67
68 -- These are the SSL/TLS-related settings. If you don't want to use
69 -- SSL/TLS, you may comment or remove this
70 --ssl = {
71 -- key = "/etc/prosody/certs/localhost.key";
72 -- certificate = "/etc/prosody/certs/localhost.cert";
73 --}
74
75 log = {
76 -- Log all error messages to prosody.err
77 { levels = { min = "error" }, to = "file", timestamps = true,
78 filename = "/var/log/prosody/prosody.err" };
79 -- Log everything of level "info" and higher (that is, all except
80 -- "debug" messages) to prosody.log
81 { levels = { min = "info" }, to = "file", timestamps = true,
82 filename = "/var/log/prosody/prosody.log" };
83 }
84
85 -- Required for proper daemonization support
86 pidfile = "/var/run/prosody/prosody.pid"
87
88-- This allows clients to connect to localhost. No harm in it.
89Host "localhost"
90
91-- Section for example.com
92-- (replace example.com with your domain name)
93Host "example.com"
94 -- Assign this host a certificate for TLS, otherwise it would use the one
95 -- set in the global section (if any).
96 -- Note that old-style SSL on port 5223 only supports one certificate, and
97 -- will always use the global one.
98 --ssl = {
99 -- key = "/etc/prosody/certs/example.com.key";
100 -- certificate = "/etc/prosody/certs/example.com.crt";
101 --}
102
103 enabled = false -- This will disable the host, preserving the config, but
104 -- denying connections
105
106-- Set up a MUC (multi-user chat) room server on conference.localhost:
107Component "conference.localhost" "muc"
diff --git a/testing/prosody/prosody.cfg.lua.patch b/testing/prosody/prosody.cfg.lua.patch
new file mode 100644
index 0000000000..ca1c9b331f
--- /dev/null
+++ b/testing/prosody/prosody.cfg.lua.patch
@@ -0,0 +1,32 @@
1--- prosody.cfg.lua.org
2+++ prosody.cfg.lua
3@@ -22,6 +22,9 @@
4 -- Example: admins = { "user1@example.com", "user2@example.net" }
5 admins = { }
6
7+daemonize = true;
8+pidfile = "/var/run/prosody/prosody.pid";
9+
10 -- Enable use of libevent for better performance under high load
11 -- For more information see: http://prosody.im/doc/libevent
12 --use_libevent = true;
13@@ -59,7 +62,7 @@
14 --"admin_telnet"; -- Opens telnet console interface on localhost port 5582
15
16 -- Other specific functionality
17- --"posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
18+ "posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
19 --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
20 --"httpserver"; -- Serve static files from a directory over HTTP
21 --"groups"; -- Shared roster support
22@@ -123,8 +126,8 @@
23 -- Logging configuration
24 -- For advanced logging see http://prosody.im/doc/logging
25 log = {
26- info = "prosody.log"; -- Change 'info' to 'debug' for verbose logging
27- error = "prosody.err";
28+ info = "/var/log/prosody.log"; -- Change 'info' to 'debug' for verbose logging
29+ error = "/var/log/prosody.err";
30 -- "*syslog"; -- Uncomment this for logging to syslog
31 -- "*console"; -- Log to the console, useful for debugging with daemonize=false
32 }