aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-08-15 15:51:05 +0300
committerTimo Teräs <timo.teras@iki.fi>2011-08-15 15:51:05 +0300
commita50fdbd9146b48006f82f69422e9c475d52a14d6 (patch)
treebb588e8ccfa20f3dc388c63c52784ee0bc9949b8
parentbc0bf19e19e4ec722cb05da08f29f8493bb6248b (diff)
downloadalpine_aports-a50fdbd9146b48006f82f69422e9c475d52a14d6.tar.bz2
alpine_aports-a50fdbd9146b48006f82f69422e9c475d52a14d6.tar.xz
alpine_aports-a50fdbd9146b48006f82f69422e9c475d52a14d6.zip
main/dahdi-linux-vserver: fix build error
-rw-r--r--main/dahdi-linux-vserver/APKBUILD6
-rw-r--r--main/dahdi-linux-vserver/zaphfc-dahdi-2.5.0.patch18
2 files changed, 18 insertions, 6 deletions
diff --git a/main/dahdi-linux-vserver/APKBUILD b/main/dahdi-linux-vserver/APKBUILD
index 6e52ce9ff8..7b5cb6d000 100644
--- a/main/dahdi-linux-vserver/APKBUILD
+++ b/main/dahdi-linux-vserver/APKBUILD
@@ -31,9 +31,11 @@ subpackages="$pkgname-dev"
31source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$_dahdiver.tar.gz 31source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$_dahdiver.tar.gz
32 dahdi-depmod.patch 32 dahdi-depmod.patch
33 dahdi-bri_dchan.patch 33 dahdi-bri_dchan.patch
34 dahdi-2.5.0-bri-fixes.patch
34 dahdi-zaphfc.patch 35 dahdi-zaphfc.patch
35 zaphfc-dahdi-flortz.diff 36 zaphfc-dahdi-flortz.diff
36 zaphfc-dahdi-2.4.0.patch 37 zaphfc-dahdi-2.4.0.patch
38 zaphfc-dahdi-2.5.0.patch
37 " 39 "
38 40
39prepare() { 41prepare() {
@@ -77,6 +79,8 @@ dev() {
77md5sums="449f6591ccedb68937b5b30cbd37cea3 dahdi-linux-2.5.0.tar.gz 79md5sums="449f6591ccedb68937b5b30cbd37cea3 dahdi-linux-2.5.0.tar.gz
78c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch 80c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
793bb419ac598534cd4ad5248f23656001 dahdi-bri_dchan.patch 813bb419ac598534cd4ad5248f23656001 dahdi-bri_dchan.patch
829088ee5cd24f94b7f90c24e5ed6071e0 dahdi-2.5.0-bri-fixes.patch
80a822c092f0548cd13f5e8d8cba053af6 dahdi-zaphfc.patch 83a822c092f0548cd13f5e8d8cba053af6 dahdi-zaphfc.patch
81291c5c44c86ab02443a742415461ddca zaphfc-dahdi-flortz.diff 84291c5c44c86ab02443a742415461ddca zaphfc-dahdi-flortz.diff
820fdcd8c8c93bc1fe33c0af12b6cc6b05 zaphfc-dahdi-2.4.0.patch" 850fdcd8c8c93bc1fe33c0af12b6cc6b05 zaphfc-dahdi-2.4.0.patch
86fc49cf22258d63487a83560385c3f6fa zaphfc-dahdi-2.5.0.patch"
diff --git a/main/dahdi-linux-vserver/zaphfc-dahdi-2.5.0.patch b/main/dahdi-linux-vserver/zaphfc-dahdi-2.5.0.patch
index 37a1e76ba8..883a634847 100644
--- a/main/dahdi-linux-vserver/zaphfc-dahdi-2.5.0.patch
+++ b/main/dahdi-linux-vserver/zaphfc-dahdi-2.5.0.patch
@@ -1,8 +1,16 @@
1Index: dahdi-linux-2.5.0/drivers/dahdi/zaphfc.c 1Index: dahdi-linux-2.5.0/drivers/dahdi/zaphfc.c
2=================================================================== 2===================================================================
3--- dahdi-linux-2.5.0.orig/drivers/dahdi/zaphfc.c 2011-08-15 14:29:51.000000000 +0300 3--- dahdi-linux-2.5.0.orig/drivers/dahdi/zaphfc.c 2011-08-15 15:49:47.000000000 +0300
4+++ dahdi-linux-2.5.0/drivers/dahdi/zaphfc.c 2011-08-15 14:30:11.000000000 +0300 4+++ dahdi-linux-2.5.0/drivers/dahdi/zaphfc.c 2011-08-15 15:50:07.000000000 +0300
5@@ -616,7 +616,7 @@ 5@@ -26,6 +26,7 @@
6 #include <linux/init.h>
7 #include <linux/interrupt.h>
8 #include <linux/delay.h>
9+#include <linux/sched.h>
10 #include <dahdi/kernel.h>
11 #include "zaphfc.h"
12
13@@ -616,7 +617,7 @@
6 return 0; 14 return 0;
7 } 15 }
8 16
@@ -11,7 +19,7 @@ Index: dahdi-linux-2.5.0/drivers/dahdi/zaphfc.c
11 struct dahdi_hfc *zthfc = container_of(span, struct dahdi_hfc, span); 19 struct dahdi_hfc *zthfc = container_of(span, struct dahdi_hfc, span);
12 struct hfc_card *hfctmp = zthfc->card; 20 struct hfc_card *hfctmp = zthfc->card;
13 int alreadyrunning; 21 int alreadyrunning;
14@@ -653,12 +653,12 @@ 22@@ -653,12 +654,12 @@
15 return 0; 23 return 0;
16 } 24 }
17 25
@@ -26,7 +34,7 @@ Index: dahdi-linux-2.5.0/drivers/dahdi/zaphfc.c
26 span->lineconfig = lc->lineconfig; 34 span->lineconfig = lc->lineconfig;
27 return 0; 35 return 0;
28 } 36 }
29@@ -699,7 +699,6 @@ 37@@ -699,7 +700,6 @@
30 zthfc->span.deflaw = DAHDI_LAW_ALAW; 38 zthfc->span.deflaw = DAHDI_LAW_ALAW;
31 zthfc->span.linecompat = DAHDI_CONFIG_AMI | DAHDI_CONFIG_CCS; // <--- this is really BS 39 zthfc->span.linecompat = DAHDI_CONFIG_AMI | DAHDI_CONFIG_CCS; // <--- this is really BS
32 zthfc->span.offset = 0; 40 zthfc->span.offset = 0;