aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-24 19:31:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-24 19:54:29 +0000
commit0ae0f839c4f2558983a493c7067fc8f9f7e80a6b (patch)
tree132b2e4687f9055b777f79c249c47d01098cae52
parent9edcf6dad4ec052978a787db19b998d918bea10e (diff)
downloadalpine_aports-0ae0f839c4f2558983a493c7067fc8f9f7e80a6b.tar.bz2
alpine_aports-0ae0f839c4f2558983a493c7067fc8f9f7e80a6b.tar.xz
alpine_aports-0ae0f839c4f2558983a493c7067fc8f9f7e80a6b.zip
testing/keyutils: new aport
Linux Key Management Utilities http://people.redhat.com/~dhowells/keyutils/
-rw-r--r--testing/keyutils/APKBUILD58
-rw-r--r--testing/keyutils/keyutils-no-key.dns_resolver.patch27
2 files changed, 85 insertions, 0 deletions
diff --git a/testing/keyutils/APKBUILD b/testing/keyutils/APKBUILD
new file mode 100644
index 0000000000..8a004e38da
--- /dev/null
+++ b/testing/keyutils/APKBUILD
@@ -0,0 +1,58 @@
1# Contributor: Natanael Copa <ncopa@alpinelinux.org>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=keyutils
4pkgver=1.5.2
5pkgrel=0
6pkgdesc="Linux Key Management Utilities"
7url="http://people.redhat.com/~dhowells/keyutils/"
8arch="all"
9license="GPLv2+ LGPLv2+"
10depends=""
11makedepends=""
12install=""
13subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
14source="http://people.redhat.com/~dhowells/keyutils/keyutils-$pkgver.tar.bz2
15 keyutils-no-key.dns_resolver.patch"
16
17_builddir="$srcdir"/keyutils-$pkgver
18prepare() {
19 local i
20 cd "$_builddir"
21 for i in $source; do
22 case $i in
23 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "$_builddir"
30 make -j1 \
31 NO_ARLIB=1 \
32 LIBDIR=/lib \
33 USRLIBDIR=/usr/lib \
34 VERSION=$pkgver \
35 RELEASE=-r$pkgrel \
36 CFLAGS="$CFLAGS" \
37 NO_GLIBC_KEYERR=1 \
38 || return 1
39}
40
41package() {
42 cd "$_builddir"
43 make DESTDIR="$pkgdir" \
44 NO_ARLIB=1 \
45 LIBDIR=/lib \
46 USRLIBDIR=/usr/lib \
47 install || return 1
48 rm -f "$pkgdir"/usr/lib/*.la
49}
50
51libs() {
52 pkgdesc="Key utilities library"
53 mkdir -p "$subpkgdir"
54 mv "$pkgdir"/lib "$subpkgdir"/
55}
56
57md5sums="19811ee31f683058a9aae3e6a3a23a7f keyutils-1.5.2.tar.bz2
585884b0e3fa9609d484ad6f073810b21a keyutils-no-key.dns_resolver.patch"
diff --git a/testing/keyutils/keyutils-no-key.dns_resolver.patch b/testing/keyutils/keyutils-no-key.dns_resolver.patch
new file mode 100644
index 0000000000..512b04da67
--- /dev/null
+++ b/testing/keyutils/keyutils-no-key.dns_resolver.patch
@@ -0,0 +1,27 @@
1--- ./Makefile.orig
2+++ ./Makefile
3@@ -84,7 +84,7 @@
4 # Normal build rule
5 #
6 ###############################################################################
7-all: $(DEVELLIB) keyctl request-key key.dns_resolver
8+all: $(DEVELLIB) keyctl request-key
9
10 ###############################################################################
11 #
12@@ -150,7 +150,6 @@
13 $(INSTALL) -D keyctl $(DESTDIR)$(BINDIR)/keyctl
14 $(INSTALL) -D request-key $(DESTDIR)$(SBINDIR)/request-key
15 $(INSTALL) -D request-key-debug.sh $(DESTDIR)$(SHAREDIR)/request-key-debug.sh
16- $(INSTALL) -D key.dns_resolver $(DESTDIR)$(SBINDIR)/key.dns_resolver
17 $(INSTALL) -D -m 0644 request-key.conf $(DESTDIR)$(ETCDIR)/request-key.conf
18 $(INSTALL) -D -m 0644 keyctl.1 $(DESTDIR)$(MAN1)/keyctl.1
19 $(INSTALL) -D -m 0644 keyctl_chown.3 $(DESTDIR)$(MAN3)/keyctl_chown.3
20@@ -180,7 +179,6 @@
21 $(LNS) recursive_key_scan.3 $(DESTDIR)$(MAN3)/recursive_session_key_scan.3
22 $(INSTALL) -D -m 0644 request-key.conf.5 $(DESTDIR)$(MAN5)/request-key.conf.5
23 $(INSTALL) -D -m 0644 request-key.8 $(DESTDIR)$(MAN8)/request-key.8
24- $(INSTALL) -D -m 0644 key.dns_resolver.8 $(DESTDIR)$(MAN8)/key.dns_resolver.8
25 $(INSTALL) -D -m 0644 keyutils.h $(DESTDIR)$(INCLUDEDIR)/keyutils.h
26
27 ###############################################################################