aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Godec <danilo.godec@agenda.si>2011-08-23 13:16:04 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-23 12:27:59 +0000
commit74c5bedf5008b93ccd50312d4a25b7f0b86d0e0b (patch)
treeed013dc9a1deeff0c11f3e1ec94aab1455b01087
parent53f5db04542cb6f8816a68ab6595720a12a01305 (diff)
downloadalpine_aports-74c5bedf5008b93ccd50312d4a25b7f0b86d0e0b.tar.bz2
alpine_aports-74c5bedf5008b93ccd50312d4a25b7f0b86d0e0b.tar.xz
alpine_aports-74c5bedf5008b93ccd50312d4a25b7f0b86d0e0b.zip
haveged - new aport. haveged is a daemon that feeds the /dev/random pool on Linux.
-rw-r--r--testing/haveged/APKBUILD50
-rw-r--r--testing/haveged/haveged.confd5
-rw-r--r--testing/haveged/haveged.initd18
3 files changed, 73 insertions, 0 deletions
diff --git a/testing/haveged/APKBUILD b/testing/haveged/APKBUILD
new file mode 100644
index 0000000000..7ddc258bd3
--- /dev/null
+++ b/testing/haveged/APKBUILD
@@ -0,0 +1,50 @@
1# Contributor: Danilo Godec <danilo.godec@agenda.si>
2# Maintainer:
3pkgname=haveged
4pkgver=1.2
5pkgrel=0
6pkgdesc="haveged is a daemon that feeds the /dev/random pool on Linux"
7url="http://freshmeat.net/projects/haveged"
8arch="all"
9license="GPL"
10depends=""
11depends_dev=""
12makedepends="$depends_dev"
13install=""
14subpackages="$pkgname-doc"
15source="saveas-http://freshmeat.net/urls/d3425b56b35b00df22090e077d802c1c/$pkgname-$pkgver.tar.gz haveged.initd haveged.confd"
16
17_builddir="$srcdir"/$pkgname-$pkgver
18prepare() {
19 local i
20 cd "$_builddir"
21 for i in $source; do
22 case $i in
23 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "$_builddir"
30 ./configure --prefix /usr --sysconfdir /etc
31 make || return 1
32 make check || return 1
33}
34
35package() {
36 cd "$_builddir"
37 make DESTDIR="$pkgdir" install
38 install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
39 install -Dm644 AUTHORS "$pkgdir"/usr/share/doc/$pkgname/AUTHORS
40 install -Dm644 ChangeLog "$pkgdir"/usr/share/doc/$pkgname/ChangeLog
41 install -Dm644 INSTALL "$pkgdir"/usr/share/doc/$pkgname/INSTALL
42 install -Dm644 NEWS "$pkgdir"/usr/share/doc/$pkgname/NEWS
43 install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
44 install -Dm755 "$srcdir"/haveged.initd "$pkgdir"/etc/init.d/haveged
45 install -Dm644 "$srcdir"/haveged.confd "$pkgdir"/etc/conf.d/haveged
46}
47
48md5sums="dc961f36c065239f2ddeeb840ddf9ec0 haveged-1.2.tar.gz
490718d29f820b878a311e939b3682935c haveged.initd
50242300ea7948a16018d1b0f77fb5ec96 haveged.confd"
diff --git a/testing/haveged/haveged.confd b/testing/haveged/haveged.confd
new file mode 100644
index 0000000000..9ee6c61776
--- /dev/null
+++ b/testing/haveged/haveged.confd
@@ -0,0 +1,5 @@
1# Config file for /etc/init.d/haveged
2
3# Any extra options you want to pass to haveged
4# on start-up should be put here.
5HAVEGED_OPTS=""
diff --git a/testing/haveged/haveged.initd b/testing/haveged/haveged.initd
new file mode 100644
index 0000000000..d8b2fadbf9
--- /dev/null
+++ b/testing/haveged/haveged.initd
@@ -0,0 +1,18 @@
1#!/sbin/runscript
2
3depend() {
4 need net
5}
6
7start() {
8 ebegin "Starting haveged"
9 start-stop-daemon --start --quiet --exec /usr/sbin/haveged -- ${HAVEGED_OPTS}
10 eend $?
11}
12
13stop() {
14 ebegin "Stopping haveged"
15 start-stop-daemon --stop --quiet --pidfile /var/run/haveged.pid
16 result=$?
17 eend $result
18}