aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-23 06:31:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-23 06:31:33 +0000
commit94193c1044f516baae20c506d2cf61947273b8d5 (patch)
tree99f400f09bd72e697bb646ed40c8948a5f6b0082
parent420fc4f8e231b15e000124b357e8a97a41d32694 (diff)
downloadalpine_aports-94193c1044f516baae20c506d2cf61947273b8d5.tar.bz2
alpine_aports-94193c1044f516baae20c506d2cf61947273b8d5.tar.xz
alpine_aports-94193c1044f516baae20c506d2cf61947273b8d5.zip
main/php: fix crypt() md5 hashing
https://bugs.php.net/bug.php?id=55439
-rw-r--r--main/php/APKBUILD4
-rw-r--r--main/php/php-crypt-fix-r315218.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index 3acdbf7ce1..2f0c8d698e 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -3,7 +3,7 @@
3pkgname=php 3pkgname=php
4pkgver=5.3.7 4pkgver=5.3.7
5_suhosinver=5.3.7-0.9.10 5_suhosinver=5.3.7-0.9.10
6pkgrel=0 6pkgrel=1
7pkgdesc="The PHP language runtime engine" 7pkgdesc="The PHP language runtime engine"
8url="http://www.php.net/" 8url="http://www.php.net/"
9arch="all" 9arch="all"
@@ -73,6 +73,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-common $pkgname-cgi
73# http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz 73# http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz
74source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2 74source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2
75 suhosin-patch-${_suhosinver}.patch 75 suhosin-patch-${_suhosinver}.patch
76 php-crypt-fix-r315218.patch
76 php-fpm.initd 77 php-fpm.initd
77 php5-module.conf 78 php5-module.conf
78 " 79 "
@@ -426,5 +427,6 @@ pdo_dblib() { _mv_ext pdo_dblib "php-pdo freetds"; }
426 427
427md5sums="2d47d003c96de4e88863ff38da61af33 php-5.3.7.tar.bz2 428md5sums="2d47d003c96de4e88863ff38da61af33 php-5.3.7.tar.bz2
4288bd8840465d6bcd8e1e5d2cec80a1bfc suhosin-patch-5.3.7-0.9.10.patch 4298bd8840465d6bcd8e1e5d2cec80a1bfc suhosin-patch-5.3.7-0.9.10.patch
43015464f965b6957c19684c992c669e1c2 php-crypt-fix-r315218.patch
4298f2bb2b744a2de50025842cb51fb6a3a php-fpm.initd 4318f2bb2b744a2de50025842cb51fb6a3a php-fpm.initd
43067719f428f44ec004da18705cbabe2ee php5-module.conf" 43267719f428f44ec004da18705cbabe2ee php5-module.conf"
diff --git a/main/php/php-crypt-fix-r315218.patch b/main/php/php-crypt-fix-r315218.patch
new file mode 100644
index 0000000000..aaf688a2fc
--- /dev/null
+++ b/main/php/php-crypt-fix-r315218.patch
@@ -0,0 +1,13 @@
1Index: php-src/trunk/ext/standard/php_crypt_r.c
2===================================================================
3--- trunk/ext/standard/php_crypt_r.c (revision 315217)
4+++ trunk/ext/standard/php_crypt_r.c (revision 315218)
5@@ -377,7 +377,7 @@
6 /* Now make the output string */
7 memcpy(passwd, MD5_MAGIC, MD5_MAGIC_LEN);
8 strlcpy(passwd + MD5_MAGIC_LEN, sp, sl + 1);
9- strlcat(passwd, "$", 1);
10+ strcat(passwd, "$");
11
12 PHP_MD5Final(final, &ctx);
13