aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-26 11:30:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-26 11:30:02 +0000
commit27122b883948bc635037f2ffbfe78243cfa5de5e (patch)
tree224308bab6d57bffa6c86f830c7c059093f5356b
parentefcd7ef99b94fa79dd054e99cba9175eaa557fb1 (diff)
downloadalpine_aports-27122b883948bc635037f2ffbfe78243cfa5de5e.tar.bz2
alpine_aports-27122b883948bc635037f2ffbfe78243cfa5de5e.tar.xz
alpine_aports-27122b883948bc635037f2ffbfe78243cfa5de5e.zip
main/linux-grsec: fix constify in makefile
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/makefile-constify.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 60813e21fe..60fd1b1d24 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
4pkgname=linux-${_flavor} 4pkgname=linux-${_flavor}
5pkgver=3.0.3 5pkgver=3.0.3
6_kernver=3.0 6_kernver=3.0
7pkgrel=1 7pkgrel=2
8pkgdesc="Linux kernel with grsecurity" 8pkgdesc="Linux kernel with grsecurity"
9url=http://grsecurity.net 9url=http://grsecurity.net
10depends="mkinitfs linux-firmware" 10depends="mkinitfs linux-firmware"
@@ -17,6 +17,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-$_kernver.tar.bz2
17 grsecurity-2.2.2-3.0.3-201108251825.patch 17 grsecurity-2.2.2-3.0.3-201108251825.patch
18 18
19 0004-arp-flush-arp-cache-on-device-change.patch 19 0004-arp-flush-arp-cache-on-device-change.patch
20 makefile-constify.patch
20 21
21 kernelconfig.x86 22 kernelconfig.x86
22 kernelconfig.x86_64 23 kernelconfig.x86_64
@@ -140,5 +141,6 @@ md5sums="398e95866794def22b12dfbc15ce89c0 linux-3.0.tar.bz2
1401757786b9a9ffbd48ad9642199ff5bd7 patch-3.0.3.bz2 1411757786b9a9ffbd48ad9642199ff5bd7 patch-3.0.3.bz2
141dbf71c02960bdb9e047ed6ccd61e108e grsecurity-2.2.2-3.0.3-201108251825.patch 142dbf71c02960bdb9e047ed6ccd61e108e grsecurity-2.2.2-3.0.3-201108251825.patch
142776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch 143776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
144d948f4dc51ed32f86e9e75d61680597f makefile-constify.patch
143406e62e430cee7ba3bb37be341d9ff3e kernelconfig.x86 145406e62e430cee7ba3bb37be341d9ff3e kernelconfig.x86
1446957efc9f017c59b05aa0a2e4167255e kernelconfig.x86_64" 1466957efc9f017c59b05aa0a2e4167255e kernelconfig.x86_64"
diff --git a/main/linux-grsec/makefile-constify.patch b/main/linux-grsec/makefile-constify.patch
new file mode 100644
index 0000000000..679bd1ab2d
--- /dev/null
+++ b/main/linux-grsec/makefile-constify.patch
@@ -0,0 +1,10 @@
1--- ./Makefile.orig
2+++ ./Makefile
3@@ -1383,6 +1383,7 @@
4 $(module-dirs): crmodverdir $(objtree)/Module.symvers
5 $(Q)$(MAKE) $(build)=$(patsubst _module_%,%,$@)
6
7+modules: KBUILD_CFLAGS += $(CONSTIFY_PLUGIN) $(STACKLEAK_PLUGIN)
8 modules: $(module-dirs)
9 @$(kecho) ' Building modules, stage 2.';
10 $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost