aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-24 19:03:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-24 19:54:29 +0000
commit9edcf6dad4ec052978a787db19b998d918bea10e (patch)
tree3235f0bed3fcde4205a55cdb9f697d000d881b77
parentd69119e2ffe536055809ddd5fbd924a1d3ff8ea0 (diff)
downloadalpine_aports-9edcf6dad4ec052978a787db19b998d918bea10e.tar.bz2
alpine_aports-9edcf6dad4ec052978a787db19b998d918bea10e.tar.xz
alpine_aports-9edcf6dad4ec052978a787db19b998d918bea10e.zip
testing/libnfsidmap: new aport
NFSv4 User and Group ID Mapping Library http://www.citi.umich.edu/projects/nfsv4/linux/
-rw-r--r--testing/libnfsidmap/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/libnfsidmap/APKBUILD b/testing/libnfsidmap/APKBUILD
new file mode 100644
index 0000000000..d927d47217
--- /dev/null
+++ b/testing/libnfsidmap/APKBUILD
@@ -0,0 +1,49 @@
1# Contributor: Natanael Copa <ncopa@alpinelinux.org>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=libnfsidmap
4pkgver=0.24
5pkgrel=0
6pkgdesc="NFSv4 User and Group ID Mapping Library"
7url="http://www.citi.umich.edu/projects/nfsv4/linux/"
8arch="all"
9license="BSD"
10depends=""
11makedepends="openldap-dev"
12install=""
13subpackages="$pkgname-dev $pkgname-doc $pkgname-ldap"
14source="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/libnfsidmap-$pkgver.tar.gz"
15
16_builddir="$srcdir"/libnfsidmap-$pkgver
17prepare() {
18 local i
19 cd "$_builddir"
20 for i in $source; do
21 case $i in
22 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
23 esac
24 done
25}
26
27build() {
28 cd "$_builddir"
29 ./configure --prefix=/usr \
30 --disable-static \
31 || return 1
32 make || return 1
33}
34
35package() {
36 cd "$_builddir"
37 make DESTDIR="$pkgdir" install || return 1
38 rm -f "$pkgdir"/usr/lib/*.la \
39 "$pkgdir"/usr/lib/$pkgname/*.la || return 1
40 install -D -m644 idmapd.conf "$pkgdir"/etc/idmapd.conf
41}
42
43ldap() {
44 pkgdesc="LDAP plugin for $pkgname"
45 mkdir -p "$subpkgdir"/usr/lib/$pkgname
46 mv "$pkgdir"/usr/lib/$pkgname/*ldap* "$subpkgdir"/usr/lib/$pkgname/
47}
48
49md5sums="d71a1ee9881d5b5814ff3ec41256937d libnfsidmap-0.24.tar.gz"